View Issue Details

IDProjectCategoryView StatusLast Update
0005208The Dark ModGUIpublic24.04.2021 14:11
Reportert405 Assigned Tocabalistic  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSLinux 
Product VersionTDM 2.07 
Fixed in VersionTDM 2.10 
Summary0005208: Support for extra mouse buttons
DescriptionIt would be very convenient to be able to map extra mouse buttons to actions.

The most basic use-case would be to map the usual forward/backward buttons to cycling inventory, for example.

This would be even more useful for mice with more than 6 buttons.
TagsNo tags attached.

Activities

cabalistic

cabalistic

03.05.2020 11:13

developer   ~0012448

This is on Linux, I presume? Yeah, the input handling there is... ancient.
t405

t405

03.05.2020 23:54

reporter   ~0012453

cabalistic: yes, linux.

Is anybody working on this? If I wanted to jump into development, how can I start?
MirceaKitsune

MirceaKitsune

12.03.2021 18:10

reporter   ~0013784

I'd like to note that this bug is of big importance: I'm trying to introduce the game to someone close (also a Linux user). He needs to use a mouse with special buttons for gaming due to medical reasons... he can only play FPS with the mouse, no WASD keys but special mouse buttons for movement. If non-standard mouse keys can't be mapped, this is a game we won't be able to enjoy together. I showed him videos of TDM and he said he likes it, but this will need to be solved in some form before he can play. I hope the developers can at least find a quick solution in the meantime, before a deeper rewrite of the input code if one is needed. Thank you.
cabalistic

cabalistic

15.04.2021 20:40

developer   ~0013858

An experimental build with GLFW is now available, see:
https://forums.thedarkmod.com/index.php?/topic/20889-linux-testers-needed-new-window-management-and-input-handling/

In theory, GLFW should support up to 8 mouse buttons, which coincidentally is also the hard limit for what the engine supports. If you need more buttons, you'll have to use a keyboard mapping tool, as the effort to increase that engine limit would be substantial...
MirceaKitsune

MirceaKitsune

24.04.2021 13:52

reporter   ~0013902

Does 8 mouse buttons mean left / right click + mouse wheel scrolling + mouse wheel sideways click + backward / forward buttons? If so that's pretty much the existing limitation, potentially two buttons more since only previous / next didn't work for me. Those 8 buttons are all standard on modern mice: I was hoping something could be done for ones with more special buttons too if possible. This is a welcome improvement none the less, I will follow that thread to see how the new system goes, thanks for sharing this good news.
cabalistic

cabalistic

24.04.2021 14:10

developer   ~0013903

No, it means 8 physical buttons. Scroll is treated separately, but the engine only supports vertical scrolling. I can confirm that all 5 buttons on my mouse are working - left, right, middle and forward/backward. I don't have any mouse with more than those buttons, so I can't test the final three buttons. However, even if they are not working, there's probably nothing (reasonable) left to do about it...
cabalistic

cabalistic

24.04.2021 14:11

developer   ~0013904

Committed with revision 9310.

Issue History

Date Modified Username Field Change
03.04.2020 21:40 t405 New Issue
03.05.2020 11:13 cabalistic Note Added: 0012448
03.05.2020 23:51 t405 OS => Linux
03.05.2020 23:51 t405 Platform => Linux
03.05.2020 23:54 t405 Note Added: 0012453
18.02.2021 15:41 stgatilov Assigned To => cabalistic
18.02.2021 15:41 stgatilov Status new => assigned
12.03.2021 18:10 MirceaKitsune Note Added: 0013784
15.04.2021 20:40 cabalistic Note Added: 0013858
15.04.2021 20:41 cabalistic Status assigned => feedback
24.04.2021 13:52 MirceaKitsune Note Added: 0013902
24.04.2021 14:10 cabalistic Note Added: 0013903
24.04.2021 14:11 cabalistic Status feedback => resolved
24.04.2021 14:11 cabalistic Resolution open => fixed
24.04.2021 14:11 cabalistic Fixed in Version => TDM 2.10
24.04.2021 14:11 cabalistic Note Added: 0013904