View Issue Details

IDProjectCategoryView StatusLast Update
0005210DarkRadiantGUIpublic07.04.2020 04:16
Reporterorbweaver Assigned Toorbweaver  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.7.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0005210: Difficulty dialog shows string table entries instead of difficulty names
DescriptionSince the mod switched to string-table based translation, the difficulty names in DarkRadiant are displayed only as string table entries rather than user-friendly names like "Easy" and "Difficulty".
TagsNo tags attached.

Activities

orbweaver

orbweaver

06.04.2020 20:10

developer   ~0012336

As of 2b2c39d10e18b0d44ba9822742a1bf4bac3dda1f, difficulty names are now translated (only) into English based on a simple lookup table in the .game file.

Related Changesets

DarkRadiant: master 2b2c39d1

2020-03-02 20:55:07

orbweaver

Details Diff
Show useful difficulty names in the Difficulty editor

The default difficulty names are contained within the 'difficultyMenu' entity
def stored inside the mod data itself; however these names are intended to be
translated using the mod-specific translation system, which is not read or
processed by DarkRadiant. Therefore the names actually shown in the GUI were
meaningless string table entries like '#str_03000', rather than the
user-friendly names like 'Easy'.

Rather than try to support the entire mod translation system, which would be a
massive task, a simple string table lookup is performed based on the contents
of additional <string> nodes which have been added to the darkmod.game file.
Affected Issues
0005210
mod - install/games/darkmod.game Diff File
mod - libs/gamelib.h Diff File
mod - plugins/dm.difficulty/DifficultySettingsManager.cpp Diff File

DarkRadiant: master 84cbe47e

2020-03-31 20:11:55

orbweaver

Details Diff
Refactor difficulty name translation into new class

New class ModDifficultyNames handles looking up mod-specific difficult name
defaults and their translations in the .game file.
Affected Issues
0005210
mod - plugins/dm.difficulty/DifficultySettingsManager.cpp Diff File

Issue History

Date Modified Username Field Change
06.04.2020 20:09 orbweaver New Issue
06.04.2020 20:09 orbweaver Status new => assigned
06.04.2020 20:09 orbweaver Assigned To => orbweaver
06.04.2020 20:10 orbweaver Status assigned => resolved
06.04.2020 20:10 orbweaver Resolution open => fixed
06.04.2020 20:10 orbweaver Fixed in Version => 2.8.0
06.04.2020 20:10 orbweaver Note Added: 0012336
07.04.2020 04:11 greebo Changeset attached => DarkRadiant master 84cbe47e
07.04.2020 04:16 greebo Changeset attached => DarkRadiant master 2b2c39d1