View Issue Details

IDProjectCategoryView StatusLast Update
0005213The Dark ModTDM Updaterpublic03.05.2020 18:55
Reporterstgatilov Assigned Tostgatilov  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 2.08 
Target VersionTDM 2.08Fixed in VersionTDM 2.09 
Summary0005213: tdm_update: better handling of permission errors
DescriptionUnfortunately, Windows users are too used to putting everything into Program Files.

Since writes into Program Files are usually forbidden to normal users, they cannot install TDM there.
Some users run updater with elevated/admin rights because sometimes it helps, and succeed in installing TDM there.
However after that the game is not functioning correctly because they run it as normal user, but the directory is still writable by admins only.
Steps To ReproduceWait for a few years and monitor new threads in Tech Support forum =)
Additional InformationSee one example on forums:
  https://forums.thedarkmod.com/index.php?/topic/20321-issue-runningdownloading-maps/
TagsNo tags attached.

Activities

stgatilov

stgatilov

12.04.2020 04:57

developer   ~0012360

Committed a bunch of changes.

r8663 --- Abort gracefully if tdm_mirrors.txt is missing.
This is mainly important for people who click the "don't download mirrors" checkbox, i.e. beta testers.
Otherwise some different error handling should cover the case when downloading fails for whatever reason.

r8664 --- Report problem properly when HTTP downloading code cannot open destination file for writing.
Since tdm_update writes its log file before downloading anything, this case can only happen when user uses custom installation path.
For instance, when he runs updater directly from the "downloads" dir which is user-writable, and sets something inside Program Files as custom installation path (without admin rights, of course).
The error report is not very user-friendly: some specific sentences are printed to the log file in this case.

r8665 --- Revised error message when tdm_updater cannot write to log file on start. Among several reasons, Program Files and admin-owned locations is the most popular one today.
This case happens when user manages to put tdm_update into admin-protected location (e.g. Program Files), but runs it without admin rights.
The old error message was not very clear, since it mainly talked about "read-only".
Also, now we discourage from Program Files in this message.

r8666 --- Added utility function which detects if current process is run "under admin". No effect on the installation procedure yet.
r8667 --- Warn user if tdm_update is started with admin rights. Warn that he might be able to play the game only with admin rights after such install. Discourage from Program Files.
This happens when user decides to start installer "as admin", thinking that it would fix the errors happening without it.
Doing so usually leads to disaster, and the message of the warning says so.

r8668 --- Bumped version of tdm_update after changes in revs 8663-8667.
stgatilov

stgatilov

12.04.2020 05:00

developer   ~0012361

These changes with screenshots and text dumps are also described here:
  https://forums.thedarkmod.com/index.php?/topic/20199-tdm-in-read-only-locations/&do=findComment&comment=445876

I believe I have covered all ways to install to Program Files now.
Both with admin rights and without them, both when tdm_update.exe is already in Program Files and when it is in normal location.

Issue History

Date Modified Username Field Change
12.04.2020 04:31 stgatilov New Issue
12.04.2020 04:31 stgatilov Status new => assigned
12.04.2020 04:31 stgatilov Assigned To => stgatilov
12.04.2020 04:57 stgatilov Note Added: 0012360
12.04.2020 05:00 stgatilov Note Added: 0012361
12.04.2020 05:00 stgatilov Status assigned => resolved
12.04.2020 05:00 stgatilov Resolution open => fixed
12.04.2020 05:00 stgatilov Fixed in Version => TDM 2.09
15.04.2020 06:05 stgatilov Target Version TDM 2.09 => TDM 2.08