View Issue Details

IDProjectCategoryView StatusLast Update
0005222DarkRadiantGUIpublic08.11.2020 18:34
ReporterDragofer Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2.7.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0005222: Make it easier to collapse all folders
DescriptionWhen I use the search function I often open a multitude of folders in the process of typing in and searching for the search terms. I found out how to use the left arrow key to quickly collapse folders after a search, but this often still leaves several folders expanded (this becomes apparent as soon as the top-level folder is expanded). All those expanded folders make it difficult to manually navigate to a specific item.

I'd appreciate either of these solutions:
1) collapsing, then expanding a higher level folder shows all lower level folders in a collapsed state
2) add collapse/expand all buttons/toggles to all lists with folders (models/entities/light inspector/media browser/speakers/vocal set chooser/head chooser/prefabs etc)
Steps To Reproduce1) In the Media browser, search for 'grass' and hold down the 'down' arrow key for a while. This opens a lot of folders.
2) Hold down the 'left' arrow key to quickly collapse all folders. "Other Materials" will still be expanded because you started collapsing within "textures"
3) Manually expand "textures". A lot of the folders that were expanded during the search are now expanded again.
TagsNo tags attached.

Activities

greebo

greebo

20.04.2020 17:56

administrator   ~0012376

I went for solution 1) collapsing, then expanding a higher level folder shows all lower level folders in a collapsed state

Related Changesets

DarkRadiant: master bef72505

2020-04-20 17:55:41

greebo

Details Diff
Resolve 0005222: Collapsing a single node in the wxutil::TreeView will now (by default) collapse all of its children too. Affected Issues
0005222
mod - libs/wxutil/TreeView.cpp Diff File
mod - libs/wxutil/TreeView.h Diff File

Issue History

Date Modified Username Field Change
20.04.2020 13:48 Dragofer New Issue
20.04.2020 13:48 Dragofer Summary Feature: make it easier to collapse all folders => Make it easier to collapse all folders
20.04.2020 13:48 Dragofer Severity normal => feature
20.04.2020 14:29 greebo Status new => acknowledged
20.04.2020 17:55 greebo Target Version => 2.8.0
20.04.2020 17:55 greebo Changeset attached => DarkRadiant master bef72505
20.04.2020 17:55 greebo Assigned To => greebo
20.04.2020 17:55 greebo Resolution open => fixed
20.04.2020 17:56 greebo Status acknowledged => resolved
20.04.2020 17:56 greebo Fixed in Version => 2.8.0
20.04.2020 17:56 greebo Note Added: 0012376
08.11.2020 18:34 greebo Status resolved => closed