View Issue Details

IDProjectCategoryView StatusLast Update
0005223The Dark ModDesign/Codingpublic05.10.2021 15:52
Reporterkingsal Assigned Tonbohr1more  
PrioritynormalSeveritynormalReproducibilityalways
Status assignedResolutionfixed 
Product VersionTDM 2.07 
Target VersionTDM 2.10Fixed in VersionTDM 2.10 
Summary0005223: 2.08 Bad internal format console error
DescriptionI'm getting a R_BitsForInternalFormat : bad internalFormat : 0 error while using cvar r_showPrimitives in 2.08.
This floods the console with the warning.
Steps To ReproduceSet "r_showPrimitives" "1"
TagsNo tags attached.

Activities

kingsal

kingsal

20.04.2020 18:18

developer  

Capture.JPG (61,758 bytes)   
Capture.JPG (61,758 bytes)   
Bikerdude

Bikerdude

26.12.2020 14:27

reporter   ~0013247

@kingsal, can you confirm if this still needs looking at?
kingsal

kingsal

26.12.2020 18:59

developer   ~0013286

Yes it does.
nbohr1more

nbohr1more

05.10.2021 02:57

developer   ~0014401

Rev 9621
stgatilov

stgatilov

05.10.2021 14:52

administrator   ~0014406

I'm not sure that adding a cvar check in global error handler is a proper way to fix it.

It should be fixed properly: find why error is happening and fix the core reason, instead of masking the consequences.
nbohr1more

nbohr1more

05.10.2021 15:06

developer   ~0014407

To me this looks like unintentional log spam.

The r_showPrimitives function is generating a test draw and it does not have an associated image for the draw so it falls back to "default"
and therefore also spams the warning. I guess the "true" fix is to assign an image to r_showPrimitives or find a way to generate the data without
triggering the image association?

Is it worth it to do this for the single reason of avoiding console spam?

I guess I should check to see if other debug cvars do the same thing...
stgatilov

stgatilov

05.10.2021 15:52

administrator   ~0014408

Why does r_showPrimitives generate test draw?
Shouldn't it simple print out numbers collected during current frame?

Issue History

Date Modified Username Field Change
20.04.2020 18:18 kingsal New Issue
20.04.2020 18:18 kingsal File Added: Capture.JPG
26.12.2020 14:27 Bikerdude Note Added: 0013247
26.12.2020 18:59 kingsal Note Added: 0013286
05.10.2021 02:57 nbohr1more Note Added: 0014401
05.10.2021 02:57 nbohr1more Assigned To => nbohr1more
05.10.2021 02:57 nbohr1more Status new => resolved
05.10.2021 02:57 nbohr1more Resolution open => fixed
05.10.2021 02:57 nbohr1more Fixed in Version => TDM 2.10
05.10.2021 02:57 nbohr1more Target Version => TDM 2.10
05.10.2021 02:57 nbohr1more Description Updated
05.10.2021 14:52 stgatilov Note Added: 0014406
05.10.2021 14:52 stgatilov Status resolved => assigned
05.10.2021 15:06 nbohr1more Note Added: 0014407
05.10.2021 15:52 stgatilov Note Added: 0014408