View Issue Details

IDProjectCategoryView StatusLast Update
0005272The Dark ModDef / Setuppublic28.06.2020 04:14
ReporterDragofer Assigned ToDragofer  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.08 
Target VersionTDM 2.09Fixed in VersionTDM 2.09 
Summary0005272: Duplicate material/skin/sound defs causing console warnings at startup (beta 2.08)
DescriptionThere are a handful material, skin and sound defs that have duplicates, causing the console to print console warnings several times at various places in the console when starting up TDM. They are:

1) WARNING:file materials/tdm_epi_shader_2.mtr, line 485: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:389
2) WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
3) WARNING:file skins/tdm_epi_skins.skin, line 86: skin 'steam_engine_003_off' previously defined at skins/steam_engine_003.skin:1
4) WARNING:file skins/tdm_epi_skins.skin, line 97: skin 'steam_engine_003_on' previously defined at skins/steam_engine_003.skin:18
5) WARNING:file sound/tdm_ai_maiden.sndshd, line 1709: sound 'tdm_ai_maiden_request_help' previously defined at sound/tdm_ai_maiden.sndshd:1561

I have addressed them as follows in rev 15961:
1) these are identical duplicates (except for the outdated ambient stages), I deleted one.
2) I left this untouched, because the 2 copies are quite different so I wouldn't want to commit a deletion without betatesting.
3 & 4) steam_engine_003.skin is an outdated file with outdated model paths, deleted.
5) a new version of the sound shader was added with considerably better sounds. I've deleted the old shader, but added its sound files to the new shader as comments.
TagsNo tags attached.

Activities

Dragofer

Dragofer

20.06.2020 12:37

developer   ~0012625

Last edited: 20.06.2020 12:40

View 2 revisions

Fixed all except the below, which I think should be fixed for 2.09 when there's a fresh round of betatesting.
WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1

Issue History

Date Modified Username Field Change
20.06.2020 12:33 Dragofer New Issue
20.06.2020 12:33 Dragofer Status new => assigned
20.06.2020 12:33 Dragofer Assigned To => Dragofer
20.06.2020 12:37 Dragofer Status assigned => resolved
20.06.2020 12:37 Dragofer Resolution open => fixed
20.06.2020 12:37 Dragofer Note Added: 0012625
20.06.2020 12:40 Dragofer Note Edited: 0012625 View Revisions
28.06.2020 04:14 stgatilov Fixed in Version => TDM 2.09
28.06.2020 04:14 stgatilov Target Version TDM 2.08 => TDM 2.09