View Issue Details

IDProjectCategoryView StatusLast Update
0005358DarkRadiantGUIpublic13.10.2020 16:18
ReporterDragofer Assigned Togreebo  
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.8.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0005358: Skin listing issues in Skin Chooser
DescriptionThere are a couple issues with the way the Skin Chooser lists skins:

1) the list isn't alphabetical, which can make it difficult to manually find skins
2) in the 'All skins' folder, but not in the 'Matching skins' almost every skin and folder is listed twice. This is even without any FM installed in 2.08. Some of the rare exceptions are "addition_dirty" and "addition_darktimber".
TagsNo tags attached.

Activities

greebo

greebo

13.10.2020 03:55

administrator   ~0012815

It seems the duplication is due to a change in wxWidgets 3.1.x: http://trac.wxwidgets.org/ticket/18405
I'm not 100% sure it's a regression or a sloppy tree model handling in DarkRadiant's code, I need to dig deeper.

Related Changesets

DarkRadiant: master e9a668fc

2020-10-12 17:53:30

greebo

Details Diff
0005358: Add comment to VFSTreePopulator::SendItemAdded(), fixup SoundChooser to call TreeModel::Row::SendItemAdded() Affected Issues
0005358
mod - libs/wxutil/VFSTreePopulator.h Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File

DarkRadiant: master 81f3030a

2020-10-13 16:17:28

greebo

Details Diff
0005358: Work around duplicate items added to the "All Skins" tree in SkinChooser (due to a regression in wxWidgets 3.1.x: http://trac.wxwidgets.org/ticket/18405).
Also, sort the model before passing it to the view, alphabetically.
Affected Issues
0005358
mod - radiant/ui/einspector/SkinChooser.cpp Diff File

Issue History

Date Modified Username Field Change
11.10.2020 17:54 Dragofer New Issue
11.10.2020 18:01 greebo Status new => acknowledged
13.10.2020 03:55 greebo Note Added: 0012815
13.10.2020 03:55 greebo Status acknowledged => confirmed
13.10.2020 16:17 greebo Changeset attached => DarkRadiant master e9a668fc
13.10.2020 16:17 greebo Changeset attached => DarkRadiant master 81f3030a
13.10.2020 16:17 greebo Assigned To => greebo
13.10.2020 16:17 greebo Status confirmed => assigned
13.10.2020 16:18 greebo Target Version => 2.9.0
13.10.2020 16:18 greebo Status assigned => resolved
13.10.2020 16:18 greebo Resolution open => fixed
13.10.2020 16:18 greebo Fixed in Version => 2.9.0