View Issue Details

IDProjectCategoryView StatusLast Update
0000537DarkRadiantGeneralpublic26.03.2008 20:50
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.4 
Target Version0.9.6Fixed in Version0.9.6 
Summary0000537: Crash on closing map with target0
DescriptionSee attached map. It contains an entity with a "target0" keypair. This is apparently hanging/crashing DR upon trying to shut down or close that map. Once the keypair is changed to "target1", it works fine.

Note this exists in at least 0.9.4 as well.
TagsNo tags attached.

Relationships

child of 0000577 closedgreebo Refactor entity Target code 

Activities

22.01.2008 00:37

 

candleprefab4.rar (1,161 bytes)
greebo

greebo

24.01.2008 13:22

administrator   ~0001018

I could reproduce that. The reason is that DR assigns indices for all target keys on an entity. Both "target" and "target0" get the same index 0 assigned by DarkRadiant, and upon removal it tries to double-remove the observer.

Assigning a "target" and "target0" is probably valid, so DarkRadiant needs to handle that case a bit more general.

Issue History

Date Modified Username Field Change
22.01.2008 00:37 SneaksieDave New Issue
22.01.2008 00:37 SneaksieDave File Added: candleprefab4.rar
22.01.2008 00:37 SneaksieDave Description Updated
24.01.2008 13:19 greebo Status new => confirmed
24.01.2008 13:19 greebo Status confirmed => assigned
24.01.2008 13:19 greebo Assigned To => greebo
24.01.2008 13:22 greebo Note Added: 0001018
06.02.2008 15:08 greebo Status assigned => resolved
06.02.2008 15:08 greebo Resolution open => fixed
06.02.2008 15:08 greebo Projection none => minor fix
06.02.2008 15:08 greebo Build => 2993
06.02.2008 15:08 greebo Fixed in Version => 0.9.6
06.02.2008 15:08 greebo Target Version => 0.9.6
14.02.2008 13:14 greebo Relationship added child of 0000577
26.03.2008 20:50 SneaksieDave Status resolved => closed