View Issue Details

IDProjectCategoryView StatusLast Update
0005374DarkRadiantSaving and loadingpublic07.11.2020 04:19
ReporterSpooks Assigned Togreebo  
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.9.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0005374: Ctrl+C attempts to save the map, then crashes DarkRadiant
DescriptionAs above. Keybindings point to "Ctrl~C" being "Copy". I even re-set it and tried again. Crash.
TagsNo tags attached.

Activities

greebo

greebo

01.11.2020 07:48

administrator   ~0012852

I got the crash (and fixed that in source), but I can't get it to ask me to save the map.
Can you elaborate what you are doing to get the save prompt?
Spooks

Spooks

01.11.2020 19:39

reporter   ~0012853

The prompt that flashes is "Attempting to write to file" or something to the effect. It has no buttons, just a progress bar (that doesn't progress any before crashing FWIW). I've been thinking that it might not be EXACTLY the same prompt as the "saving map" one, I can't see what that one says at the start because it goes by too fast.

I am not doing anything besides pressing Ctrl+C to get that to show up. If you thought I meant something like the "Save File" folder dialogue window, none of that shows up, sorry for not being super clear.
greebo

greebo

02.11.2020 12:11

administrator   ~0012854

What you're seeing is the map progress dialog, which I guess hasn't been there before 2.9.0. If it's too distracting, then I can see into suppressing it somehow.
Spooks

Spooks

03.11.2020 17:31

reporter   ~0012863

If it's just a progress bar for saving the chunk of map as it's getting put in the clipboard I'm neutral on having it visible or not. If it should stay I only suggest that it's renamed - if it can be for that particular instance of it showing up - to something like "saving to clipboard" as writing "to file" can give the wrong impression.

Related Changesets

DarkRadiant: 2.9.0 a729e93e

2020-11-01 07:50:00

greebo

Details Diff
0005374: Fix crash in Map::exportSelected due to a beginner's fault, passing a reference to an instance that is about to be deleted as soon as the call returns. Affected Issues
0005374
mod - radiantcore/map/Map.cpp Diff File

DarkRadiant: 2.9.0 e5b3ae0f

2020-11-01 08:08:23

greebo

Details Diff
0005374: Promote the exportSelected() methods to the public IMap interface Affected Issues
0005374
mod - include/imap.h Diff File
mod - radiantcore/map/Map.h Diff File

DarkRadiant: 2.9.0 079ade49

2020-11-01 18:50:39

greebo

Details Diff
0005374: Add a unit test checking that Map::exportSelected is not failing and produces a string result that looks like an XML file. Affected Issues
0005374
mod - test/Makefile.am Diff File
add - test/MapExport.cpp Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: 2.9.0 a47dcbdc

2020-11-03 17:28:42

greebo

Details Diff
0005374: Disable file operation progress messages when exporting the map selection to a stream (used by Ctrl-C, for instance), to get rid of the progress dialog that is flashing up for a very short amount of time. Affected Issues
0005374
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/algorithm/MapExporter.cpp Diff File
mod - radiantcore/map/algorithm/MapExporter.h Diff File

DarkRadiant: 2.9.0 efb2726f

2020-11-03 17:34:43

greebo

Details Diff
0005374: Add unit test asserting the new Map::exportSelected behaviour, not sending any progress messages. Affected Issues
0005374
mod - test/MapExport.cpp Diff File

DarkRadiant: 2.9.0 c52baf7f

2020-11-07 04:18:44

greebo

Details Diff
0005374: Fix compilation errors in Linux Affected Issues
0005374
mod - radiant/ui/LongRunningOperationHandler.cpp Diff File
mod - radiant/ui/MapFileProgressHandler.cpp Diff File

Issue History

Date Modified Username Field Change
30.10.2020 23:02 Spooks New Issue
31.10.2020 04:39 greebo Status new => acknowledged
01.11.2020 05:32 greebo Product Version 2.8.0 => 2.9.0
01.11.2020 07:45 greebo Status acknowledged => confirmed
01.11.2020 07:48 greebo Note Added: 0012852
01.11.2020 07:50 greebo Assigned To => greebo
01.11.2020 07:50 greebo Status confirmed => assigned
01.11.2020 18:53 greebo Changeset attached => DarkRadiant 2.9.0 a729e93e
01.11.2020 18:53 greebo Changeset attached => DarkRadiant 2.9.0 e5b3ae0f
01.11.2020 18:53 greebo Changeset attached => DarkRadiant 2.9.0 079ade49
01.11.2020 19:39 Spooks Note Added: 0012853
02.11.2020 12:11 greebo Note Added: 0012854
03.11.2020 17:31 Spooks Note Added: 0012863
03.11.2020 17:34 greebo Changeset attached => DarkRadiant 2.9.0 a47dcbdc
03.11.2020 17:34 greebo Changeset attached => DarkRadiant 2.9.0 efb2726f
03.11.2020 17:35 greebo Status assigned => resolved
03.11.2020 17:35 greebo Resolution open => fixed
03.11.2020 17:35 greebo Fixed in Version => 2.9.0
03.11.2020 17:35 greebo Target Version => 2.9.0
07.11.2020 04:19 greebo Changeset attached => DarkRadiant 2.9.0 c52baf7f