View Issue Details

IDProjectCategoryView StatusLast Update
0000538The Dark ModCodingpublic25.04.2018 05:34
Reportercrispy Assigned To 
PriorityhighSeverityfeatureReproducibilityN/A
Status suspendedResolutionsuspended 
Product VersionSVN 
Summary0000538: Display warnings when certain crucial cvars are at non-recommended values
DescriptionThere are certain cvars which must be set to particular values to work with TDM. If they are not set correctly then compressed textures will not appear, which may cause them to display black and/or cause map compilation errors. Doom 3 provided uncompressed versions of all its textures and so did not have this problem, but we don't wish to do this for space reasons.

This feature involves the following tasks:

- Check the value of the critical cvars at startup.
- If any of them are wrong, display a message explaining that incorrect settings were detected. Offer to fix the settings, but allow the user to decline.
- If settings are changed that require a restart of Doom 3, tell the user that TDM will now quit, and instruct them to start it up again once it closes.

See forum thread (in which this was a slightly off-topic discussion):
http://forums.thedarkmod.com/?showtopic=6995&&gopid=136253&&page=2
Additional InformationAs far as I (Crispy) know, the cvars in question and the values they need to be set to are:

seta image_usePrecompressedTextures "1"
seta image_useNormalCompression "2"
seta image_useAllFormats "1"
seta image_useCompression "1"

Some of these settings may no longer be required(???), so test them and check with the team before implementation.
TagsNo tags attached.

Activities

crispy

crispy

26.05.2008 02:22

reporter   ~0001204

SneaksieDave had HUGE performance problems (HDD thrashing due to memory usage exceeding available memory) in Saint Lucia when image_useNormalCompression was accidentally set back to 0 due to a Doom 3 bug. This highlights how important it is to have these settings correct!

user81

28.03.2018 15:26

  ~0010284

The following args have been used for ages by lots of people with no ill effects -

seta image_usePrecompressedTextures "1"
seta image_useNormalCompression "2"
seta image_useAllFormats "1"
seta image_useCompression "1"
nbohr1more

nbohr1more

25.04.2018 05:34

developer   ~0010398

Last edited: 25.04.2018 05:34

View 2 revisions

This is not about the cvars in question, it's about a general idea that users should be warned if they change default cvar values to ones that could break TDM.

suspended

Issue History

Date Modified Username Field Change
22.01.2008 08:36 crispy New Issue
26.05.2008 02:22 crispy Note Added: 0001204
26.05.2008 02:24 crispy Priority low => high
28.03.2018 15:26 user81 Note Added: 0010284
28.03.2018 15:26 user81 Status new => closed
28.03.2018 15:26 user81 Assigned To => user81
28.03.2018 15:26 user81 Resolution open => fixed
28.03.2018 15:26 user81 Fixed in Version => TDM 2.06
25.04.2018 05:33 nbohr1more Assigned To user81 =>
25.04.2018 05:33 nbohr1more Status closed => suspended
25.04.2018 05:33 nbohr1more Resolution fixed => suspended
25.04.2018 05:33 nbohr1more Fixed in Version TDM 2.06 =>
25.04.2018 05:33 nbohr1more Description Updated View Revisions
25.04.2018 05:34 nbohr1more Note Added: 0010398
25.04.2018 05:34 nbohr1more Note Edited: 0010398 View Revisions