View Issue Details

IDProjectCategoryView StatusLast Update
0005386DarkRadiantGUIpublic18.11.2020 08:28
ReporterBikerdude Assigned To 
PriorityhighSeveritynormalReproducibilityalways
Status acknowledgedResolutionreopened 
PlatformPCOSWindowsOS Version10
Product Version2.8.0 
Summary0005386: Orthoview in 2.9pre2 very laggy compared to 2.8
Description2.8 -
- Opened up The painters wife (large map), hide all layers bar city north and south.
- after a few seconds looking around with the mouse becomes smooth

2.9 -
- Opened up The painters wife, hide all layers bar city north and south.
- In the same section, looking around is very laggy and juddery.

TagsNo tags attached.

Activities

Bikerdude

Bikerdude

08.11.2020 20:26

reporter   ~0012876

Last edited: 09.11.2020 11:24

View 3 revisions

Using the middle mouse button to move around the map is also quite bad.

nb. I have far plane clip mode disabled, due to it being impossible to use on an AMD gpu.
Bikerdude

Bikerdude

11.11.2020 10:17

reporter   ~0012894

Last edited: 13.11.2020 10:48

View 2 revisions

Nuking the DR config folder from the "C:\Users\<username>\AppData\Roaming" does not fixe it. I have been swapping between 2.9 & 2.8 and was using 2.8 and didn't realize it.
Bikerdude

Bikerdude

13.11.2020 10:46

reporter   ~0012899

Reopening as I have been flicking between 2.8 and 2.9pre2 to see if I could get to the bottom of this. While hiding layers helps, the 3D renderer in 2.9 makes DR feel like I have downgraded my graphics card to some generic pos.
Bikerdude

Bikerdude

17.11.2020 15:34

reporter   ~0012964

Just in case something was tweaked, testing 2.9pre3, issue is the same.
greebo

greebo

18.11.2020 03:38

administrator   ~0012975

Only fired up the profiler a bit, and of course the performance is horrible since the map is huge. I couldn't spot anything in the Orthoview renderer that had been introduced just recently (since 2.8.0), so I won't do much now. For the moment being, I'll put that on the huge pile of issues tagged with "DR renderer sucks".
Bikerdude

Bikerdude

18.11.2020 08:28

reporter   ~0012977

heh, ok thanks fella.

Issue History

Date Modified Username Field Change
08.11.2020 20:22 Bikerdude New Issue
08.11.2020 20:26 Bikerdude Note Added: 0012876
08.11.2020 20:27 Bikerdude Description Updated View Revisions
08.11.2020 20:27 Bikerdude Steps to Reproduce Updated View Revisions
08.11.2020 20:29 Bikerdude Note Edited: 0012876 View Revisions
09.11.2020 11:24 Bikerdude Note Edited: 0012876 View Revisions
11.11.2020 10:17 Bikerdude Note Added: 0012894
11.11.2020 16:50 greebo Status new => closed
11.11.2020 16:50 greebo Resolution open => no change required
11.11.2020 16:50 greebo Fixed in Version => 2.9.0
13.11.2020 10:46 Bikerdude Status closed => assigned
13.11.2020 10:46 Bikerdude Resolution no change required => reopened
13.11.2020 10:46 Bikerdude Note Added: 0012899
13.11.2020 10:47 Bikerdude Priority normal => high
13.11.2020 10:47 Bikerdude Status assigned => new
13.11.2020 10:48 Bikerdude Note Edited: 0012894 View Revisions
17.11.2020 15:34 Bikerdude Note Added: 0012964
18.11.2020 03:38 greebo Status new => acknowledged
18.11.2020 03:38 greebo Note Added: 0012975
18.11.2020 03:38 greebo Fixed in Version 2.9.0 =>
18.11.2020 08:28 Bikerdude Note Added: 0012977