View Issue Details

IDProjectCategoryView StatusLast Update
0005388DarkRadiantGUIpublic05.01.2021 15:32
ReporterSpooks Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version2.8.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005388: Skin Chooser starts with expanded All Skins root folder
Description...as well as the Matching Skins folder. This makes it that you always have to click one extra time to collapse All Skins before you can choose your skin.
Steps To ReproduceAs in the comments, the reproduction steps were found to be:

1) Create model > painting01.lwo (no skin)
2) On the painting's model spawnarg, click "Choose skin...". The skin chooser opens correctly with "All skins" collapsed and "Matching skins" expanded.
3) Choose any matching skin.
4) Repeat step 2. The skin chooser now opens incorrectly with both "All skins" and "Matching skins" expanded.

For step 4, it doesn't matter if you open the skin chooser via the "model" or the "skin" spawnarg.
TagsNo tags attached.

Activities

greebo

greebo

15.11.2020 05:07

administrator   ~0012944

"All Skins" is collapsed on my end, both in 2.8.0 and 2.9.0pre2 - can you double-check and maybe post the steps you made? Maybe I'm doing something differently.
Spooks

Spooks

18.11.2020 15:23

reporter   ~0012985

Weird! The bug was there for me in 2.9.0pre2 but now after installing 2.9.0 (and checking pre3 afterwards) it is gone. I think this can be closed.
Spooks

Spooks

29.12.2020 16:47

reporter   ~0013308

Happens to me almost always, again, on 2.10. I saw 1 out of 50 or so times where the All Skins folder started collapsed.
Dragofer

Dragofer

29.12.2020 18:49

developer   ~0013310

Can confirm on my end, the bug occurs always if the model already has a skin, never if it has no skin yet. The reproduction steps are:

1) Create model > painting01.lwo (no skin)
2) On the painting's model spawnarg, click "Choose skin...". The skin chooser opens correctly with "All skins" collapsed and "Matching skins" expanded.
3) Choose any matching skin.
4) Repeat step 2. The skin chooser now opens incorrectly with both "All skins" and "Matching skins" expanded.

For step 4, it doesn't matter if you open the skin chooser via the "model" or the "skin" spawnarg.
greebo

greebo

05.01.2021 08:12

administrator   ~0013369

I can see the behaviour now - it's because the assigned skin value is found in the "All Skins" tree and is highlighted when the dialog is opened. Since the skin is listed in both trees (All and Matching), the one in All Skins is located first and this expands the subtree.

Related Changesets

DarkRadiant: master 1c874215

2021-01-05 12:47:23

greebo

Details Diff
0005388: Extend TreeModel::FindString/FindInteger methods to accept a starting point for the search Affected Issues
0005388
mod - libs/wxutil/dataview/TreeModel.cpp Diff File
mod - libs/wxutil/dataview/TreeModel.h Diff File
mod - libs/wxutil/dataview/TreeModelFilter.cpp Diff File

DarkRadiant: master 32ca17a6

2021-01-05 15:30:26

greebo

Details Diff
0005388: Search the skin in the Matching Skins tree first when pre-selecting an item in the SkinChooser tree Affected Issues
0005388
mod - radiant/ui/einspector/SkinChooser.cpp Diff File
mod - radiant/ui/einspector/SkinChooser.h Diff File

Issue History

Date Modified Username Field Change
08.11.2020 20:40 Spooks New Issue
15.11.2020 05:07 greebo Status new => feedback
15.11.2020 05:07 greebo Note Added: 0012944
18.11.2020 15:23 Spooks Note Added: 0012985
18.11.2020 15:23 Spooks Status feedback => new
18.11.2020 16:09 greebo Assigned To => greebo
18.11.2020 16:09 greebo Status new => closed
18.11.2020 16:09 greebo Resolution open => unable to reproduce
18.11.2020 16:09 greebo Fixed in Version => 2.9.0
29.12.2020 16:47 Spooks Status closed => assigned
29.12.2020 16:47 Spooks Resolution unable to reproduce => reopened
29.12.2020 16:47 Spooks Note Added: 0013308
29.12.2020 17:55 greebo Assigned To greebo =>
29.12.2020 17:55 greebo Status assigned => acknowledged
29.12.2020 18:49 Dragofer Note Added: 0013310
05.01.2021 08:12 greebo Status acknowledged => confirmed
05.01.2021 08:12 greebo Note Added: 0013369
05.01.2021 08:13 greebo Steps to Reproduce Updated View Revisions
05.01.2021 15:30 greebo Assigned To => greebo
05.01.2021 15:30 greebo Status confirmed => assigned
05.01.2021 15:31 greebo Changeset attached => DarkRadiant master 1c874215
05.01.2021 15:31 greebo Changeset attached => DarkRadiant master 32ca17a6
05.01.2021 15:32 greebo Status assigned => resolved
05.01.2021 15:32 greebo Fixed in Version 2.9.0 => 2.11.0
05.01.2021 15:32 greebo Target Version => 2.11.0