View Issue Details

IDProjectCategoryView StatusLast Update
0005393DarkRadiantGUIpublic13.11.2020 19:24
ReporterBikerdude Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version2.9.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0005393: DR 2.9pre2 wont load from recently opened maps list
DescriptionClicking on any of the last 5 opened maps does nothing.
TagsNo tags attached.

Activities

Bikerdude

Bikerdude

10.11.2020 09:35

reporter  

Untitled.jpg (224,223 bytes)   
Untitled.jpg (224,223 bytes)   
Spooks

Spooks

11.11.2020 08:44

reporter   ~0012889

I tried and I couldn't reproduce this.
Bikerdude

Bikerdude

11.11.2020 09:15

reporter   ~0012891

hmm, we are seeing some anomalies with this version. By that I wasnt able to reproduce some of the bugs you reported.

Back to this bug this is what I see in the console right after loading DR -

"Auto-saving registry to user settings path.
Cannot execute command LoadMRUMap: Command not found.
Auto-saving registry to user settings path."

@Spooks, when you click on a recent map and you post what you get in the console? it might help me/us troubleshoot the issue.
Spooks

Spooks

11.11.2020 09:26

reporter   ~0012892

Nothing unusual,
"Open file [filepath].map from filesystem...success.
Auto-saving registry to user settings path.
Using Doom 3 format to load the data.
Open file [filepath].darkradiant from filesystem...success.
Parsing info file..."
Bikerdude

Bikerdude

11.11.2020 10:04

reporter   ~0012893

I might just try and nuke all the config files reverting to a Vanilla state and see if that fixes it.
Bikerdude

Bikerdude

11.11.2020 10:19

reporter   ~0012895

This can be closed, can confirm nuking the DR config folder from the "C:\Users\<username>\AppData\Roaming" fixes it.
greebo

greebo

13.11.2020 16:49

administrator   ~0012905

This is due to some XML tags in the user.xml file that are created after using DR 2.9.0.

Have a look in your user.xml file in the AppData Roaming folder. It's very likely that it contains statement bindings created by 2.9.0, like these:

<commandsystem>
  <binds>
  <bind name="MRUOpen1" value="LoadMRUMap 1"/>
  <bind name="MRUOpen2" value="LoadMRUMap 2"/>
  <bind name="MRUOpen3" value="LoadMRUMap 3"/>
  <bind name="MRUOpen4" value="LoadMRUMap 4"/>
  <bind name="MRUOpen5" value="LoadMRUMap 5"/>
  </binds>
  </commandsystem>

You can remove those from the user.xml (but close DR first), this ought to fix it.
greebo

greebo

13.11.2020 16:51

administrator   ~0012906

I'll assign this me, to add code preventing those tags from being written to user.xml.
Bikerdude

Bikerdude

13.11.2020 19:24

reporter   ~0012912

thanks Greebo.

Related Changesets

DarkRadiant: 2.9.0 3e08dcea

2020-11-13 16:53:36

greebo

Details Diff
0005393: Don't save the auto-generated MRUOpen<N> commands to the registry. Affected Issues
0005393
mod - radiantcore/map/mru/MRU.cpp Diff File

Issue History

Date Modified Username Field Change
10.11.2020 09:35 Bikerdude New Issue
10.11.2020 09:35 Bikerdude File Added: Untitled.jpg
11.11.2020 08:44 Spooks Note Added: 0012889
11.11.2020 09:15 Bikerdude Note Added: 0012891
11.11.2020 09:26 Spooks Note Added: 0012892
11.11.2020 10:04 Bikerdude Note Added: 0012893
11.11.2020 10:19 Bikerdude Note Added: 0012895
13.11.2020 16:49 greebo Note Added: 0012905
13.11.2020 16:49 greebo Status new => resolved
13.11.2020 16:49 greebo Resolution open => no change required
13.11.2020 16:49 greebo Product Version 2.8.0 => 2.9.0
13.11.2020 16:51 greebo Assigned To => greebo
13.11.2020 16:51 greebo Status resolved => assigned
13.11.2020 16:51 greebo Resolution no change required => reopened
13.11.2020 16:51 greebo Note Added: 0012906
13.11.2020 16:53 greebo Changeset attached => DarkRadiant 2.9.0 3e08dcea
13.11.2020 16:53 greebo Status assigned => resolved
13.11.2020 16:53 greebo Resolution reopened => fixed
13.11.2020 16:53 greebo Fixed in Version => 2.9.0
13.11.2020 16:54 greebo Target Version => 2.9.0
13.11.2020 19:24 Bikerdude Note Added: 0012912