View Issue Details

IDProjectCategoryView StatusLast Update
0000054DarkRadiantGUIpublic28.02.2007 21:24
ReporterSneaksieDave Assigned Togreebo  
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.8.0 
Fixed in Version0.9.0 
Summary0000054: Translate Mode (w) more friendly functionality
DescriptionSource:
http://modetwo.net/darkmod/index.php?s=&showtopic=4735&view=findpost&p=88426

Translate Mode (W)
Possibly my most pressed key in D3Ed. I'm glad it exists in DR. However, it acts a bit different. In D3Ed, you press W, and then anywhere you click and drag, you affect the selected entities (for translation). In DR, the user must either click the brush itself, or one of the directional arrows extending out of the brush(es). This requirement pretty much eliminates the convenience and use of the feature at all, because if the user could simply click the brush, they don't really even need a translate lock key. The whole advantage (in D3Ed) to having this locked mode is that you don't have to pinpoint your brush(es) and drag them - you can drag anywhere in, out, or around them, and they'll still move, completely intact.

Edit: If/when making these changes, please don't remove the axis lock arrows - they rule!
TagsNo tags attached.

Activities

greebo

greebo

27.02.2007 16:05

administrator   ~0000260

Clicking anywhere in the orthoview can select the translate manipulator. An option has been added (Preferences > Orthoview) to choose whether this "click-anywhere-to-translate" is constrained to an axis or if it's interpreted as free translation.
SneaksieDave

SneaksieDave

28.02.2007 01:09

developer   ~0000267

I'm guessing this must not be uploaded yet. I don't see this value in options, nor the drag anywhere behavior.
SneaksieDave

SneaksieDave

28.02.2007 20:32

developer   ~0000280

greebo: don't kill me.

I know that above, I said, "Edit: If/when making these changes, please don't remove the axis lock arrows - they rule!"

I was actually referring to not getting rid of them when specifically clicking the arrows and the little box in the center. The axis locking seems to carry out into the whole grid. I originally imagined that the gridspace dragging would be the free translate mode. If the user still needs axis locking for fine control, he'd probably be close enough to the brush to click the arrows anyway. Can that either be an option, or not there (if you guys agree it's a good idea). Reason being, after using the 'total grid translate mode' here, it seems the axis locking kinda gets in the way.

So to clarify: the arrows and functionality definitely should stay, they do indeed rule. But I'm not positive it should extend to the full grid dragging. What do you guys think? I could go either way and we can probably consider this closed now, but I thought I would ask before closing it.
greebo

greebo

28.02.2007 20:40

administrator   ~0000282

I don't get it, please explain more clearly. What is it you refer to as "gridspace dragging"? Do you want to have axis-locked translation if you click anywhere in the view? (If yes, have you tried pressing SHIFT while dragging?)
SneaksieDave

SneaksieDave

28.02.2007 20:53

developer   ~0000283

Last edited: 28.02.2007 20:57

By 'gridspace dragging' I'm trying to come up with a term for this new functionality (in this issue). I don't know what else to call it.

Shift while dragging is select complete tall for me (and hopefully stays that way)?

Okay, to try and be more clear - I think what I said in the original entry was misinterpretted. What I meant:

Make it so the arrows function as they currently do, and everywhere else in the whole view acts like the little box in the center (drag in either orthogonal direction at once).

greebo

greebo

28.02.2007 21:00

administrator   ~0000284

Last edited: 28.02.2007 21:01

Try dragging and holding shift AFTER you began the actual translation. The operation is immediately constrained to the axes.

"...everywhere else in the whole view acts like the little box in the center (drag in either orthogonal direction at once)."
Currently, if you click anywhere in the view the translation is not constrained to the axis, isn't that what you're requesting? The little yellow box in the center is "free translation", as is clicking anywhere in the view.

SneaksieDave

SneaksieDave

28.02.2007 21:11

developer   ~0000287

"Try dragging and holding shift AFTER you began the actual translation. The operation is immediately constrained to the axes."

Right, that happens to me only if I click in the yellow box.

"Currently, if you click anywhere in the view the translation is not constrained to the axis, isn't that what you're requesting? The little yellow box in the center is "free translation", as is clicking anywhere in the view."

Okay we are talking about the same thing. But, it's not doing that for me. If I click in the view, I get axis constraining based what looks like 45 degree quadrants. E.g., clicking outside of the brush, all the way across the map, to the immediate right of the brush, gives me horizontal motion only. Clicking at the top, gives me vertical motion only. I'm not getting the same behavior as the yellow box, so that's why I'm asking. :)
greebo

greebo

28.02.2007 21:18

administrator   ~0000291

Last edited: 28.02.2007 21:19

Argh! I forgot to tell you: there's a preference under "Preferences>Orthographic" (the last option). Tick it off.

(I had implemented this all the way and then I realised that it was more practical to have the gridspace translator in free-translation mode by default - That's why I made it a preference. I forget my own changes, I should really take a break!)

SneaksieDave

SneaksieDave

28.02.2007 21:24

developer   ~0000293

Awesome! Thanks for the option. :)

Issue History

Date Modified Username Field Change
27.01.2007 02:43 SneaksieDave New Issue
27.01.2007 02:47 SneaksieDave Product Version => 0.8.0
27.01.2007 02:47 SneaksieDave Description Updated
27.01.2007 10:02 orbweaver Status new => confirmed
10.02.2007 19:17 SneaksieDave Description Updated
27.02.2007 16:05 greebo Status confirmed => resolved
27.02.2007 16:05 greebo Fixed in Version => latest SVN
27.02.2007 16:05 greebo Resolution open => fixed
27.02.2007 16:05 greebo Assigned To => greebo
27.02.2007 16:05 greebo Note Added: 0000260
28.02.2007 01:09 SneaksieDave Note Added: 0000267
28.02.2007 20:32 SneaksieDave Status resolved => feedback
28.02.2007 20:32 SneaksieDave Resolution fixed => reopened
28.02.2007 20:32 SneaksieDave Note Added: 0000280
28.02.2007 20:40 greebo Note Added: 0000282
28.02.2007 20:53 SneaksieDave Note Added: 0000283
28.02.2007 20:54 SneaksieDave Note Edited: 0000283
28.02.2007 20:57 SneaksieDave Note Edited: 0000283
28.02.2007 21:00 greebo Note Added: 0000284
28.02.2007 21:01 greebo Note Edited: 0000284
28.02.2007 21:11 SneaksieDave Note Added: 0000287
28.02.2007 21:18 greebo Note Added: 0000291
28.02.2007 21:19 greebo Note Edited: 0000291
28.02.2007 21:24 SneaksieDave Status feedback => closed
28.02.2007 21:24 SneaksieDave Note Added: 0000293
28.02.2007 21:24 SneaksieDave Resolution reopened => fixed