View Issue Details

IDProjectCategoryView StatusLast Update
0005403DarkRadiantGeneralpublic17.11.2020 04:13
ReporterMirceaKitsune Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionduplicate 
Platformx64OSLinux openSUSEOS VersionRelease
Product Version2.8.0 
Fixed in Version2.9.0 
Summary0005403: Select Group Parts does not work
DescriptionDarkRadiant is supposed to allow you to select individual entities in a group using the option Select Group Parts (the icon with a rubix cube in the upper bar). However this doesn't appear to work: Clicking on this icon, either before or after I've selected a group of entities, does nothing. The only change is that the the icon to its left, Select Entities (the icon with a blue chess piece) gets turned on and off in its place. Toggling that icon doesn't allow me to select group parts either, the only workaround right now is to ungroup then edit the entity you need then group again (very annoying for groups with a lot of items).
Steps To ReproduceImport a prefab as a group or manually group a bunch of entities on your map. Try using the Select Group Parts option: It simply doesn't work and nothing happens.
TagsBug, Glitch

Relationships

duplicate of 0005380 resolvedgreebo DR2.9 beta Select Group Parts not working 

Activities

greebo

greebo

13.11.2020 19:16

administrator   ~0012909

Possible duplicate of 0005380?
MirceaKitsune

MirceaKitsune

13.11.2020 19:18

reporter   ~0012910

Sounds like the same thing. Should the fix be in latest Git master, or will it only get there once 2.9.0 is released? I'll confirm it's solved for me as well then.
greebo

greebo

13.11.2020 19:22

administrator   ~0012911

Right now, everything goes to the 2.9.0 branch, but I'm beginning to re-think that decision. I was thinking I might be working on one or two other features next to stabilising the release and waiting for feedback, but since there are so many reports incoming for 2.9.0, and I'm pretty much exclusively working on fixing those, I think there's not much benefit in keeping the master separate and free for feature development.
MirceaKitsune

MirceaKitsune

17.11.2020 03:38

reporter   ~0012952

Just updated to latest Git master. Select grouped parts now seems to work in principle, but there's a major issue left: Apparently it only lets me select brushes! I'm unable to select any entities inside a group with it.

Additionally there's another problem though this is a tiny one: If you have a brush in a group selected then turn off the "select grouped parts" button, you'll still maintain that one brush selected. Normally toggling the feature off while having a group part selected should either select the entire group or deselect everything.
MirceaKitsune

MirceaKitsune

17.11.2020 03:39

reporter   ~0012953

Reopening this to avoid opening yet another issue and for the same component, see my note above.
greebo

greebo

17.11.2020 04:13

administrator   ~0012954

What you're experiencing is I guess the same as in this issue 0005125. As discussed there, the feature you're using has a misleading name, as it was there long before grouping was implemented.
There's also another feature request for the thing you want to do: 0004863.

Setting this issue to resolved again, as the issue at hand was about the toggle button not working.

Issue History

Date Modified Username Field Change
13.11.2020 18:57 MirceaKitsune New Issue
13.11.2020 18:57 MirceaKitsune Tag Attached: Bug
13.11.2020 18:57 MirceaKitsune Tag Attached: Glitch
13.11.2020 19:15 greebo Relationship added related to 0005380
13.11.2020 19:16 greebo Note Added: 0012909
13.11.2020 19:18 MirceaKitsune Note Added: 0012910
13.11.2020 19:22 greebo Note Added: 0012911
14.11.2020 05:47 greebo Relationship replaced duplicate of 0005380
14.11.2020 05:47 greebo Assigned To => greebo
14.11.2020 05:47 greebo Status new => resolved
14.11.2020 05:47 greebo Resolution open => duplicate
14.11.2020 05:47 greebo Fixed in Version => 2.9.0
17.11.2020 03:38 MirceaKitsune Note Added: 0012952
17.11.2020 03:39 MirceaKitsune Status resolved => assigned
17.11.2020 03:39 MirceaKitsune Resolution duplicate => reopened
17.11.2020 03:39 MirceaKitsune Note Added: 0012953
17.11.2020 03:39 MirceaKitsune Status assigned => new
17.11.2020 04:13 greebo Status new => resolved
17.11.2020 04:13 greebo Resolution reopened => duplicate
17.11.2020 04:13 greebo Note Added: 0012954