View Issue Details

IDProjectCategoryView StatusLast Update
0005406DarkRadiantObjectivespublic26.12.2020 07:39
ReporterGeep Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
OSWin 10 
Product Version2.8.0 
Target Version2.10.0Fixed in Version2.10.0 
Summary0005406: Provide list of all named map entities when editing the "Name of single Entity" objective specifier
DescriptionAssociated with every objective component, when selected for editing, are typically additional text fields. Whenever such a text field is of field type of "Name of single entity", it would be desirable to make visible a button, "Select entity...", that if pressed would allow choosing the name from a list of pre-existing entities. Typically, there is room for this button above the text field and right-justified with it.

Note greebo: I'll be going for adding a dropdown list to that text field, this is easier than a separate dialog.
TagsNo tags attached.

Activities

greebo

greebo

25.12.2020 09:08

administrator   ~0013191

This is how it looks like, is that ok for you, Geep?
Geep

Geep

25.12.2020 10:55

reporter   ~0013192

I have no problem with a dropdown. A concern is how to find an item of interest if there are hundreds of rows listed, and there is no full-text search (e.g., to bypass any atdm prefixes). Could you enforce alphabetization in the listing? That would help.
Geep

Geep

25.12.2020 16:12

reporter   ~0013194

I guess another issue is whether or not free-text entry is allowed, or selection is restrained to items in the list. An advantage of restraint is that it helps avoid spelling errors. Nevertheless, I have a slight preference for free-text here, because -
- it is more flexible and allows existing practices, such as direct type in of simple names or cut&paste from entity viewer name field.
- it allows specifying a entity name in anticipation of creating the entity
- if the referrenced entity is subsequently renamed, how to display the resulting mismatch at the dropdown is trivial (i.e., do nothing). (This issue becomes moot if the renaming is auto-propagated to the objective field.)
greebo

greebo

25.12.2020 18:10

administrator   ~0013196

The text is not restricted to the names in the list, they are merely used as suggestion. I can take care of the sorting, no problem.
I think if the entity is renamed, DarkRadiant's namespace management code might take care of all referencing spawnargs automatically.
Geep

Geep

25.12.2020 22:32

reporter   ~0013197

All good. Look forward to it. Thanks
greebo

greebo

26.12.2020 04:03

administrator   ~0013205

Ok, this is what it looks like now
Geep

Geep

26.12.2020 06:46

reporter   ~0013207

Excellent. BTW, on the dialog pages that have choices other than "Name of single entity", are there situations where you can provide similar lists for some of those choices? I don't understand those other choices well enough to give any guidance, but maybe you do.
greebo

greebo

26.12.2020 07:39

administrator   ~0013208

I guess there's always room for improvements, but I admit I haven't looked into it very far. It's been a while since I worked with objectives.

Related Changesets

DarkRadiant: master 62a4ab79

2020-12-25 08:39:01

greebo

Details Diff
0005406: Upgrade "Name of single entity" SpecifierEditor to a combo box listing all the map's entities. Affected Issues
0005406
mod - plugins/dm.objectives/ce/specpanel/EntityNameSpecifierPanel.cpp Diff File
mod - plugins/dm.objectives/ce/specpanel/EntityNameSpecifierPanel.h Diff File

DarkRadiant: master 9f7eede4

2020-12-25 08:45:08

greebo

Details Diff
0005406: Auto-select the first objective entity when opening the objectives editor Affected Issues
0005406
mod - plugins/dm.objectives/ObjectivesEditor.cpp Diff File
mod - plugins/dm.objectives/ObjectivesEditor.h Diff File

DarkRadiant: master 14e8d903

2020-12-25 08:48:35

greebo

Details Diff
0005406: Double-clicking an objective will open the edit dialog Affected Issues
0005406
mod - plugins/dm.objectives/ObjectivesEditor.cpp Diff File
mod - plugins/dm.objectives/ObjectivesEditor.h Diff File

DarkRadiant: master eac6cd20

2020-12-26 04:00:34

greebo

Details Diff
0005406: Sort the list of entity names in the dropdown box Affected Issues
0005406
mod - plugins/dm.objectives/ce/specpanel/EntityNameSpecifierPanel.cpp Diff File

Issue History

Date Modified Username Field Change
13.11.2020 19:22 Geep New Issue
15.11.2020 05:16 greebo Status new => confirmed
25.12.2020 08:28 greebo Assigned To => greebo
25.12.2020 08:28 greebo Status confirmed => assigned
25.12.2020 08:30 greebo Summary Feature: Add "Select entity..." button when editing certain Objective parameters => Provide list of all named map entities when editing the "Name of single Entity" objective specifier
25.12.2020 08:30 greebo Description Updated View Revisions
25.12.2020 08:30 greebo Target Version => 2.10.0
25.12.2020 09:06 greebo Changeset attached => DarkRadiant master 62a4ab79
25.12.2020 09:06 greebo Changeset attached => DarkRadiant master 9f7eede4
25.12.2020 09:06 greebo Changeset attached => DarkRadiant master 14e8d903
25.12.2020 09:07 greebo Status assigned => resolved
25.12.2020 09:07 greebo Resolution open => fixed
25.12.2020 09:07 greebo Fixed in Version => 2.10.0
25.12.2020 09:08 greebo Note Added: 0013191
25.12.2020 09:08 greebo File Added: 2020-12-25 10_07_17-Mission Objectives.png
25.12.2020 10:55 Geep Note Added: 0013192
25.12.2020 16:12 Geep Note Added: 0013194
25.12.2020 18:10 greebo Note Added: 0013196
25.12.2020 22:32 Geep Note Added: 0013197
26.12.2020 04:03 greebo Note Added: 0013205
26.12.2020 04:03 greebo File Added: 2020-12-26 05_02_57-Edit Objective.png
26.12.2020 04:03 greebo Changeset attached => DarkRadiant master eac6cd20
26.12.2020 06:46 Geep Note Added: 0013207
26.12.2020 07:39 greebo Note Added: 0013208