View Issue Details

IDProjectCategoryView StatusLast Update
0005440DarkRadiantGeneralpublic19.12.2020 03:40
ReporterHMart Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.9.1 
Target Version2.10.0Fixed in Version2.10.0 
Summary0005440: Overwriting protection of newer files: alert the player when the file has been modified on disk before saving
Descriptiontaken from this forum discussion: https://forums.thedarkmod.com/index.php?/topic/20679-handling-two-instances-of-dr-with-the-same-map-open/&tab=comments#comment-454046

" I forgot that I add DR open in one virtual desktop hidden from view, so I opened another DR instance, I worked on the map in this new instance ... I closed it and changed to my second virtual desktop that add Visual Studio open, behind it was the forgotten, second instance of DR that I didn't saw..., I alt+tab to go to the desktop for some reason and saw it, instead of closing it straight away, I instinctively clicked ctrl+s, not realizing that this version of the map was outdated and so, it undone all the changes made to the map on the other DR instance... "
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 04ae5764

2020-12-13 13:27:09

greebo

Details Diff
0005440: Experimental commit, MapResource is keeping track of the last modification date of a file Affected Issues
0005440
mod - include/imapresource.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File

DarkRadiant: master e836a292

2020-12-14 11:55:45

greebo

Details Diff
0005440: Add FileOverwriteConfirmation message. An unhandled message will cancel the save process. Affected Issues
0005440
mod - include/imessagebus.h Diff File
add - libs/messages/FileOverwriteConfirmation.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: master 35364ec7

2020-12-14 12:05:44

greebo

Details Diff
0005440: Add FileOverwriteConfirmationHandler to UI module Affected Issues
0005440
mod - libs/messages/FileOverwriteConfirmation.h Diff File
add - radiant/ui/FileOverwriteConfirmationHandler.h Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/ui/UserInterfaceModule.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 8b74197d

2020-12-14 16:39:11

greebo

Details Diff
0005440: Add a couple of test scenarios - unit tests are pretty red right now since it's warning way too often and blocking the save Affected Issues
0005440
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: master 2bd99ba7

2020-12-18 18:52:47

greebo

Details Diff
0005440: Fix exception on writing layer mappings of an empty map to the .darkradiant file Affected Issues
0005440
mod - radiantcore/layers/LayerInfoFileModule.cpp Diff File

DarkRadiant: master b99f6e6d

2020-12-18 18:58:31

greebo

Details Diff
0005440: Update last modification timestamp in MapResource after successful loading or saving Affected Issues
0005440
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File

DarkRadiant: master 60bc7dbe

2020-12-19 03:33:05

greebo

Details Diff
0005440: Set last modification timestamp right in constructor, which is needed to make "save as" working without double asking for overwrite Affected Issues
0005440
mod - radiantcore/map/MapResource.cpp Diff File
mod - test/MapSavingLoading.cpp Diff File

Issue History

Date Modified Username Field Change
07.12.2020 17:11 HMart New Issue
07.12.2020 17:17 HMart Summary alert the player when two instances of DR are open, on the same map at save time. => (overwriting protection of newer files) alert the player when two instances of DR are open, on the same map at save time.
07.12.2020 17:23 greebo Status new => confirmed
19.12.2020 03:35 greebo Product Version => 2.9.1
19.12.2020 03:35 greebo Target Version => 2.10.0
19.12.2020 03:35 greebo Assigned To => greebo
19.12.2020 03:35 greebo Status confirmed => assigned
19.12.2020 03:39 greebo Changeset attached => DarkRadiant master 04ae5764
19.12.2020 03:39 greebo Changeset attached => DarkRadiant master e836a292
19.12.2020 03:39 greebo Changeset attached => DarkRadiant master 35364ec7
19.12.2020 03:39 greebo Changeset attached => DarkRadiant master 8b74197d
19.12.2020 03:39 greebo Changeset attached => DarkRadiant master 2bd99ba7
19.12.2020 03:39 greebo Changeset attached => DarkRadiant master b99f6e6d
19.12.2020 03:39 greebo Changeset attached => DarkRadiant master 60bc7dbe
19.12.2020 03:39 greebo Status assigned => resolved
19.12.2020 03:39 greebo Resolution open => fixed
19.12.2020 03:39 greebo Fixed in Version => 2.10.0
19.12.2020 03:40 greebo Summary (overwriting protection of newer files) alert the player when two instances of DR are open, on the same map at save time. => Overwriting protection of newer files: alert the player when the file has been modified on disk before saving