View Issue Details

IDProjectCategoryView StatusLast Update
0005441The Dark ModCodingpublic14.12.2020 22:54
Reporternbohr1more Assigned Tostgatilov  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
OSLinux MintOS Version19.3 
Product VersionSVN 
Target VersionTDM 2.09Fixed in VersionTDM 2.09 
Summary0005441: r_useParallelAddModels crashes when the Lightgem is hidden via Gameplay Settings
DescriptionThe new r_useParallelAddModels optimization works very well but appears to crash when code that updates the lightgem HUD
is touched. This happens almost instantly if you use the "hide lightgem" setting
Steps To Reproduce1) Install any mission ( Closemouthed Shadows)
2) Main Menu > Settings > Game Play > General > Hide Lightgem = ON
3) Open the console and invoke "r_useParallelAddModels 1"
4) Start the Mission
5) Note the crash shortly after starting
Additional Informationhttps://forums.thedarkmod.com/index.php?/topic/20684-r_useparalleladdmodels-crash/

Debug log:

 Normal cycle:


tdm_src/trunk/game/Player.cpp (9711):DEB (LIGHT) FR: 0] Averaged colorvalue total: 0.125368
tdm_src/trunk/game/Player.cpp (9714):DEB (LIGHT) FR: 0] Adjustment 0.000000
tdm_src/trunk/game/Player.cpp (9727):DEB (LIGHT) FR: 0] After player adjustment 4
tdm_src/trunk/game/Player.cpp (3181):INF (SYSTEM) FR: 0] PlayerHUD: [guis/tdm_hud.gui]
tdm_src/trunk/game/Player.cpp (3228):DEB (LIGHT) FR: 0] Setting Lightgemvalue: 4 on hud: 12AD1460

Crash:

tdm_src/trunk/game/ai/Mind.cpp ( 85):INF (AI) FR: 6701] Mind is thinking... basement_hut_spider
tdm_src/trunk/game/Game_local.cpp (3477):INF (FRAME) FR: 6701] Frame end 76908 - 1921: all:2.6 th:2.6 ev:0.0 0 ents

tdm_src/trunk/game/Player.cpp (9711):DEB (LIGHT) FR: 0] Averaged colorvalue total: 0.125368
tdm_src/trunk/game/Player.cpp (9714):DEB (LIGHT) FR: 0] Adjustment 0.000000
tdm_src/trunk/game/Player.cpp (9727):DEB (LIGHT) FR: 0] After player adjustment 4

Even small changes to Player.cpp > idPlayer::DrawHUD or Overlay.sys > COverlaySys::drawOverlays()" under /game/OverlaySys.cpp cause instant crashes
so I suspect that that this is where the problem lies?

That, or the lightgem hud is touching m_lightgemValue at the same time as another process?
TagsNo tags attached.

Relationships

child of 0005169 assignedcabalistic Clean multithreading routines 

Activities

nbohr1more

nbohr1more

13.12.2020 16:24

developer   ~0013119

Unable to reproduce after Rev 9038 ( stgatilov )

Issue History

Date Modified Username Field Change
08.12.2020 22:54 nbohr1more New Issue
08.12.2020 22:54 nbohr1more Status new => assigned
08.12.2020 22:54 nbohr1more Assigned To => cabalistic
08.12.2020 22:55 nbohr1more OS => Linux Mint
08.12.2020 22:55 nbohr1more OS Version => 19.3
10.12.2020 05:00 nbohr1more Additional Information Updated View Revisions
13.12.2020 16:24 nbohr1more Note Added: 0013119
13.12.2020 16:25 nbohr1more Status assigned => feedback
14.12.2020 05:52 nbohr1more Assigned To cabalistic => stgatilov
14.12.2020 05:52 nbohr1more Status feedback => resolved
14.12.2020 05:52 nbohr1more Resolution open => fixed
14.12.2020 05:52 nbohr1more Fixed in Version => TDM 2.09
14.12.2020 22:54 nbohr1more Relationship added child of 0005169