View Issue Details

IDProjectCategoryView StatusLast Update
0005445DarkRadiantGUIpublic15.01.2021 17:23
ReporterMirceaKitsune Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionduplicate 
Platformx64OSLinux openSUSEOS VersionRelease
Product Version2.9.1 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005445: Filter search for asset browsers
DescriptionFeature for the suggestion posted on the forum thread:

https://forums.thedarkmod.com/index.php?/topic/20640-feature-filter-search-for-asset-browsers

There already seems to be a preliminary but limited search system. If you open a browser such as the entity browser then start typing a word within its window, you'll be able to use search similarly to searching for words in Notepad; You're taken to the first entry containing that word, can use the next button to select the next one, etc. This is helpful itself to some extent, however I believe filter based searching would be much better and make it easier to find things you need without clutter.
Additional InformationA practical example of what I mean: Let's say I'm quickly looking for a table to add to my scene. I open up a model browser. I type the word "table" in a filter field. This causes all models except those containing the word table to be filtered from the entity browser: The directory tree structure remains the same, you still expand folders and subfolders to see and select their contents... it's just that everything else is treated as it doesn't exist in that window, and empty directories (which don't contain contain assets matching the filter or subdirectories with such) are also not shown. This would make it easy to look at all tables available in the asset repository without being hindered by anything else, as if tables are the only models that exist in TDM at that moment.
Tagsgui, search

Relationships

duplicate of 0003250 resolvedgreebo Extend Search-Feature of browsers 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
17.12.2020 15:28 MirceaKitsune New Issue
17.12.2020 15:28 MirceaKitsune Tag Attached: gui
17.12.2020 15:28 MirceaKitsune Tag Attached: search
25.12.2020 09:10 greebo Relationship added related to 0003250
15.01.2021 17:22 greebo Assigned To => greebo
15.01.2021 17:22 greebo Status new => resolved
15.01.2021 17:22 greebo Resolution open => duplicate
15.01.2021 17:22 greebo Fixed in Version => 2.11.0
15.01.2021 17:23 greebo Relationship replaced duplicate of 0003250
15.01.2021 17:23 greebo Target Version => 2.11.0