View Issue Details

IDProjectCategoryView StatusLast Update
0003250DarkRadiantMap Editingpublic16.01.2021 05:37
ReporterSTiFU Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Target Version2.11.0Fixed in Version2.11.0 
Summary0003250: Extend Search-Feature of browsers
DescriptionThe search function in all browsers (like the model browser) is pretty well hidden and also rather limited in its capabilites in that it only shows the first result, that matches the search word. Especially for new mappers, it is hard to find the assets they are looking for, so a proper (and directly visible) search function would be highly appreciated.
TagsNo tags attached.

Relationships

has duplicate 0004789 resolvedgreebo Better searching - entity/textures/model/prefab/folder/inspector windows. 
has duplicate 0005445 resolvedgreebo Filter search for asset browsers 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: resourcetree_filtering fbda72d3

2021-01-06 03:07:19

greebo

Details Diff
0003250: Add filter text entry field to the ResourceTreeViewToolbar Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File

DarkRadiant: resourcetree_filtering a77d3da3

2021-01-09 17:44:53

greebo

Details Diff
0003250: The visibility logic needs to inspect all child nodes too. This is likely to check the same items over and over again, but as long as this is not a performance problem, this can be left as it is. Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: resourcetree_filtering c0f5a443

2021-01-10 05:09:27

greebo

Details Diff
0003250: Try to make the filter search feel more alive by focusing on the first matching item (unless the selected item already matches the filter text). Tweak the toolbar a bit. Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File
mod - libs/wxutil/dataview/TreeView.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File

DarkRadiant: resourcetree_filtering 3af57989

2021-01-10 05:38:00

greebo

Details Diff
0003250: Add up/down button functionality like in the existing search popups Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File

DarkRadiant: resourcetree_filtering c6f0ddfa

2021-01-10 06:21:13

greebo

Details Diff
0003250: Move ResourceTreeViewToolbar implementation to .cpp file Affected Issues
0003250
mod - libs/wxutil/CMakeLists.txt Diff File
add - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: resourcetree_filtering 86f7ee75

2021-01-10 15:29:24

greebo

Details Diff
0003250: Save a few string conversions Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File

DarkRadiant: resourcetree_filtering 1ca4aa65

2021-01-10 16:06:06

greebo

Details Diff
0003250: Move string extraction to TreeModel::ItemValueProxy, refactor some algorithms to reduce code duplication.
ResourceTreeView is now using the configured search columns of the base TreeView to scan the tree model.
Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/TreeModel.cpp Diff File
mod - libs/wxutil/dataview/TreeModel.h Diff File

DarkRadiant: resourcetree_filtering 22e321e4

2021-01-10 16:17:44

greebo

Details Diff
0003250: Privatise Column member, used by friend ColumnRecord. Affected Issues
0003250
mod - libs/wxutil/dataview/TreeModel.h Diff File

DarkRadiant: resourcetree_filtering 986ba880

2021-01-15 03:55:17

greebo

Details Diff
0003250: Some key binds to hopefully make navigation more intuitive Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File

DarkRadiant: resourcetree_filtering b808161a

2021-01-15 04:10:36

greebo

Details Diff
0003250: Make ResourceTreeView more versatile in terms of which column the selection can work with Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: resourcetree_filtering bdd4b450

2021-01-15 04:22:51

greebo

Details Diff
0003250: Fix SoundChooser's selection handling Affected Issues
0003250
mod - radiant/uimanager/SoundChooser.cpp Diff File

DarkRadiant: resourcetree_filtering 27a1de0b

2021-01-15 04:30:35

greebo

Details Diff
0003250: EntityClassChooser clears the filter entry field when showing the dialog Affected Issues
0003250
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File

DarkRadiant: resourcetree_filtering 0e20af86

2021-01-15 05:06:22

greebo

Details Diff
0003250: To rebuild the tree on filter text changes, TreeView::Rebuild is 1) doing too much and 2) is not present in Linux. It turns out a wxDataViewModel::Cleared() call is enough to let the attached view re-query the tree and achieve the desired effect. Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: master afb08f68

2021-01-15 05:44:33

greebo

Details Diff
0003250: Fix Linux compilation Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File

DarkRadiant: master 383c12a7

2021-01-15 17:12:31

greebo

Details Diff
0003250: Paint the search text red when nothing in the tree matches the criteria. Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File

DarkRadiant: master 6937d113

2021-01-15 17:20:30

greebo

Details Diff
0003250: Let's clear the filter entry box when switching between favourite and regular trees.
This is merely to fix a visual glitch where a mismatching red search text remains painted red after switching to a tree which has matches.
Affected Issues
0003250
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File

DarkRadiant: master e04a0798

2021-01-16 03:05:07

greebo

Details Diff
0003250: ModelSelector tweaks Affected Issues
0003250
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File

DarkRadiant: master 90742cc6

2021-01-16 03:53:01

greebo

Details Diff
0003250: Fix TreeModel string comparison function Affected Issues
0003250
mod - libs/wxutil/dataview/TreeModel.cpp Diff File

DarkRadiant: master e0087a71

2021-01-16 03:55:30

greebo

Details Diff
0003250: Remove header from EClassChooser tree view. Affected Issues
0003250
mod - include/version.h Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File

Issue History

Date Modified Username Field Change
09.10.2012 17:33 STiFU New Issue
26.11.2019 15:21 greebo Relationship added related to 0004789
25.12.2020 09:10 greebo Relationship added related to 0005445
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering fbda72d3
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering a77d3da3
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering c0f5a443
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering 3af57989
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering c6f0ddfa
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering 86f7ee75
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering 1ca4aa65
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering 22e321e4
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering 986ba880
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering b808161a
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering bdd4b450
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering 27a1de0b
15.01.2021 05:07 greebo Changeset attached => DarkRadiant resourcetree_filtering 0e20af86
15.01.2021 05:07 greebo Status new => confirmed
15.01.2021 05:07 greebo Target Version => 2.11.0
15.01.2021 05:07 greebo Assigned To => greebo
15.01.2021 05:07 greebo Status confirmed => assigned
15.01.2021 05:54 greebo Changeset attached => DarkRadiant master afb08f68
15.01.2021 17:20 greebo Changeset attached => DarkRadiant master 383c12a7
15.01.2021 17:20 greebo Changeset attached => DarkRadiant master 6937d113
15.01.2021 17:22 greebo Status assigned => resolved
15.01.2021 17:22 greebo Resolution open => fixed
15.01.2021 17:22 greebo Fixed in Version => 2.11.0
15.01.2021 17:23 greebo Relationship replaced has duplicate 0005445
15.01.2021 17:23 greebo Relationship replaced has duplicate 0004789
16.01.2021 03:12 greebo Changeset attached => DarkRadiant master e04a0798
16.01.2021 05:37 greebo Changeset attached => DarkRadiant master 90742cc6
16.01.2021 05:37 greebo Changeset attached => DarkRadiant master e0087a71