View Issue Details

IDProjectCategoryView StatusLast Update
0005452DarkRadiantScriptingpublic21.12.2020 06:27
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.9.1 
Target Version2.10.0Fixed in Version2.10.0 
Summary0005452: Upgrade pybind11 dependencies
DescriptionThe pybind11 sources that have been shipping with DR are rather old - upgrade them to be able to make use of the newer features, especially pybind11's embedding API.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: pybind11_upgrade b84b373b

2020-12-20 11:24:38

greebo

Details Diff
0005452: Upgrade pybind11 sources that are shipped with DR. Affected Issues
0005452
mod - libs/pybind/pybind11/attr.h Diff File
add - libs/pybind/pybind11/buffer_info.h Diff File
mod - libs/pybind/pybind11/cast.h Diff File
mod - libs/pybind/pybind11/chrono.h Diff File
rm - libs/pybind/pybind11/class_support.h Diff File
mod - libs/pybind/pybind11/common.h Diff File
mod - libs/pybind/pybind11/complex.h Diff File
rm - libs/pybind/pybind11/descr.h Diff File
add - libs/pybind/pybind11/detail/class.h Diff File
add - libs/pybind/pybind11/detail/common.h Diff File
add - libs/pybind/pybind11/detail/descr.h Diff File
add - libs/pybind/pybind11/detail/init.h Diff File
add - libs/pybind/pybind11/detail/internals.h Diff File
mod - libs/pybind/pybind11/eigen.h Diff File
add - libs/pybind/pybind11/embed.h Diff File
mod - libs/pybind/pybind11/eval.h Diff File
mod - libs/pybind/pybind11/functional.h Diff File
add - libs/pybind/pybind11/iostream.h Diff File
mod - libs/pybind/pybind11/numpy.h Diff File
mod - libs/pybind/pybind11/operators.h Diff File
mod - libs/pybind/pybind11/options.h Diff File
mod - libs/pybind/pybind11/pybind11.h Diff File
mod - libs/pybind/pybind11/pytypes.h Diff File
mod - libs/pybind/pybind11/stl.h Diff File
mod - libs/pybind/pybind11/stl_bind.h Diff File

DarkRadiant: pybind11_upgrade 4a643a91

2020-12-20 13:24:39

greebo

Details Diff
0005452: Start upgrading PythonModule class to an actual instance housing the module and the globals. Affected Issues
0005452
mod - include/iscriptinterface.h Diff File
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/PythonModule.h Diff File
mod - plugins/script/ScriptingSystem.cpp Diff File
mod - plugins/script/ScriptingSystem.h Diff File

DarkRadiant: pybind11_upgrade 7323145a

2020-12-20 13:45:07

greebo

Details Diff
0005452: PythonModule instance is owned by ScriptingSystem now.
Due to the C-style Python API we still need a few statics around.
Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/PythonModule.h Diff File
mod - plugins/script/ScriptingSystem.cpp Diff File
mod - plugins/script/ScriptingSystem.h Diff File

DarkRadiant: pybind11_upgrade c27e326c

2020-12-20 13:59:51

greebo

Details Diff
0005452: Interpreter initialisation is now handled in PythonModule internally Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/PythonModule.h Diff File
mod - plugins/script/ScriptingSystem.cpp Diff File

DarkRadiant: pybind11_upgrade ee9607e5

2020-12-20 14:34:13

greebo

Details Diff
0005452: Move the console writers to PythonModule Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/PythonModule.h Diff File
mod - plugins/script/ScriptingSystem.cpp Diff File
mod - plugins/script/ScriptingSystem.h Diff File

DarkRadiant: pybind11_upgrade 65bd8b36

2020-12-20 14:55:07

greebo

Details Diff
0005452: Privatise the python module name Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/PythonModule.h Diff File

DarkRadiant: pybind11_upgrade c36d8ff9

2020-12-20 15:11:22

greebo

Details Diff
0005452: Since all platforms are using pybind11 from DR's git, we can skip all that version checks Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File

DarkRadiant: pybind11_upgrade c0bd5242

2020-12-20 15:42:07

greebo

Details Diff
0005452: More shifting around, less static members and cross-references Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/PythonModule.h Diff File
mod - plugins/script/ScriptingSystem.cpp Diff File
mod - plugins/script/ScriptingSystem.h Diff File

DarkRadiant: pybind11_upgrade b7eb9a95

2020-12-20 15:49:01

greebo

Details Diff
0005452: Privatise the py::module member Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/PythonModule.h Diff File

DarkRadiant: pybind11_upgrade 11e5a7f8

2020-12-20 17:06:40

greebo

Details Diff
0005452 Fix compilation in gcc Affected Issues
0005452
mod - plugins/script/PythonModule.cpp Diff File
mod - plugins/script/ScriptingSystem.cpp Diff File

DarkRadiant: pybind11_upgrade 94fd4595

2020-12-20 17:07:21

greebo

Details Diff
0005452 Set -fvisibility=hidden compiler flag for the scripting module Affected Issues
0005452
mod - plugins/script/CMakeLists.txt Diff File

DarkRadiant: pybind11_upgrade 5e72bc8c

2020-12-20 17:54:06

greebo

Details Diff
0005452 Set the RegisterModule symbol explicitly to visibility=default for gcc Affected Issues
0005452
mod - include/imodule.h Diff File

Issue History

Date Modified Username Field Change
20.12.2020 11:23 greebo New Issue
20.12.2020 11:23 greebo Status new => confirmed
20.12.2020 11:23 greebo Assigned To => greebo
20.12.2020 11:23 greebo Status confirmed => assigned
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade b84b373b
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade 4a643a91
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade 7323145a
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade c27e326c
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade ee9607e5
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade 65bd8b36
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade c36d8ff9
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade c0bd5242
20.12.2020 15:49 greebo Changeset attached => DarkRadiant pybind11_upgrade b7eb9a95
20.12.2020 17:54 greebo Changeset attached => DarkRadiant pybind11_upgrade 11e5a7f8
20.12.2020 17:54 greebo Changeset attached => DarkRadiant pybind11_upgrade 94fd4595
20.12.2020 17:54 greebo Changeset attached => DarkRadiant pybind11_upgrade 5e72bc8c
21.12.2020 06:27 greebo Target Version => 2.10.0
21.12.2020 06:27 greebo Status assigned => resolved
21.12.2020 06:27 greebo Resolution open => fixed
21.12.2020 06:27 greebo Fixed in Version => 2.10.0