View Issue Details

IDProjectCategoryView StatusLast Update
0005455DarkRadiantGUIpublic05.09.2021 18:22
ReporterDragofer Assigned Togreebo  
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2.9.1 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005455: Prefab Chooser preview: improvements to initial view
Description- If the prefab author exported the prefab far away from the map's origin, the prefab might not show up at all in the preview.
- If the prefab contains something with a very large radius, i.e. a speaker or light, the whole prefab will appear very zoomed out, since the preview tries to capture the whole thing.
- Making the preview camera look more towards the north. This way, the preview would show the prefab (close to) the same way as it'll show up in orthoview. This would make it somewhat easier to deal with prefabs that come in 4 variants, one per direction.

These things make it more difficult to go through a list of prefabs to choose one, so it'd be neat if the Prefab Chooser automatically centered on the prefab's midpoint rather than 0,0,0, and disregarded the radius of lights and speakers when calculating the initial zoom level.
TagsNo tags attached.

Relationships

related to 0005502 acknowledged Broken rendering of prefabs in Prefab Chooser preview on AMD cards 

Activities

Dragofer

Dragofer

24.12.2020 13:10

developer   ~0013189

Last edited: 24.12.2020 13:23

The ticket has been transformed successfully. Would probably have been better to just delete & create new, tbh.
Dragofer

Dragofer

17.01.2021 12:43

developer   ~0013475

Last edited: 17.01.2021 12:51

Another thing that I think could be helpful: making the preview camera look more towards the north. This way, the preview would show the prefab (close to) the same way as it'll show up in orthoview. This would make it somewhat easier to deal with prefabs that come in 4 variants, one per direction.

I've attached a comparison of what one currently sees in the preview, compared to how it ends up in orthoview, using the north-facing prefab for the new animated steam engine. There's a difference of maybe 150° between the 2, maybe a 30° difference would be better.
Preview.png (111,906 bytes)   
Preview.png (111,906 bytes)   
How it ends up in orthoview.png (21,722 bytes)   
How it ends up in orthoview.png (21,722 bytes)   
Dragofer

Dragofer

24.01.2021 21:43

developer   ~0013505

Last edited: 24.01.2021 21:49

One last comment during pre5: in pre4 I thought the camera's position was too high, so I suggested to lower it to a certain level, but tbh that feels too low now.

The sweet spot would probably be halfway between the pre4 and pre5 heights. I think that's also how the height was before 2.11.

Related Changesets

DarkRadiant: master 8aae7f8d

2021-01-17 06:29:59

greebo

Details Diff
0005455: MapPreview should focus on the scene bounds origin, not the world origin. Many prefabs have been saved with their elements placed off-center. Affected Issues
0005455
mod - radiant/ui/common/MapPreview.cpp Diff File

DarkRadiant: master 3b3f2294

2021-01-17 07:08:37

greebo

Details Diff
0005455: Move the AABBAccumulateWalker to a separate header so it can be subclassed by a custom PrefabBoundsAccumulator.
Since lights and speakers are just needlessly adding huge AABBs to the result, the PrefabBoundsAccumulator will ignore those (WIP).
Affected Issues
0005455
add - libs/scene/AABBAccumulateWalker.h Diff File
mod - libs/scene/Node.cpp Diff File
add - libs/scene/PrefabBoundsAccumulator.h Diff File
mod - radiant/ui/common/MapPreview.cpp Diff File
mod - tools/msvc/scenelib.vcxproj Diff File
mod - tools/msvc/scenelib.vcxproj.filters Diff File

DarkRadiant: master 9a3d663b

2021-01-17 13:13:48

greebo

Details Diff
0005455: Introduce ISpeakerNode interface to get more useful bounds when calculating the prefab size. Affected Issues
0005455
add - include/ispeakernode.h Diff File
mod - libs/scene/PrefabBoundsAccumulator.h Diff File
mod - radiantcore/entity/speaker/SpeakerNode.cpp Diff File
mod - radiantcore/entity/speaker/SpeakerNode.h Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: master 8290fa27

2021-01-21 17:47:45

greebo

Details Diff
0005455: Tweak the initial viewing angle and position, the orient the prefabs more like they're ending up in the XY top view. Affected Issues
0005455
mod - radiant/ui/common/MapPreview.cpp Diff File

DarkRadiant: master b0e44f30

2021-01-24 04:57:44

greebo

Details Diff
0005455: Adjust grid center to be located at the scene's origin Affected Issues
0005455
mod - libs/wxutil/preview/RenderPreview.cpp Diff File

DarkRadiant: master 52960b4d

2021-01-25 04:20:46

greebo

Details Diff
0005455: Tweak view position Affected Issues
0005455
mod - radiant/ui/common/MapPreview.cpp Diff File

Issue History

Date Modified Username Field Change
24.12.2020 11:04 Dragofer New Issue
24.12.2020 11:10 Dragofer Additional Information Updated
24.12.2020 11:15 Dragofer Additional Information Updated
24.12.2020 11:56 greebo Status new => feedback
24.12.2020 12:19 Dragofer Status feedback => new
24.12.2020 13:10 Dragofer Summary Feature: rotate view in Prefab Chooser preview => Prefab Chooser preview: improvements to initial centration & zoom
24.12.2020 13:10 Dragofer Description Updated
24.12.2020 13:10 Dragofer Additional Information Updated
24.12.2020 13:10 Dragofer Note Added: 0013189
24.12.2020 13:23 Dragofer Note Edited: 0013189
24.12.2020 18:02 greebo Status new => acknowledged
17.01.2021 06:28 greebo Status acknowledged => confirmed
17.01.2021 06:28 greebo Target Version => 2.11.0
17.01.2021 06:28 greebo Assigned To => greebo
17.01.2021 06:28 greebo Status confirmed => assigned
17.01.2021 12:43 Dragofer Note Added: 0013475
17.01.2021 12:43 Dragofer File Added: Preview.png
17.01.2021 12:43 Dragofer File Added: How it ends up in orthoview.png
17.01.2021 12:44 Dragofer Description Updated
17.01.2021 12:44 Dragofer Note Edited: 0013475
17.01.2021 12:45 Dragofer Note Edited: 0013475
17.01.2021 12:51 Dragofer Note Edited: 0013475
17.01.2021 12:59 Dragofer Summary Prefab Chooser preview: improvements to initial centration & zoom => Prefab Chooser preview: improvements to initial view
21.01.2021 17:48 greebo Changeset attached => DarkRadiant master 8aae7f8d
21.01.2021 17:48 greebo Changeset attached => DarkRadiant master 3b3f2294
21.01.2021 17:48 greebo Changeset attached => DarkRadiant master 9a3d663b
21.01.2021 17:48 greebo Changeset attached => DarkRadiant master 8290fa27
21.01.2021 17:48 greebo Status assigned => resolved
21.01.2021 17:48 greebo Resolution open => fixed
21.01.2021 17:48 greebo Fixed in Version => 2.11.0
24.01.2021 04:57 greebo Changeset attached => DarkRadiant master b0e44f30
24.01.2021 16:36 Dragofer Relationship added related to 0005502
24.01.2021 21:43 Dragofer Note Added: 0013505
24.01.2021 21:45 Dragofer Status resolved => feedback
24.01.2021 21:45 Dragofer Resolution fixed => reopened
24.01.2021 21:48 Dragofer Note Edited: 0013505
24.01.2021 21:49 Dragofer Note Edited: 0013505
25.01.2021 04:20 greebo Changeset attached => DarkRadiant master 52960b4d
25.01.2021 04:21 greebo Status feedback => resolved
25.01.2021 04:21 greebo Resolution reopened => fixed
05.09.2021 18:22 greebo Status resolved => closed