View Issue Details

IDProjectCategoryView StatusLast Update
0005481The Dark ModModelspublic01.01.2021 16:20
ReporterSpooks Assigned ToDragofer  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.08 
Target VersionTDM 2.09Fixed in VersionTDM 2.09 
Summary0005481: Ornate chandeliers look too bright because of duplicate geometry
Description"models/darkmod/lights/non-extinguishable/chandelier_ornate01.lwo"
"models/darkmod/lights/non-extinguishable/chandelier_ornate02.lwo"

These two models look like they have a duplicate mesh - the body of both is too bright, as if twice textured. Interestingly, in "ornate01", the unlit skin looks okay but the lit one, as well as every skin of "ornate02", they all look wrong.
Steps To ReproducePlace either of the two chandeliers in a dark room, with their lit skins. You'll see that their metal bodies are overbright. With the new bloom it's especially obvious.
Additional InformationThe offending material seems to be "tdm_chalice_gold_lit", which makes up the body of the chandeliers (but not the chains, which for some reason use "tdm_chalice_gold"). As an afterthought, there should only be one material for chain and body.
TagsNo tags attached.

Activities

Dragofer

Dragofer

01.01.2021 16:19

developer   ~0013339

Last edited: 01.01.2021 16:20

View 3 revisions

Rev 16062.

chandelier_ornate01 is fine, the problem was that it was used with a default skin, neither "lit" nor "unlit".
chandelier_ornate02 had problems with:
- materials: no self-lit material for teapot_gold_clean existed
- skins: no unlit skin, skins didn't switch all materials that needed to be switched

Also fixed a duplicate line (display folder) in the entity def for a related lamp.

No mesh duplication, it only appeared this way because:
- the chandeliers use selflit metal materials when lit (intentional)
- DR's skin display lists a material multiple times if multiple surfaces switch to it in a skin.

Issue History

Date Modified Username Field Change
31.12.2020 15:40 Spooks New Issue
01.01.2021 16:19 Dragofer Assigned To => Dragofer
01.01.2021 16:19 Dragofer Status new => resolved
01.01.2021 16:19 Dragofer Resolution open => fixed
01.01.2021 16:19 Dragofer Note Added: 0013339
01.01.2021 16:19 Dragofer Fixed in Version => TDM 2.09
01.01.2021 16:19 Dragofer Target Version => TDM 2.09
01.01.2021 16:19 Dragofer Note Edited: 0013339 View Revisions
01.01.2021 16:20 Dragofer Note Edited: 0013339 View Revisions