View Issue Details

IDProjectCategoryView StatusLast Update
0005487The Dark ModGraphicspublic10.01.2021 03:40
Reporternbohr1more Assigned Tocabalistic  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
OSLinux 
Product VersionSVN 
Target VersionTDM 2.09Fixed in VersionTDM 2.09 
Summary0005487: "image_preload 0" breaks rendering if SSAO or Bloom are enabled
DescriptionSetting "image_preload" to "0" is supposed to force the engine to dynamically load textures as needed to save on VRAM

2.09 (?) rendering changes have broke this feature.

We either need to un-archive the cvar, remove the cvar or fix it.
Steps To Reproduce1) Start TDM with default settings
2) Open the console and invoke image_preload 0
3) Restart TDM
4) Enable SSAO
5) Restart TDM
6) Start a mission
7) Note that the screen is black on load
8) Kill TDM
9) Start TDM
10) Disable SSAO and enable Bloom
11) Start a mission
12) Note that a distorted Bloom image is all that is rendered
TagsNo tags attached.

Relationships

related to 0005433 resolvedstgatilov Random crash when dynamically loading textures 

Activities

duzenko

duzenko

07.01.2021 14:52

developer   ~0013420

@nbohr1more
Seems to work for me as usual on current SVN
Quick load in a small room with 1.1 GB used VRAM
Noclip and fly over to grow usage to 1.6 GB with obvious stuttering when the textures queue to upload
BTW this cvar in its current implementation is targeted for quicker mission load (i.e. game world start) rather than saving VRAM
nbohr1more

nbohr1more

07.01.2021 15:25

developer   ~0013421

Last edited: 07.01.2021 21:24

View 3 revisions

Hmm... Maybe it's only broken on Linux?

Edit: Forum reports indicate that only Linux is affected
nbohr1more

nbohr1more

08.01.2021 03:44

developer   ~0013424

Updated the description.

This only affects Bloom or SSAO

That said, when image_preload is disabled the GUI flickers with messy white textures when transitioning animations too.
nbohr1more

nbohr1more

08.01.2021 04:35

developer   ~0013425

It turns out that this sequence works live with no restarts:

1) Disable SSAO and Bloom
2) Set image_preload 0
3) Start the mission
4) Set image_preload 1
5) Enable SSAO and Bloom
6) Set image_preload 0

This does still have quirks with GUI elements flashing but it seems to retain the intended design.
cabalistic

cabalistic

09.01.2021 16:31

developer   ~0013428

It's fixed on trunk.
nbohr1more

nbohr1more

09.01.2021 21:49

developer   ~0013431

I can confirm that the game now renders when SSAO is enabled and image_preload = 0

There is one last issue, which is that if you set SSAO and image_preload 0 there will be no SSAO effect
when you start the mission.
cabalistic

cabalistic

09.01.2021 22:14

developer   ~0013432

This "feature" is getting on my nerves... Fixed.

Seriously, though, we may want to invest some time in proper load time reductions...
nbohr1more

nbohr1more

09.01.2021 22:29

developer   ~0013433

Last edited: 10.01.2021 03:40

View 3 revisions

Fix confirmed! Thank you!

Yes, the image_preload dichotomy is a pretty bad implementation.

Carmack thought that the normal "asset loading zone" design for open-world games was ugly so he avoided it with all his might.

Then he invented "megatexture" as the "better version" of an asset loading design.

I guess now that the kinks have been worked out in megatexture he has been somewhat vindicated.

Issue History

Date Modified Username Field Change
06.01.2021 14:33 nbohr1more New Issue
06.01.2021 14:33 nbohr1more Status new => assigned
06.01.2021 14:33 nbohr1more Assigned To => stgatilov
06.01.2021 14:34 nbohr1more Relationship added related to 0005433
06.01.2021 15:38 stgatilov Assigned To stgatilov => cabalistic
07.01.2021 14:52 duzenko Note Added: 0013420
07.01.2021 15:25 nbohr1more Note Added: 0013421
07.01.2021 15:25 nbohr1more Note Edited: 0013421 View Revisions
07.01.2021 21:23 nbohr1more OS => Linux
07.01.2021 21:24 nbohr1more Note Edited: 0013421 View Revisions
08.01.2021 03:42 nbohr1more Summary "image_preload 0" no longer functions => "image_preload 0" breaks rendering if SSAO or Bloom are enabled
08.01.2021 03:42 nbohr1more Steps to Reproduce Updated View Revisions
08.01.2021 03:44 nbohr1more Note Added: 0013424
08.01.2021 04:35 nbohr1more Note Added: 0013425
09.01.2021 16:31 cabalistic Note Added: 0013428
09.01.2021 16:32 cabalistic Status assigned => resolved
09.01.2021 16:32 cabalistic Resolution open => fixed
09.01.2021 16:32 cabalistic Fixed in Version => TDM 2.09
09.01.2021 21:49 nbohr1more Note Added: 0013431
09.01.2021 22:14 cabalistic Note Added: 0013432
09.01.2021 22:29 nbohr1more Note Added: 0013433
10.01.2021 03:39 nbohr1more Note Edited: 0013433 View Revisions
10.01.2021 03:40 nbohr1more Note Edited: 0013433 View Revisions