View Issue Details

IDProjectCategoryView StatusLast Update
0000055DarkRadiantGUIpublic26.02.2007 00:20
ReporterSneaksieDave Assigned ToSneaksieDave  
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.8.0 
Summary0000055: Option to close dialogs with ESC
DescriptionEdit by SneaksieDave: to clarify - I mean the Surface Properties dialog (S), Patch Props (Shift-S) etc; NOT the inspectors window.

Source:
http://modetwo.net/darkmod/index.php?s=&showtopic=4735&view=findpost&p=88426

ESC to close dialogs
If a dialog like the surface inspector is open and has focus in D3Ed, hitting ESC will close it. Not so in DR. Just a user-friendliness thing.
---
Perhaps this should be an option? There is some usefulness to being able to leave an edit dialog (like surface properties) open while deselecting and reselecting other entities (or faces).
TagsNo tags attached.

Activities

greebo

greebo

27.01.2007 08:07

administrator   ~0000021

Making it an option is probably the best way to go, because I personally prefer to be able to de-select and re-select things when dialogs are open.
SneaksieDave

SneaksieDave

11.02.2007 19:35

developer   ~0000091

To further advance that it should be Optional if it is implemented at all: I just realized you can hit S again to close Surface Properties, Shift-S to close Patch Props, etc. Pretty convenient.

Currently doesn't work for Light Properties... will track that separate.
greebo

greebo

25.02.2007 20:02

administrator   ~0000227

Is this still an issue?
SneaksieDave

SneaksieDave

26.02.2007 00:20

developer   ~0000230

No, I don't feel it's an issue anymore. ESC might be a nice convenience, and a behavior carryover from DoomEd, but I think overall it's just as easy to toggle a key which opened the dialog, and it's more convenient to be able to leave it open and deselect (e.g. surfaces) and leave one open but not another, selectively.

Issue History

Date Modified Username Field Change
27.01.2007 02:45 SneaksieDave New Issue
27.01.2007 02:46 SneaksieDave Severity minor => feature
27.01.2007 02:46 SneaksieDave Description Updated
27.01.2007 08:07 greebo Note Added: 0000021
27.01.2007 08:07 greebo Status new => acknowledged
11.02.2007 19:35 SneaksieDave Note Added: 0000091
11.02.2007 21:42 SneaksieDave Description Updated
25.02.2007 20:02 greebo Note Added: 0000227
25.02.2007 20:02 greebo Assigned To => SneaksieDave
25.02.2007 20:02 greebo Status acknowledged => feedback
26.02.2007 00:20 SneaksieDave Status feedback => closed
26.02.2007 00:20 SneaksieDave Note Added: 0000230
26.02.2007 00:20 SneaksieDave Resolution open => fixed