View Issue Details

IDProjectCategoryView StatusLast Update
0005527DarkRadiantDesign/Codingpublic05.09.2021 18:21
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityN/A
Status closedResolutionfixed 
Product Version2.12.0 
Target Version2.12.0Fixed in Version2.12.0 
Summary0005527: UI Manager cleanup
DescriptionA housekeeping task. Since most of the UI code is either in the main binary or wxutil, the need for a separate UI manager class has become smaller now. It's not going to go away completely, but shared stuff can be moved to wxutil or into separate modules.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 9f26b942

2021-02-06 05:04:16

greebo

Details Diff
0005527: Move FilterMenu class to wxutil, it's only used by the RenderPreview class which happens to be in wxutil too.
Rename class to FilterPopupMenu. Remove the global interface for it.
Affected Issues
0005527
rm - include/ifiltermenu.h Diff File
mod - include/iuimanager.h Diff File
mod - include/precompiled_interfaces.h Diff File
mod - libs/wxutil/CMakeLists.txt Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - libs/wxutil/preview/RenderPreview.h Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/include.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 2279efed

2021-02-06 05:10:12

greebo

Details Diff
0005527: FilterPopupMenu inherits from wxutil::PopupMenu because that's what it is Affected Issues
0005527
mod - libs/wxutil/menu/FilterPopupMenu.cpp Diff File
mod - libs/wxutil/menu/FilterPopupMenu.h Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File

DarkRadiant: master 3736c00e

2021-02-06 05:14:49

greebo

Details Diff
0005527: Fix a name collision compiler warning Affected Issues
0005527
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File

DarkRadiant: master db5acfe5

2021-02-06 10:06:51

greebo

Details Diff
0005527: Extract status bar manager interface to separate file. Affected Issues
0005527
add - include/istatusbarmanager.h Diff File
mod - include/iuimanager.h Diff File
mod - radiant/eventmanager/MouseToolManager.cpp Diff File
mod - radiant/ui/grid/GridUserInterface.cpp Diff File
mod - radiant/ui/mainframe/TopLevelFrame.cpp Diff File
mod - radiant/ui/shaderclipboard/ShaderClipboardStatus.h Diff File
mod - radiant/ui/statusbar/EditingStopwatchStatus.cpp Diff File
mod - radiant/uimanager/StatusBarManager.cpp Diff File
mod - radiant/uimanager/StatusBarManager.h Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - radiant/xyview/GlobalXYWnd.cpp Diff File
mod - radiant/xyview/XYWnd.cpp Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: master b7022c4a

2021-02-06 14:48:14

greebo

Details Diff
0005527: Move map statistics status bar widget into its own object. Affected Issues
0005527
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/ui/UserInterfaceModule.h Diff File
add - radiant/ui/statusbar/MapStatistics.cpp Diff File
add - radiant/ui/statusbar/MapStatistics.h Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - radiant/xyview/GlobalXYWnd.cpp Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master d414d9c1

2021-02-06 15:03:57

greebo

Details Diff
0005527: Move more classes to ui::statusbar namespace. Affected Issues
0005527
mod - include/istatusbarmanager.h Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/ui/UserInterfaceModule.h Diff File
mod - radiant/ui/grid/GridUserInterface.cpp Diff File
mod - radiant/ui/statusbar/EditingStopwatchStatus.cpp Diff File
mod - radiant/ui/statusbar/EditingStopwatchStatus.h Diff File
mod - radiant/ui/statusbar/MapStatistics.cpp Diff File
mod - radiant/ui/statusbar/StatusBarManager.cpp Diff File
mod - radiant/ui/statusbar/StatusBarManager.h Diff File
mod - radiant/xyview/GlobalXYWnd.cpp Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master aec77c09

2021-02-06 15:09:11

greebo

Details Diff
0005527: Move constant to the one place it's being used Affected Issues
0005527
mod - include/istatusbarmanager.h Diff File
mod - radiant/eventmanager/MouseToolManager.cpp Diff File
mod - radiant/ui/statusbar/StatusBarManager.cpp Diff File

DarkRadiant: master eaca85ec

2021-02-06 17:10:21

greebo

Details Diff
0005527: Make ToolbarManager a separate module, extract interface to itoolbarmanager.h Affected Issues
0005527
add - include/itoolbarmanager.h Diff File
mod - include/iuimanager.h Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/textool/TexTool.cpp Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/ui/mainframe/TopLevelFrame.cpp Diff File
mod - radiant/ui/mainframe/TopLevelFrame.h Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: master d3f3cf0a

2021-02-07 06:08:36

greebo

Details Diff
0005527: Move MenuManager to separate interface file imenumanager.h, refactor namespace a bit. Affected Issues
0005527
add - include/imenumanager.h Diff File
mod - include/iuimanager.h Diff File
mod - plugins/dm.conversation/plugin.cpp Diff File
mod - plugins/dm.difficulty/plugin.cpp Diff File
mod - plugins/dm.editing/plugin.cpp Diff File
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - plugins/dm.gui/plugin.cpp Diff File
mod - plugins/dm.objectives/objectives.cpp Diff File
mod - plugins/dm.stimresponse/plugin.cpp Diff File
mod - radiant/ui/filters/FiltersMainMenu.cpp Diff File
mod - radiant/ui/mainframe/EmbeddedLayout.cpp Diff File
mod - radiant/ui/mainframe/LayoutCommand.h Diff File
mod - radiant/ui/mainframe/RegularLayout.cpp Diff File
mod - radiant/ui/mainframe/SplitPaneLayout.cpp Diff File
mod - radiant/ui/mainframe/TopLevelFrame.cpp Diff File
mod - radiant/ui/mru/MRUMenu.h Diff File
mod - radiant/ui/script/ScriptMenu.cpp Diff File
mod - radiant/ui/script/ScriptUserInterfaceModule.cpp Diff File
mod - radiant/ui/statusbar/StatusBarManager.cpp Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - radiant/uimanager/menu/MenuBar.cpp Diff File
mod - radiant/uimanager/menu/MenuBar.h Diff File
mod - radiant/uimanager/menu/MenuElement.cpp Diff File
mod - radiant/uimanager/menu/MenuElement.h Diff File
mod - radiant/uimanager/menu/MenuFolder.cpp Diff File
mod - radiant/uimanager/menu/MenuFolder.h Diff File
mod - radiant/uimanager/menu/MenuItem.cpp Diff File
mod - radiant/uimanager/menu/MenuItem.h Diff File
mod - radiant/uimanager/menu/MenuManager.cpp Diff File
mod - radiant/uimanager/menu/MenuManager.h Diff File
mod - radiant/uimanager/menu/MenuRootElement.h Diff File
mod - radiant/uimanager/menu/MenuSeparator.cpp Diff File
mod - radiant/uimanager/menu/MenuSeparator.h Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: master 47202d3b

2021-02-07 06:11:24

greebo

Details Diff
0005527: Move MenuManager files to ui/menu/ Affected Issues
0005527
mod - radiant/CMakeLists.txt Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master dcf6d394

2021-02-07 06:59:52

greebo

Details Diff
0005527: Linux build adjusted Affected Issues
0005527
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/mainframe/EmbeddedLayout.cpp Diff File
mod - radiant/ui/mainframe/RegularLayout.cpp Diff File
mod - radiant/ui/mainframe/SplitPaneLayout.cpp Diff File
mod - radiant/ui/mainframe/TopLevelFrame.cpp Diff File
mod - radiant/ui/script/ScriptUserInterfaceModule.cpp Diff File

DarkRadiant: master 4021f236

2021-02-07 07:05:29

greebo

Details Diff
0005527: Move animation preview and colourscheme editor to ui/ folder Affected Issues
0005527
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/uimanager/DialogManager.cpp Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 751d8f9a

2021-02-07 07:13:26

greebo

Details Diff
0005527: Handle art provider (de-)registration in the LocalBitmapArtProvider class itself Affected Issues
0005527
mod - radiant/uimanager/LocalBitmapArtProvider.h Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File

DarkRadiant: master 01a74f13

2021-02-07 07:26:55

greebo

Details Diff
0005527: Move LocalBitmapArtProvider to wxutil library. Rename bitmap.h filename to leading uppercase to fit the rest of the files. Affected Issues
0005527
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - radiant/ui/menu/MenuItem.cpp Diff File
mod - radiant/ui/statusbar/StatusBarManager.cpp Diff File
mod - radiant/ui/toolbar/ToolbarManager.cpp Diff File
mod - radiant/uimanager/GroupDialog.cpp Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master ca89e71c

2021-02-07 07:35:53

greebo

Details Diff
0005527: Use wxutil::GetLocalBitmap to be more concise about where the method is loading bitmaps from.
GetLocalBitmap is directly referencing the LocalBitmapArtProvider static prefix, bypassing the UI manager module.
Construct LocalBitmapArtProvider with the search path instead of having it look up the path every time from the application context.
Affected Issues
0005527
mod - libs/wxutil/Bitmap.h Diff File
mod - libs/wxutil/LocalBitmapArtProvider.h Diff File
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - radiant/ui/menu/MenuItem.cpp Diff File
mod - radiant/ui/statusbar/StatusBarManager.cpp Diff File
mod - radiant/ui/toolbar/ToolbarManager.cpp Diff File
mod - radiant/uimanager/GroupDialog.cpp Diff File
mod - radiant/uimanager/UIManager.cpp Diff File

DarkRadiant: master 4a396dd8

2021-02-07 07:54:32

greebo

Details Diff
0005527: Replace all occurrences of wxArtProvider::GetBitmap(GlobalUIManager().getArtIdPrefix() + "bla") with wxutil::GetLocalBitmap("bla").
The UI manager module no longer exposes that prefix, now that wxutil::GetLocalBitmap is the only client.
Affected Issues
0005527
mod - include/iuimanager.h Diff File
mod - libs/wxutil/Bitmap.h Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File
mod - libs/wxutil/dataview/TreeView.cpp Diff File
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/menu/IconTextMenuItem.h Diff File
mod - libs/wxutil/preview/ParticlePreview.cpp Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - libs/wxutil/window/TransientWindow.cpp Diff File
mod - plugins/dm.conversation/CommandArgumentItem.cpp Diff File
mod - plugins/dm.editing/AIEditingPanel.cpp Diff File
mod - plugins/dm.editing/AIHeadPropertyEditor.cpp Diff File
mod - plugins/dm.editing/AIVocalSetPreview.cpp Diff File
mod - plugins/dm.editing/AIVocalSetPropertyEditor.cpp Diff File
mod - plugins/dm.gui/GuiSelector.cpp Diff File
mod - plugins/dm.gui/XDataSelector.cpp Diff File
mod - plugins/dm.stimresponse/SREntity.cpp Diff File
mod - plugins/dm.stimresponse/StimTypes.cpp Diff File
mod - radiant/ui/aas/AasControl.cpp Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/eclasstree/EClassTree.cpp Diff File
mod - radiant/ui/eclasstree/EClassTreeBuilder.cpp Diff File
mod - radiant/ui/einspector/AddPropertyDialog.cpp Diff File
mod - radiant/ui/einspector/AnglePropertyEditor.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/ModelPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.cpp Diff File
mod - radiant/ui/einspector/SkinChooser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/layers/LayerControl.cpp Diff File
mod - radiant/ui/mainframe/TopLevelFrame.cpp Diff File
mod - radiant/ui/mapinfo/MapInfoDialog.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/modelselector/ModelPopulator.h Diff File
mod - radiant/ui/patch/CapDialog.cpp Diff File
mod - radiant/ui/patch/PatchInspector.cpp Diff File
mod - radiant/ui/selectionset/SelectionSetToolmenu.cpp Diff File
mod - radiant/ui/surfaceinspector/SurfaceInspector.cpp Diff File
mod - radiant/ui/transform/TransformDialog.cpp Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File
mod - radiant/uimanager/SoundShaderPreview.cpp Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File

DarkRadiant: master 7a7207fd

2021-02-07 08:07:29

greebo

Details Diff
0005527: Since modules cannot know that the UI manager is registering the local art provider, or rely on it happening in time, the LocalBitmapArtProvider is now instantiated right at application startup in RadiantApp. Affected Issues
0005527
mod - radiant/RadiantApp.cpp Diff File
mod - radiant/RadiantApp.h Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File

DarkRadiant: master 11cd8c26

2021-02-07 08:48:47

greebo

Details Diff
0005527: Move static wx initialisation code to RadiantApp, add the corresponding tear down calls rather than leaving the app without cleanup. Affected Issues
0005527
mod - radiant/RadiantApp.cpp Diff File
mod - radiant/RadiantApp.h Diff File
mod - radiant/uimanager/UIManager.cpp Diff File

DarkRadiant: master c9616814

2021-02-07 08:55:32

greebo

Details Diff
0005527: Initialise the PNG and JPEG image handlers only, we don't need the rest for loading our local icons and bitmaps. Affected Issues
0005527
mod - radiant/RadiantApp.cpp Diff File

DarkRadiant: master ad503384

2021-02-07 09:51:38

greebo

Details Diff
0005527: DialogManager is a separate module now Affected Issues
0005527
mod - include/idialogmanager.h Diff File
mod - include/iuimanager.h Diff File
mod - plugins/script/interfaces/DialogInterface.cpp Diff File
mod - radiant/uimanager/DialogManager.cpp Diff File
mod - radiant/uimanager/DialogManager.h Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File

DarkRadiant: master 79e6118e

2021-02-07 15:07:38

greebo

Details Diff
0005527: With the GroupDialog instance getter as the only service left, the UIManager is now demoted to a GroupDialogManager. Affected Issues
0005527
mod - include/iuimanager.h Diff File
mod - radiant/camera/CameraWndManager.cpp Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/favourites/FavouritesUserInterfaceModule.cpp Diff File
mod - radiant/ui/mainframe/MainFrameLayoutManager.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - radiant/ui/ortho/OrthoContextMenu.cpp Diff File
mod - radiant/uimanager/UIManager.cpp Diff File
mod - radiant/uimanager/UIManager.h Diff File
mod - radiant/xyview/GlobalXYWnd.cpp Diff File

DarkRadiant: master 0ffee640

2021-02-07 15:13:16

greebo

Details Diff
0005527: More files renamed and moved to the ui/ folder Affected Issues
0005527
mod - radiant/CMakeLists.txt Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 88224147

2021-02-07 15:37:55

greebo

Details Diff
0005527: Move remaining parts of iuimanager.h to igroupdialog.h. Affected Issues
0005527
mod - include/igroupdialog.h Diff File
mod - include/iuimanager.h Diff File
mod - include/precompiled_interfaces.h Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeViewToolbar.cpp Diff File
mod - libs/wxutil/dataview/TreeView.cpp Diff File
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/menu/IconTextMenuItem.h Diff File
mod - libs/wxutil/preview/ModelPreview.cpp Diff File
mod - libs/wxutil/preview/ParticlePreview.cpp Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - libs/wxutil/window/TransientWindow.cpp Diff File
mod - plugins/dm.conversation/CommandArgumentItem.cpp Diff File
mod - plugins/dm.difficulty/DifficultyDialog.cpp Diff File
mod - plugins/dm.difficulty/DifficultyEditor.cpp Diff File
mod - plugins/dm.editing/AIEditingPanel.cpp Diff File
mod - plugins/dm.editing/AIHeadChooserDialog.cpp Diff File
mod - plugins/dm.editing/AIHeadPropertyEditor.cpp Diff File
mod - plugins/dm.editing/AIVocalSetChooserDialog.cpp Diff File
mod - plugins/dm.editing/AIVocalSetPreview.cpp Diff File
mod - plugins/dm.editing/AIVocalSetPropertyEditor.cpp Diff File
mod - plugins/dm.gui/GuiSelector.cpp Diff File
mod - plugins/dm.gui/XDataSelector.cpp Diff File
mod - plugins/dm.objectives/ObjectiveConditionsDialog.cpp Diff File
mod - plugins/dm.objectives/ObjectivesEditor.cpp Diff File
mod - plugins/dm.stimresponse/SREntity.cpp Diff File
mod - plugins/dm.stimresponse/StimResponseEditor.cpp Diff File
mod - plugins/dm.stimresponse/StimTypes.cpp Diff File
mod - plugins/script/ScriptingSystem.cpp Diff File
mod - radiant/camera/CameraWndManager.cpp Diff File
mod - radiant/log/Console.cpp Diff File
mod - radiant/textool/TexTool.cpp Diff File
mod - radiant/ui/aas/AasControl.cpp Diff File
mod - radiant/ui/about/AboutDialog.cpp Diff File
mod - radiant/ui/commandlist/CommandList.cpp Diff File
mod - radiant/ui/common/MapPreview.cpp Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/eclasstree/EClassTree.cpp Diff File
mod - radiant/ui/eclasstree/EClassTreeBuilder.cpp Diff File
mod - radiant/ui/einspector/AddPropertyDialog.cpp Diff File
mod - radiant/ui/einspector/AnglePropertyEditor.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/LightTextureChooser.cpp Diff File
mod - radiant/ui/einspector/ModelPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.cpp Diff File
mod - radiant/ui/einspector/SkinChooser.cpp Diff File
mod - radiant/ui/entitylist/EntityList.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesUserInterfaceModule.cpp Diff File
mod - radiant/ui/filters/FilterContextMenu.cpp Diff File
mod - radiant/ui/findshader/FindShader.cpp Diff File
mod - radiant/ui/groupdialog/GroupDialog.cpp Diff File
mod - radiant/ui/groupdialog/GroupDialogManager.h Diff File
mod - radiant/ui/layers/LayerContextMenu.cpp Diff File
mod - radiant/ui/layers/LayerOrthoContextMenuItem.cpp Diff File
mod - radiant/ui/lightinspector/LightInspector.cpp Diff File
mod - radiant/ui/mainframe/EmbeddedLayout.cpp Diff File
mod - radiant/ui/mainframe/FloatingLayout.cpp Diff File
mod - radiant/ui/mainframe/MainFrame.cpp Diff File
mod - radiant/ui/mainframe/MainFrameLayoutManager.cpp Diff File
mod - radiant/ui/mainframe/RegularLayout.cpp Diff File
mod - radiant/ui/mainframe/SplitPaneLayout.cpp Diff File
mod - radiant/ui/mainframe/TopLevelFrame.cpp Diff File
mod - radiant/ui/mapinfo/MapInfoDialog.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/menu/MenuElement.h Diff File
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File
mod - radiant/ui/ortho/OrthoContextMenu.cpp Diff File
mod - radiant/ui/particles/ParticleEditor.cpp Diff File
mod - radiant/ui/particles/ParticlesChooser.cpp Diff File
mod - radiant/ui/patch/PatchInspector.cpp Diff File
mod - radiant/ui/prefabselector/PrefabSelector.h Diff File
mod - radiant/ui/script/ScriptUserInterfaceModule.cpp Diff File
mod - radiant/ui/script/ScriptWindow.cpp Diff File
mod - radiant/ui/selectionset/SelectionSetToolmenu.cpp Diff File
mod - radiant/ui/surfaceinspector/SurfaceInspector.cpp Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File
mod - radiant/ui/texturebrowser/TextureBrowserManager.cpp Diff File
mod - radiant/ui/transform/TransformDialog.cpp Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File
mod - radiant/uimanager/SoundShaderPreview.cpp Diff File
mod - radiant/xyview/GlobalXYWnd.cpp Diff File
mod - radiant/xyview/XYWnd.cpp Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: master 63790cb8

2021-02-07 15:42:39

greebo

Details Diff
0005527: Move remaining files from uimanager/ to ui/common/ Affected Issues
0005527
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/common/DialogManager.cpp Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 005e0273

2021-02-07 16:33:56

greebo

Details Diff
0005527: Linux build fixes Affected Issues
0005527
mod - radiant/ui/mainframe/MainFrameLayoutManager.cpp Diff File

Issue History

Date Modified Username Field Change
06.02.2021 05:02 greebo New Issue
06.02.2021 05:02 greebo Assigned To => greebo
06.02.2021 05:02 greebo Status new => assigned
06.02.2021 05:02 greebo Target Version => 2.12.0
06.02.2021 15:11 greebo Changeset attached => DarkRadiant master 9f26b942
06.02.2021 15:11 greebo Changeset attached => DarkRadiant master 2279efed
06.02.2021 15:11 greebo Changeset attached => DarkRadiant master 3736c00e
06.02.2021 15:11 greebo Changeset attached => DarkRadiant master db5acfe5
06.02.2021 15:11 greebo Changeset attached => DarkRadiant master b7022c4a
06.02.2021 15:11 greebo Changeset attached => DarkRadiant master d414d9c1
06.02.2021 15:11 greebo Changeset attached => DarkRadiant master aec77c09
07.02.2021 05:20 greebo Changeset attached => DarkRadiant master eaca85ec
07.02.2021 06:11 greebo Changeset attached => DarkRadiant master d3f3cf0a
07.02.2021 06:11 greebo Changeset attached => DarkRadiant master 47202d3b
07.02.2021 07:00 greebo Changeset attached => DarkRadiant master dcf6d394
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 4021f236
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 751d8f9a
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 01a74f13
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master ca89e71c
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 4a396dd8
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 7a7207fd
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 11cd8c26
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master c9616814
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master ad503384
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 79e6118e
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 0ffee640
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 88224147
07.02.2021 15:44 greebo Changeset attached => DarkRadiant master 63790cb8
07.02.2021 16:34 greebo Changeset attached => DarkRadiant master 005e0273
07.02.2021 16:35 greebo Status assigned => resolved
07.02.2021 16:35 greebo Resolution open => fixed
07.02.2021 16:35 greebo Fixed in Version => 2.12.0
05.09.2021 18:21 greebo Status resolved => closed