View Issue Details

IDProjectCategoryView StatusLast Update
0005530DarkRadiantGUIpublic09.02.2021 19:38
ReporterAmadeus Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
OSWindows 10 
Product Version2.11.0 
Target Version2.12.0Fixed in Version2.12.0 
Summary0005530: "Toggle 16x16 grid" function in the Particle Editor broken
DescriptionWhen you open up the Particle Editor in DR 2.11 and select the "toggle 16x16 grid" button, a grid does show up but that grid is not static; it moves or shakes violently depending on what particle you select.
Steps To Reproduce1. Open DR 2.11
2. Open Particle Editor
3. Select "Toggle 16-unit wide grid"
4. Select any particle
5. Watch the grid move up and down, or shake, following whatever particle was selected.
Tagsparticle editor

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master a362d0f6

2021-02-09 19:38:33

greebo

Details Diff
0005530: Fix ParticlePreview grid origin moving around due to changing particle bounds. Tied it to the 0,0,0 origin. Affected Issues
0005530
mod - libs/wxutil/preview/ParticlePreview.cpp Diff File
mod - libs/wxutil/preview/ParticlePreview.h Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - libs/wxutil/preview/RenderPreview.h Diff File

Issue History

Date Modified Username Field Change
09.02.2021 18:59 Amadeus New Issue
09.02.2021 18:59 Amadeus Tag Attached: particle editor
09.02.2021 19:31 greebo Status new => confirmed
09.02.2021 19:38 greebo Changeset attached => DarkRadiant master a362d0f6
09.02.2021 19:38 greebo Target Version => 2.12.0
09.02.2021 19:38 greebo Assigned To => greebo
09.02.2021 19:38 greebo Status confirmed => assigned
09.02.2021 19:38 greebo Status assigned => resolved
09.02.2021 19:38 greebo Resolution open => fixed
09.02.2021 19:38 greebo Fixed in Version => 2.12.0