View Issue Details

IDProjectCategoryView StatusLast Update
0005534DarkRadiantGUIpublic12.02.2021 06:12
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinux 
Product Version2.11.0 
Target Version2.12.0Fixed in Version2.12.0 
Summary0005534: Opening the Create Entity dialog a second time will present an empty tree view
DescriptionAs the title says. Steps to reproduce:

- Open DR
- RMB OrthoView > Create Entity
- Close the dialog without selecting anything
- RMB OrthoView > Create Entity
- Tree View is empty
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master fd4b5f94

2021-02-10 20:33:14

orbweaver


Committer: greebo Details Diff
0005534: EntityClassChooser is no longer a static singleton

Since populating the tree for this dialog is very quick, there is no benefit in
keeping a singleton around. Creating a new dialog each time requires much less
code and also fixes the major issue described in 0005534, namely that the dialog
is always empty on its second showing.

There is still a problem with the search feature (at least on Linux), which
results in the tree view becoming empty as soon as any text is entered in the
search box. However it is at least now possible to resume normal service by
closing the dialog and showing another one.
Affected Issues
0005534
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File

DarkRadiant: master 0ce5666d

2021-02-10 20:33:14

orbweaver

Details Diff
0005534: EntityClassChooser is no longer a static singleton

Since populating the tree for this dialog is very quick, there is no benefit in
keeping a singleton around. Creating a new dialog each time requires much less
code and also fixes the major issue described in 0005534, namely that the dialog
is always empty on its second showing.

There is still a problem with the search feature (at least on Linux), which
results in the tree view becoming empty as soon as any text is entered in the
search box. However it is at least now possible to resume normal service by
closing the dialog and showing another one.
Affected Issues
0005534
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File

DarkRadiant: master 39250cbd

2021-02-11 18:20:03

greebo

Details Diff
0005534: Re-associate the model in UpdateTreeVisibility in wxGTK < 3.0.5 to fix the blank tree views after typing Affected Issues
0005534
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File

Issue History

Date Modified Username Field Change
10.02.2021 17:48 greebo New Issue
10.02.2021 17:49 greebo Status new => confirmed
11.02.2021 17:34 greebo Changeset attached => DarkRadiant master fd4b5f94
11.02.2021 18:20 greebo Changeset attached => DarkRadiant master 39250cbd
11.02.2021 18:20 greebo Assigned To => greebo
11.02.2021 18:20 greebo Status confirmed => assigned
11.02.2021 18:20 greebo Target Version => 2.12.0
11.02.2021 18:20 greebo Status assigned => resolved
11.02.2021 18:20 greebo Resolution open => fixed
11.02.2021 18:20 greebo Fixed in Version => 2.12.0
12.02.2021 06:12 orbweaver Changeset attached => DarkRadiant master 0ce5666d