View Issue Details

IDProjectCategoryView StatusLast Update
0005537DarkRadiantGUIpublic23.09.2022 07:48
ReporterDragofer Assigned Togreebo  
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.11.0 
Target Version3.3.0Fixed in Version3.3.0 
Summary0005537: FX Chooser
DescriptionOn its own terms, an FX Chooser for "editor_fx" spawnargs would be good to have. More so in combination with an FX Editor (0005536).

It'd be good if all spawnargs beginning with "fx" were automatically recognised as fx spawnargs so they have this button, i.e. "fx_destroyed". Similar to how it works with "snd" or "model" spawnargs.
TagsNo tags attached.

Relationships

related to 0005536 acknowledged FX Editor 
related to 0006092 resolvedgreebo FX Declaration Parsing Support 

Activities

greebo

greebo

23.09.2022 07:37

administrator   ~0015271

grafik.png (82,264 bytes)   
grafik.png (82,264 bytes)   

Related Changesets

DarkRadiant: master c29693bd

2022-09-16 13:25:55

greebo

Details Diff
0005537: Introduce DeclarationTreeView base class, move common ShaderSelector code to base Affected Issues
0005537
add - radiant/ui/common/DeclarationSelector.cpp Diff File
add - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/common/ShaderSelector.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 038a1d93

2022-09-16 13:40:42

greebo

Details Diff
0005537: Add a generic Get/SetSelectedDeclName method to DeclarationSelector, replacing the ShaderSelector methods Affected Issues
0005537
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/ShaderChooser.cpp Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/common/ShaderSelector.h Diff File
mod - radiant/ui/lightinspector/LightInspector.cpp Diff File

DarkRadiant: master 5e6b7aef

2022-09-16 13:58:32

greebo

Details Diff
0005537: Add protected virtual method to override by DeclarationSelector subclasses Affected Issues
0005537
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/common/ShaderSelector.h Diff File

DarkRadiant: master 2a3ee16b

2022-09-16 14:10:53

greebo

Details Diff
0005537: DeclarationSelector is using its own default set of columns, unless specified otherwise Affected Issues
0005537
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/common/ShaderSelector.h Diff File

DarkRadiant: master 072f99f3

2022-09-16 15:09:44

greebo

Details Diff
0005537: Merge common code from ParticleSelector into DeclarationSelector.
Expand base class for added flexibility.
Affected Issues
0005537
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/common/ShaderSelector.h Diff File
mod - radiant/ui/particles/ParticleChooserDialog.cpp Diff File
mod - radiant/ui/particles/ParticleSelector.cpp Diff File
mod - radiant/ui/particles/ParticleSelector.h Diff File

DarkRadiant: master 72c33023

2022-09-16 15:34:49

greebo

Details Diff
0005537: Rename ShaderSelector to MaterialSelector and move its file pair to ui/materials/ folder Affected Issues
0005537
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/ShaderChooser.cpp Diff File
mod - radiant/ui/common/ShaderChooser.h Diff File
mod - radiant/ui/einspector/TexturePropertyEditor.cpp Diff File
mod - radiant/ui/findshader/FindShader.cpp Diff File
mod - radiant/ui/lightinspector/LightInspector.cpp Diff File
mod - radiant/ui/lightinspector/LightInspector.h Diff File
mod - radiant/ui/materials/editor/MaterialEditor.cpp Diff File
mod - radiant/ui/surfaceinspector/SurfaceInspector.cpp Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master cb7b1104

2022-09-16 15:42:22

greebo

Details Diff
0005537: Rename ShaderChooser to MaterialChooser and move its file pair to ui/materials/ folder Affected Issues
0005537
mod - install/user.xml Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/einspector/TexturePropertyEditor.cpp Diff File
mod - radiant/ui/findshader/FindShader.cpp Diff File
mod - radiant/ui/lightinspector/LightInspector.cpp Diff File
mod - radiant/ui/materials/editor/MaterialEditor.cpp Diff File
mod - radiant/ui/surfaceinspector/SurfaceInspector.cpp Diff File
mod - radiant/ui/surfaceinspector/SurfaceInspector.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 618496f1

2022-09-17 04:14:38

greebo

Details Diff
0005537: Migrate SoundChooser to use a specialised DeclarationSelector as tree view. Affected Issues
0005537
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/common/SoundChooser.h Diff File
add - radiant/ui/common/SoundShaderSelector.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 8b682043

2022-09-17 04:38:15

greebo

Details Diff
0005537: Introduce IDeclarationPreview interface which can be used by the DeclarationSelector to notify the attached previews about selection changes. Affected Issues
0005537
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
add - radiant/ui/common/IDeclarationPreview.h Diff File
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/common/SoundChooser.h Diff File
mod - radiant/ui/common/SoundShaderPreview.cpp Diff File
mod - radiant/ui/common/SoundShaderPreview.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master bf1cf490

2022-09-17 04:43:59

greebo

Details Diff
0005537: TexturePreviewCombo implements IDeclarationPreview.
The MaterialSelector no longer needs to hold a direct reference to the combo widget, updates are issued by the DeclarationSelector base.
Affected Issues
0005537
mod - radiant/ui/common/TexturePreviewCombo.cpp Diff File
mod - radiant/ui/common/TexturePreviewCombo.h Diff File
mod - radiant/ui/materials/MaterialSelector.cpp Diff File
mod - radiant/ui/materials/MaterialSelector.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File

DarkRadiant: master 2e403a6b

2022-09-17 04:57:29

greebo

Details Diff
0005537: Move interface to include/ui/ Affected Issues
0005537
mod - libs/wxutil/preview/ParticlePreview.cpp Diff File
mod - libs/wxutil/preview/ParticlePreview.h Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/SoundShaderPreview.h Diff File
mod - radiant/ui/common/TexturePreviewCombo.h Diff File
mod - radiant/ui/particles/ParticleEditor.cpp Diff File
mod - radiant/ui/particles/ParticleSelector.cpp Diff File
mod - radiant/ui/particles/ParticleSelector.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/include.vcxproj Diff File
mod - tools/msvc/include.vcxproj.filters Diff File

DarkRadiant: master 4b6a716a

2022-09-17 05:49:05

greebo

Details Diff
0005537: Refactor SoundShaderSelector to manage the preview on its own Affected Issues
0005537
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/common/SoundChooser.h Diff File
mod - radiant/ui/common/SoundShaderSelector.h Diff File

DarkRadiant: master e21d25e7

2022-09-17 07:05:24

greebo

Details Diff
0005537: Fix linux compilation Affected Issues
0005537
mod - radiant/CMakeLists.txt Diff File

DarkRadiant: master 264995a9

2022-09-17 13:00:44

greebo

Details Diff
0005537: Since the ParticlePreview isn't a wxWindow itself, add a GetPreviewWidget method to the IDeclarationPreview interface. Affected Issues
0005537
mod - include/ui/ideclpreview.h Diff File
mod - libs/wxutil/preview/ParticlePreview.cpp Diff File
mod - libs/wxutil/preview/ParticlePreview.h Diff File
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/SoundShaderPreview.h Diff File
mod - radiant/ui/common/TexturePreviewCombo.h Diff File
mod - radiant/ui/particles/ParticleSelector.cpp Diff File
mod - radiant/ui/particles/ParticleSelector.h Diff File

DarkRadiant: master 7000412e

2022-09-17 13:24:42

greebo

Details Diff
0005537: Add a DeclFileInfo widget to all selectors Affected Issues
0005537
mod - libs/wxutil/DeclFileInfo.h Diff File
mod - radiant/ui/common/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/DeclarationSelector.h Diff File
mod - radiant/ui/common/SoundShaderPreview.cpp Diff File
mod - radiant/ui/common/SoundShaderPreview.h Diff File

DarkRadiant: master 7b31e0f8

2022-09-17 14:30:59

greebo

Details Diff
0005537: Move DeclarationSelector to wxutil namespace Affected Issues
0005537
mod - libs/wxutil/CMakeLists.txt Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/common/SoundShaderSelector.h Diff File
mod - radiant/ui/materials/MaterialSelector.h Diff File
mod - radiant/ui/particles/ParticleSelector.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 37d94a9d

2022-09-17 14:33:28

greebo

Details Diff
0005537: Move DeclFileInfo to wxutil/decl/ folder. Affected Issues
0005537
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - radiant/ui/common/SkinChooser.h Diff File
mod - radiant/ui/materials/editor/MaterialEditor.cpp Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 0ebad122

2022-09-17 14:50:04

greebo

Details Diff
0005537: Start refactoring EntityClassChooser to use a specialised DeclarationSelector Affected Issues
0005537
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File

DarkRadiant: master fb00152f

2022-09-17 14:55:01

greebo

Details Diff
0005537: Remove redundant controls Affected Issues
0005537
mod - install/ui/entityclasschooser.fbp Diff File
mod - install/ui/entityclasschooser.xrc Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File

DarkRadiant: master 5577a829

2022-09-17 15:16:24

greebo

Details Diff
0005537: Introduce EntityClassPreview (a specialised ModelPreview) and move ownership to EntityClassSelector. Affected Issues
0005537
mod - install/ui/entityclasschooser.fbp Diff File
mod - install/ui/entityclasschooser.xrc Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
add - libs/wxutil/preview/EntityClassPreview.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 8b9329a5

2022-09-17 15:46:43

greebo

Details Diff
0005537: Convert entity description text to IDeclarationPreview to receive automatic selection updates. Affected Issues
0005537
mod - install/ui/entityclasschooser.fbp Diff File
mod - install/ui/entityclasschooser.xrc Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File

DarkRadiant: master c37a0b3a

2022-09-17 16:17:25

greebo

Details Diff
0005537: DeclarationSelector creates a splitter window as soon as a preview is added to the right panel Affected Issues
0005537
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File

DarkRadiant: master 7c3b550d

2022-09-17 16:39:17

greebo

Details Diff
0005537: Remove the EntityClassChooser XRC, all there was left in the XRC file were the buttons, which are now replaced by a standard button sizer. Affected Issues
0005537
rm - install/ui/entityclasschooser.fbp Diff File
rm - install/ui/entityclasschooser.xrc Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File

DarkRadiant: master 6f9daf3e

2022-09-17 16:51:35

greebo

Details Diff
0005537: Refactor wxutil::DialogBase, cleanup #includes Affected Issues
0005537
mod - libs/wxutil/dialog/Dialog.cpp Diff File
mod - libs/wxutil/dialog/DialogBase.cpp Diff File
mod - libs/wxutil/dialog/DialogBase.h Diff File

DarkRadiant: master a5be8ad9

2022-09-18 05:00:39

greebo

Details Diff
0005537: Extend wxutil::DialogBase to maintain the window position/size, using the window name to form the registry key.
DialogBase constructors now accept an optional window name for this purpose.
Affected Issues
0005537
mod - install/user.xml Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/WindowPosition.cpp Diff File
mod - libs/wxutil/WindowPosition.h Diff File
mod - libs/wxutil/dialog/DialogBase.cpp Diff File
mod - libs/wxutil/dialog/DialogBase.h Diff File

DarkRadiant: master f9fc54f5

2022-09-18 05:35:57

greebo

Details Diff
0005537: Take a further step and introduce a generic WindowState serialization helper.
This helper will save/restore the window position as well as the state of all registered elements in a dialog that implement the IPersistableObject interface.
Affected Issues
0005537
add - include/ui/iwindowstate.h Diff File
mod - libs/wxutil/CMakeLists.txt Diff File
add - libs/wxutil/WindowState.cpp Diff File
add - libs/wxutil/WindowState.h Diff File
mod - libs/wxutil/dialog/DialogBase.cpp Diff File
mod - libs/wxutil/dialog/DialogBase.h Diff File
mod - tools/msvc/include.vcxproj Diff File
mod - tools/msvc/include.vcxproj.filters Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 8505b548

2022-09-18 06:00:29

greebo

Details Diff
0005537: Refactor WindowPosition, implement IPersistableObject Affected Issues
0005537
mod - libs/wxutil/WindowPosition.cpp Diff File
mod - libs/wxutil/WindowPosition.h Diff File
mod - libs/wxutil/dialog/DialogBase.cpp Diff File
mod - libs/wxutil/dialog/DialogBase.h Diff File
mod - plugins/dm.objectives/ObjectiveConditionsDialog.cpp Diff File

DarkRadiant: master b8b06d83

2022-09-18 06:17:37

greebo

Details Diff
0005537: DeclarationSelector is now able to persist the sash position of the splitter window.

Provided it's registered by the owning dialog to the WindowState handler.
Affected Issues
0005537
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/PanedPosition.cpp Diff File
mod - libs/wxutil/PanedPosition.h Diff File
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File

DarkRadiant: master d8c28f70

2022-09-18 06:27:06

greebo

Details Diff
0005537: PanedPosition is saving the sash position to a separate registry element to avoid name clashes when multiple splitters are saved. Affected Issues
0005537
mod - libs/wxutil/PanedPosition.cpp Diff File
mod - libs/wxutil/PanedPosition.h Diff File
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File

DarkRadiant: master 644a7afd

2022-09-18 07:03:06

greebo

Details Diff
0005537: EntityClassChooser now implements IPersistableObject to save the last selected decl name.

Precaution is necessary to not overwrite the pre-selected eclass with the one from the registry.
Affected Issues
0005537
mod - libs/registry/registry.h Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/PanedPosition.cpp Diff File
mod - libs/wxutil/PanedPosition.h Diff File

DarkRadiant: master ac26f793

2022-09-18 07:56:06

greebo

Details Diff
0005537: Start refactoring the SkinChooser Affected Issues
0005537
mod - radiant/ui/common/SkinChooser.cpp Diff File
mod - radiant/ui/common/SkinChooser.h Diff File

DarkRadiant: master af96a3fd

2022-09-18 08:22:27

greebo

Details Diff
0005537: Move more preview-related code to the SkinSelector widget. Affected Issues
0005537
mod - install/user.xml Diff File
add - libs/wxutil/preview/SkinPreview.h Diff File
mod - radiant/ui/common/SkinChooser.cpp Diff File
mod - radiant/ui/common/SkinChooser.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 70f7fa71

2022-09-18 08:32:17

greebo

Details Diff
0005537: ResourceTreeView finished event should propagate upwards Affected Issues
0005537
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - radiant/ui/common/SkinChooser.cpp Diff File

DarkRadiant: master db00b163

2022-09-18 14:16:36

greebo

Details Diff
0005537: Refactored SkinChooser, code cleanup Affected Issues
0005537
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File
mod - radiant/ui/common/SkinChooser.cpp Diff File
mod - radiant/ui/common/SkinChooser.h Diff File
mod - radiant/ui/modelselector/MaterialsList.h Diff File

DarkRadiant: master 7001d58a

2022-09-18 16:00:16

greebo

Details Diff
0005537: Introduce DeclarationSelectorDialog as new base type for declaration choosers.

Start refactoring EntityClassChooser, moving common code to the base.
Affected Issues
0005537
mod - libs/wxutil/CMakeLists.txt Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
add - libs/wxutil/decl/DeclarationSelectorDialog.cpp Diff File
add - libs/wxutil/decl/DeclarationSelectorDialog.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 77f90967

2022-09-18 16:19:04

greebo

Details Diff
0005537: Move more common code to DeclarationSelectorDialog Affected Issues
0005537
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.h Diff File

DarkRadiant: master bfcafd5c

2022-09-18 16:24:21

greebo

Details Diff
0005537: Move double-click behaviour to base DeclarationSelectorDialog Affected Issues
0005537
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.h Diff File

DarkRadiant: master 43f426f9

2022-09-18 16:35:22

greebo

Details Diff
0005537: A public Populate() method is now mandatory for DeclarationSelector implementations Affected Issues
0005537
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File
mod - radiant/ui/common/SkinChooser.cpp Diff File
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/common/SoundShaderSelector.h Diff File
mod - radiant/ui/materials/MaterialSelector.cpp Diff File
mod - radiant/ui/materials/MaterialSelector.h Diff File
mod - radiant/ui/particles/ParticleSelector.cpp Diff File
mod - radiant/ui/particles/ParticleSelector.h Diff File

DarkRadiant: master e4888612

2022-09-18 16:43:56

greebo

Details Diff
0005537: Each DeclarationSelector monitors its corresponding decl::Type to refresh the tree on reloadDecls. Affected Issues
0005537
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File

DarkRadiant: master 20ba7f38

2022-09-18 16:58:36

greebo

Details Diff
0005537: EntityClassChooser migrated after moving the state handling code to the base Affected Issues
0005537
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.h Diff File

DarkRadiant: master 9c6c7ded

2022-09-18 17:59:10

greebo

Details Diff
0005537: Fix Linux compilation Affected Issues
0005537
mod - libs/wxutil/dialog/DialogBase.cpp Diff File

DarkRadiant: master 8b7c4c05

2022-09-18 19:33:04

greebo

Details Diff
0005537: Refactor SkinChooser to inherit from DeclarationSelectorDialog. Affected Issues
0005537
mod - radiant/ui/common/SkinChooser.cpp Diff File
mod - radiant/ui/common/SkinChooser.h Diff File
mod - radiant/ui/einspector/ModelPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/SkinPropertyEditor.cpp Diff File

DarkRadiant: master b9aa3249

2022-09-23 04:56:39

greebo

Details Diff
0005537: Migrate ParticleChooserDialog to inherit from DeclarationSelectorDialog Affected Issues
0005537
mod - install/user.xml Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.h Diff File
mod - radiant/ui/particles/ParticleChooserDialog.cpp Diff File
mod - radiant/ui/particles/ParticleChooserDialog.h Diff File
mod - radiant/ui/particles/ParticleSelector.h Diff File

DarkRadiant: master f8c5083a

2022-09-23 05:16:17

greebo

Details Diff
0005537: Remove unused signal Affected Issues
0005537
mod - radiant/ui/common/SkinChooser.cpp Diff File

DarkRadiant: master 0c13973b

2022-09-23 06:20:25

greebo

Details Diff
0005537: Migrate SoundChooser dialog to derive from DeclarationSelectorDialog Affected Issues
0005537
mod - install/user.xml Diff File
mod - libs/wxutil/decl/DeclarationSelector.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelector.h Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.h Diff File
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/common/SoundChooser.h Diff File
mod - radiant/ui/common/SoundShaderSelector.h Diff File

DarkRadiant: master 2746e3c0

2022-09-23 06:43:37

greebo

Details Diff
0005537: Add a Reload Decls button to all DeclarationSelectors Affected Issues
0005537
mod - libs/wxutil/decl/DeclarationSelectorDialog.cpp Diff File
mod - libs/wxutil/decl/DeclarationSelectorDialog.h Diff File

DarkRadiant: master 5330d97d

2022-09-23 06:48:49

greebo

Details Diff
0005537: SoundChooser cleanup Affected Issues
0005537
mod - libs/wxutil/decl/DeclarationSelectorDialog.cpp Diff File
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/common/SoundChooser.h Diff File

DarkRadiant: master baa21200

2022-09-23 07:04:03

greebo

Details Diff
0005537: Migrate MaterialChooser dialog to derive from DeclarationSelectorDialog Affected Issues
0005537
mod - install/user.xml Diff File
mod - radiant/ui/einspector/TexturePropertyEditor.cpp Diff File
mod - radiant/ui/materials/MaterialChooser.cpp Diff File
mod - radiant/ui/materials/MaterialChooser.h Diff File

DarkRadiant: master 7fc8b5cc

2022-09-23 07:21:39

greebo

Details Diff
0005537: Add FxChooser dialog Affected Issues
0005537
add - install/bitmaps/icon_fx.png Diff File
mod - install/user.xml Diff File
mod - radiant/CMakeLists.txt Diff File
add - radiant/ui/fx/FxChooser.cpp Diff File
add - radiant/ui/fx/FxChooser.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master e44a83bb

2022-09-23 07:35:28

greebo

Details Diff
0005537: Add FxPropertyEditor, which listens to "fx" keys, like declared on the func_fx entityDef Affected Issues
0005537
mod - install/games/darkmod.game Diff File
mod - install/games/doom3.game Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/einspector/ClassnamePropertyEditor.cpp Diff File
add - radiant/ui/einspector/FxPropertyEditor.cpp Diff File
add - radiant/ui/einspector/FxPropertyEditor.h Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.cpp Diff File
mod - radiant/ui/fx/FxChooser.cpp Diff File
mod - radiant/ui/fx/FxChooser.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master b1219309

2022-09-23 07:47:51

greebo

Details Diff
0005537: Register fx property editor for spawnargs like "fx_something" Affected Issues
0005537
mod - install/games/darkmod.game Diff File
mod - install/games/doom3.game Diff File

Issue History

Date Modified Username Field Change
14.02.2021 15:46 Dragofer New Issue
14.02.2021 15:46 Dragofer Relationship added related to 0005536
14.02.2021 17:19 greebo Status new => acknowledged
14.02.2021 18:30 Dragofer Description Updated
04.09.2022 16:08 greebo Relationship added related to 0006092
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master c29693bd
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 038a1d93
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 5e6b7aef
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 2a3ee16b
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 072f99f3
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 72c33023
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master cb7b1104
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 618496f1
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 8b682043
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master bf1cf490
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 2e403a6b
17.09.2022 05:49 greebo Changeset attached => DarkRadiant master 4b6a716a
17.09.2022 06:10 greebo Assigned To => greebo
17.09.2022 06:10 greebo Status acknowledged => assigned
17.09.2022 06:10 greebo Target Version => 3.3.0
17.09.2022 07:05 greebo Changeset attached => DarkRadiant master e21d25e7
17.09.2022 13:28 greebo Changeset attached => DarkRadiant master 264995a9
17.09.2022 13:28 greebo Changeset attached => DarkRadiant master 7000412e
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master 7b31e0f8
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master 37d94a9d
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master 0ebad122
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master fb00152f
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master 5577a829
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master 8b9329a5
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master c37a0b3a
17.09.2022 16:41 greebo Changeset attached => DarkRadiant master 7c3b550d
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 6f9daf3e
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master a5be8ad9
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master f9fc54f5
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 8505b548
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master b8b06d83
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master d8c28f70
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 644a7afd
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master ac26f793
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master af96a3fd
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 70f7fa71
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master db00b163
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 7001d58a
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 77f90967
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master bfcafd5c
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 43f426f9
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master e4888612
18.09.2022 17:07 greebo Changeset attached => DarkRadiant master 20ba7f38
18.09.2022 18:06 greebo Changeset attached => DarkRadiant master 9c6c7ded
18.09.2022 19:36 greebo Changeset attached => DarkRadiant master 8b7c4c05
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master b9aa3249
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master f8c5083a
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master 0c13973b
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master 2746e3c0
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master 5330d97d
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master baa21200
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master 7fc8b5cc
23.09.2022 07:36 greebo Changeset attached => DarkRadiant master e44a83bb
23.09.2022 07:37 greebo Note Added: 0015271
23.09.2022 07:37 greebo File Added: grafik.png
23.09.2022 07:46 greebo Status assigned => resolved
23.09.2022 07:46 greebo Resolution open => fixed
23.09.2022 07:46 greebo Fixed in Version => 3.3.0
23.09.2022 07:48 greebo Changeset attached => DarkRadiant master b1219309