View Issue Details

IDProjectCategoryView StatusLast Update
0005555DarkRadiantMap Editingpublic22.05.2021 06:48
ReporterOGDA Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformPC/Intel 8086K/MSINvidia2080SupOSWindows 10OS Version10.0.19041
Product Version2.11.0 
Target Version2.13.0Fixed in Version2.13.0 
Summary0005555: Crash when activating GameConnection Feature "update entities on every change"
DescriptionFrom the initial thread on the forum:
https://forums.thedarkmod.com/index.php?/topic/20815-dark-radiant-crash-on-update-entities-on-every-change/&tab=comments#comment-457607

----------

I get a dark radiant crash every time I try to use

Connection > Update entities on every change

Unhandled exception at 0x00007FF9EFB1286E (ucrtbase.dll) in DarkRadiant.exe: Fatal program exit requested.

----------

Dump of a crash of the downloaded version of dark radiant after the error has occured:
https://das-kartell.org/files/darkradiant_error/DarkRadiant.zip

---------

I was able to compile the source code and then run dark radiant.
The error happens with the downloaded version and with the self compiled version.

Dump file of the crash with the self compiled version:
https://das-kartell.org/files/darkradiant_error/DarkRadiant_2.zip

Debug Screenshots:

https://das-kartell.org/files/darkradiant_error/debug_error.png

https://das-kartell.org/files/darkradiant_error/debug_error_2.png
Steps To ReproduceI do the following steps:

1. Start TDM, load map with console command "map anol"

2. Enter in console "com_automation 1", windows firewall request was accepted the first time (no other firewall is running)

3. Start dark radiant and load corresponding map fms/anol/maps/anol.map

4. Activate "Game position follows dark radiant camera" > camera synchronisation is working

5. Change an entity and use Connection > Update entities now > working without problems

6. Activate Connection > Update entities on every change

7. As soon as any entity is moved, dark radiant crashes by directly closing without giving an error on the desktop

 
When this happens, TDM prints the following in the console:

HotReload: SUCCESS
ERROR: idTCP::Read: WSAECONNRESET
Automation lost connection

 
I'm using TDM 2.09/64 #9108 and
Dark radiant 2.11.0 x64 Build date Jan 29 2021 13:59:57
TagsCrash; darkradiant

Activities

greebo

greebo

01.03.2021 19:24

administrator   ~0013753

Thanks for the detailed report

Related Changesets

DarkRadiant: master 66c3df0f

2021-05-22 06:36:50

greebo

Details Diff
0005555: Avoid double-entering the think() method from external triggers (wxTimer).
The lock cannot be placed within the GameConnection::think() body, since think is recursively calling itself by design.
Affected Issues
0005555
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - plugins/dm.gameconnection/GameConnection.h Diff File

DarkRadiant: master ed5dc937

2021-05-22 06:48:01

greebo

Details Diff
0005555: Disable map save progress dialog when updating entities Affected Issues
0005555
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File

Issue History

Date Modified Username Field Change
01.03.2021 18:33 OGDA New Issue
01.03.2021 18:33 OGDA Tag Attached: Crash; darkradiant
01.03.2021 19:24 greebo Status new => acknowledged
01.03.2021 19:24 greebo Note Added: 0013753
01.05.2021 15:52 greebo Status acknowledged => confirmed
22.05.2021 06:35 greebo Assigned To => greebo
22.05.2021 06:35 greebo Status confirmed => assigned
22.05.2021 06:35 greebo Target Version => 2.13.0
22.05.2021 06:48 greebo Changeset attached => DarkRadiant master 66c3df0f
22.05.2021 06:48 greebo Changeset attached => DarkRadiant master ed5dc937
22.05.2021 06:48 greebo Status assigned => resolved
22.05.2021 06:48 greebo Resolution open => fixed
22.05.2021 06:48 greebo Fixed in Version => 2.13.0
22.05.2021 06:48 greebo Summary Dark radiant crash on update entities on every change => Crash when activating GameConnection Feature "update entities on every change"