View Issue Details

IDProjectCategoryView StatusLast Update
0005581DarkRadiantRendererpublic10.04.2021 11:57
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.12.0 
Fixed in Version2.12.0 
Summary0005581: Regression: only one light is interacting with brushes in lighting preview
DescriptionThis must have been introduced some time ago, brushes are now lit by a single light entity only, depending on which one got moved around last. (This is not present in 2.11.0.)
Steps To ReproduceOpen the attached map
Switch to lighting mode
Move the red light (brushes are lit red)
Move the white light (red lighting is disappearing)
TagsNo tags attached.

Relationships

related to 0005566 resolvedgreebo Material stages with alpha test are incorrectly rendered as translucent 

Activities

greebo

greebo

10.04.2021 02:21

administrator  

two_lights.map.7z (923 bytes)

Related Changesets

DarkRadiant: master 356dfb4e

2021-04-10 11:55:39

greebo

Details Diff
0005581: Fix lights not interacting due to a left-over comment disabling the RENDER_BLEND flag Affected Issues
0005581
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File

Issue History

Date Modified Username Field Change
10.04.2021 02:21 greebo New Issue
10.04.2021 02:21 greebo File Added: two_lights.map.7z
10.04.2021 02:21 greebo Status new => confirmed
10.04.2021 11:54 greebo Relationship added related to 0005566
10.04.2021 11:55 greebo Assigned To => greebo
10.04.2021 11:55 greebo Status confirmed => assigned
10.04.2021 11:56 greebo Changeset attached => DarkRadiant master 356dfb4e
10.04.2021 11:57 greebo Status assigned => resolved
10.04.2021 11:57 greebo Resolution open => fixed
10.04.2021 11:57 greebo Fixed in Version => 2.12.0