View Issue Details

IDProjectCategoryView StatusLast Update
0005589DarkRadiantGUIpublic15.04.2021 17:36
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.12.0 
Target Version2.12.0Fixed in Version2.12.0 
Summary0005589: Material Editor: Add Reload Images button to reload the textures of the selected shader
DescriptionAs the title says, users needs some way to reload the images from disk after changing them, without having to reload the entire material tree through "Reload Materials".
TagsNo tags attached.

Relationships

related to 0005572 resolvedgreebo Material Editor 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 6d08c905

2021-04-15 16:19:05

greebo

Details Diff
0005589: Add interface to reload images of a specific material on demand. Affected Issues
0005589
mod - include/ishaders.h Diff File
mod - radiantcore/shaders/CShader.cpp Diff File
mod - radiantcore/shaders/CShader.h Diff File
mod - radiantcore/shaders/Doom3ShaderLayer.cpp Diff File
mod - radiantcore/shaders/Doom3ShaderLayer.h Diff File
mod - radiantcore/shaders/textures/GLTextureManager.cpp Diff File
mod - radiantcore/shaders/textures/GLTextureManager.h Diff File

DarkRadiant: master 03791b14

2021-04-15 16:26:05

greebo

Details Diff
0005589: Add "Reload Images" button to Material Editor. Affected Issues
0005589
mod - install/ui/materialeditor.fbp Diff File
mod - install/ui/materialeditor.xrc Diff File
mod - radiant/ui/materials/editor/MaterialEditor.cpp Diff File
mod - radiant/ui/materials/editor/MaterialEditor.h Diff File

DarkRadiant: master eec691dc

2021-04-15 16:27:12

greebo

Details Diff
0005589: Add tooltip Affected Issues
0005589
mod - install/ui/materialeditor.fbp Diff File
mod - install/ui/materialeditor.xrc Diff File

DarkRadiant: master 590886e2

2021-04-15 16:44:27

greebo

Details Diff
0005589: Fix a problem when reparsing complex map expressions due to inconsistent tokeniser delimiters. Affected Issues
0005589
mod - libs/parser/DefTokeniser.h Diff File
mod - radiantcore/shaders/MapExpression.cpp Diff File
mod - radiantcore/shaders/ShaderTemplate.cpp Diff File
mod - radiantcore/shaders/ShaderTemplate.h Diff File

Issue History

Date Modified Username Field Change
15.04.2021 16:18 greebo New Issue
15.04.2021 16:18 greebo Assigned To => greebo
15.04.2021 16:18 greebo Status new => assigned
15.04.2021 16:27 greebo Changeset attached => DarkRadiant master 6d08c905
15.04.2021 16:27 greebo Changeset attached => DarkRadiant master 03791b14
15.04.2021 16:27 greebo Changeset attached => DarkRadiant master eec691dc
15.04.2021 16:27 greebo Status assigned => resolved
15.04.2021 16:27 greebo Resolution open => fixed
15.04.2021 16:27 greebo Fixed in Version => 2.12.0
15.04.2021 16:27 greebo Relationship added related to 0005572
15.04.2021 16:44 greebo Changeset attached => DarkRadiant master 590886e2
15.04.2021 17:36 greebo Target Version => 2.12.0