View Issue Details

IDProjectCategoryView StatusLast Update
0005632DarkRadiantMap Editingpublic11.06.2021 09:59
ReporterLDAsh Assigned Togreebo  
PrioritylowSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.12.0 
Target Version2.13.0Fixed in Version2.13.0 
Summary0005632: Restore non-uniform scaling for texture browser.
DescriptionDarkRadiant used to display textures in the texture browser with relative scaling, based on the size of the actual texture. This is important for mappers to easily see what size of texture they're dealing with. In other words, the "uniform texture thumbnail size" should be optional, like it used to be.
TagsNo tags attached.

Activities

greebo

greebo

03.06.2021 05:58

administrator   ~0014063

I think this is related to changeset 16a20e2e966cc57d75629ae84983cb892c2d8cc3 back in 2015.

So you want to render textures in a fixed scale, like 10/25/50/75% of the actual size? How should the texture browser behave when huge textures like a 4096x2048 texture is encountered?
LDAsh

LDAsh

03.06.2021 06:46

reporter   ~0014064

Perhaps have a 5% option too? That would make 4K display as 256? I figure texture sizes of a project would be relative, so if you have 4K or 8K in there, the smallest (such as editor images) might be 64 or 128.
greebo

greebo

03.06.2021 07:55

administrator   ~0014065

I'll see what I can do. The Texture Browser is very old and hasn't really been changed since the days of GtkRadiant. There have been suggestions for improving it in the forums too.
LDAsh

LDAsh

03.06.2021 08:24

reporter   ~0014067

The first and second request are about functionality that used to exist in DarkRadiant (1.8) and still do in NetRadiant.

Related Changesets

DarkRadiant: master 538922fc

2021-06-11 08:38:41

greebo

Details Diff
0005632: Some tweaking to Texture Tile borders and colours Affected Issues
0005632
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File

DarkRadiant: master e91883e9

2021-06-11 09:49:02

greebo

Details Diff
0005632: Revive the code to render texture tiles in a size proportional to their editor image.
The default is still Uniform Texture Size clamped to 128 pixels.
Affected Issues
0005632
mod - install/user.xml Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.h Diff File
mod - radiant/ui/texturebrowser/TextureBrowserManager.cpp Diff File

DarkRadiant: master e030841a

2021-06-11 09:52:55

greebo

Details Diff
0005632: Add a 5% scale option Affected Issues
0005632
mod - install/user.xml Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File
mod - radiant/ui/texturebrowser/TextureBrowserManager.cpp Diff File

DarkRadiant: master 0a2cdfc9

2021-06-11 09:55:46

greebo

Details Diff
0005632: Add the uniform scale toggle button Affected Issues
0005632
mod - install/user.xml Diff File
mod - radiant/ui/texturebrowser/TextureBrowserManager.cpp Diff File

Issue History

Date Modified Username Field Change
03.06.2021 05:27 LDAsh New Issue
03.06.2021 05:51 greebo Status new => acknowledged
03.06.2021 05:58 greebo Note Added: 0014063
03.06.2021 05:58 greebo Status acknowledged => feedback
03.06.2021 06:46 LDAsh Note Added: 0014064
03.06.2021 06:46 LDAsh Status feedback => new
03.06.2021 07:55 greebo Note Added: 0014065
03.06.2021 08:02 greebo Status new => acknowledged
03.06.2021 08:24 LDAsh Note Added: 0014067
11.06.2021 09:56 greebo Product Version => 2.12.0
11.06.2021 09:56 greebo Target Version => 2.13.0
11.06.2021 09:56 greebo Assigned To => greebo
11.06.2021 09:56 greebo Status acknowledged => assigned
11.06.2021 09:56 greebo Changeset attached => DarkRadiant master 538922fc
11.06.2021 09:56 greebo Changeset attached => DarkRadiant master e91883e9
11.06.2021 09:56 greebo Changeset attached => DarkRadiant master e030841a
11.06.2021 09:56 greebo Changeset attached => DarkRadiant master 0a2cdfc9
11.06.2021 09:59 greebo Status assigned => resolved
11.06.2021 09:59 greebo Resolution open => fixed
11.06.2021 09:59 greebo Fixed in Version => 2.13.0