View Issue Details

IDProjectCategoryView StatusLast Update
0005639DarkRadiantMap Editingpublic08.06.2021 17:02
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.13.0 
Target Version2.13.0Fixed in Version2.13.0 
Summary0005639: Support Layers when merging Maps
DescriptionSibling issue to 0005638. When merging, Layer information of the incoming changes should be preserved/integrated.
TagsNo tags attached.

Relationships

related to 0005638 resolvedgreebo Support Selection Groups when merging Maps 
related to 0005623 resolvedgreebo Differential Map Merge 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: merge_layers ed0a3cd0

2021-06-06 07:09:21

greebo

Details Diff
0005639: Start creating the infrastructure to merge layers and test the algorithm Affected Issues
0005639
add - libs/scene/merge/LayerMerger.h Diff File
mod - test/MapMerging.cpp Diff File
add - test/resources/tdm/maps/merging_layers_1.mapx Diff File
mod - tools/msvc/scenelib.vcxproj Diff File
mod - tools/msvc/scenelib.vcxproj.filters Diff File

DarkRadiant: merge_layers be4e5878

2021-06-06 11:10:33

greebo

Details Diff
0005639: Unit test covering the addition of new layers which were missing in the base map Affected Issues
0005639
mod - test/MapMerging.cpp Diff File
add - test/resources/tdm/maps/merging_layers_2.mapx Diff File

DarkRadiant: merge_layers f9631519

2021-06-06 11:14:32

greebo

Details Diff
0005639: Removal of layers Affected Issues
0005639
mod - test/MapMerging.cpp Diff File
add - test/resources/tdm/maps/merging_layers_3.mapx Diff File

DarkRadiant: merge_layers 673b7d9b

2021-06-06 18:53:59

greebo

Details Diff
0005639: Test covering removal of layers, but with kept nodes (as decided by the user) Affected Issues
0005639
mod - include/imapmerge.h Diff File
mod - libs/scene/merge/MergeOperation.cpp Diff File
mod - libs/scene/merge/MergeOperation.h Diff File
mod - test/MapMerging.cpp Diff File
add - test/resources/tdm/maps/merging_layers_4.mapx Diff File

DarkRadiant: merge_layers fafd8a6a

2021-06-07 03:12:14

greebo

Details Diff
0005639: Test covering renaming of layers (plus modification) Affected Issues
0005639
mod - libs/scene/merge/MergeOperation.cpp Diff File
mod - test/MapMerging.cpp Diff File
add - test/resources/tdm/maps/merging_layers_5.mapx Diff File

DarkRadiant: merge_layers 7f74453a

2021-06-07 03:24:38

greebo

Details Diff
0005639: Start implementing the LayerMerger. Affected Issues
0005639
mod - libs/scene/merge/LayerMerger.h Diff File
mod - libs/scene/merge/NodeUtils.h Diff File

DarkRadiant: merge_layers 1f55a9fd

2021-06-07 03:52:18

greebo

Details Diff
0005639: Untested imeplementation of LayerMerger Affected Issues
0005639
mod - libs/scene/merge/LayerMerger.h Diff File

DarkRadiant: merge_layers c7ebb3aa

2021-06-07 04:00:31

greebo

Details Diff
0005639: Expand tests against the merge operation flags Affected Issues
0005639
mod - test/MapMerging.cpp Diff File

DarkRadiant: merge_layers 65c489ce

2021-06-07 04:46:24

greebo

Details Diff
0005639: Minor advancements in the test code, fix call to std::includes Affected Issues
0005639
mod - test/MapMerging.cpp Diff File

DarkRadiant: merge_layers 8e64384c

2021-06-07 04:58:33

greebo

Details Diff
0005639: Fix node removal and addition algorithm in LayerMerger.
We need to add nodes to layers first, since trying to remove a node from its last layer will inevitably put it on Default.
Affected Issues
0005639
mod - libs/scene/merge/LayerMerger.h Diff File

DarkRadiant: merge_layers 245ce0e7

2021-06-08 16:19:30

greebo

Details Diff
0005639: Nodes that are explicitly kept by the user won't have their layers modified Affected Issues
0005639
mod - libs/scene/merge/LayerMerger.h Diff File
mod - test/MapMerging.cpp Diff File

DarkRadiant: merge_layers 39290c45

2021-06-08 16:36:06

greebo

Details Diff
0005639: Expose layer merge option in the control dialog Affected Issues
0005639
mod - install/ui/mergecontroldialog.fbp Diff File
mod - install/ui/mergecontroldialog.xrc Diff File
mod - install/user.xml Diff File
mod - libs/scene/merge/MergeOperation.cpp Diff File
mod - radiant/ui/merge/MergeControlDialog.cpp Diff File

DarkRadiant: master ae4fa10b

2021-06-08 16:55:06

greebo

Details Diff
0005639: Warn the user about layer actions not being undoable Affected Issues
0005639
mod - install/ui/mergecontroldialog.fbp Diff File
mod - install/ui/mergecontroldialog.xrc Diff File

Issue History

Date Modified Username Field Change
06.06.2021 04:28 greebo New Issue
06.06.2021 04:28 greebo Relationship added related to 0005638
06.06.2021 04:29 greebo Relationship added related to 0005623
06.06.2021 04:29 greebo Status new => confirmed
06.06.2021 07:08 greebo Assigned To => greebo
06.06.2021 07:08 greebo Status confirmed => assigned
06.06.2021 18:54 greebo Changeset attached => DarkRadiant merge_layers ed0a3cd0
06.06.2021 18:54 greebo Changeset attached => DarkRadiant merge_layers be4e5878
06.06.2021 18:54 greebo Changeset attached => DarkRadiant merge_layers f9631519
06.06.2021 18:54 greebo Changeset attached => DarkRadiant merge_layers 673b7d9b
08.06.2021 16:19 greebo Changeset attached => DarkRadiant merge_layers fafd8a6a
08.06.2021 16:19 greebo Changeset attached => DarkRadiant merge_layers 7f74453a
08.06.2021 16:19 greebo Changeset attached => DarkRadiant merge_layers 1f55a9fd
08.06.2021 16:19 greebo Changeset attached => DarkRadiant merge_layers c7ebb3aa
08.06.2021 16:19 greebo Changeset attached => DarkRadiant merge_layers 65c489ce
08.06.2021 16:19 greebo Changeset attached => DarkRadiant merge_layers 8e64384c
08.06.2021 16:19 greebo Changeset attached => DarkRadiant merge_layers 245ce0e7
08.06.2021 16:36 greebo Changeset attached => DarkRadiant merge_layers 39290c45
08.06.2021 16:55 greebo Changeset attached => DarkRadiant master ae4fa10b
08.06.2021 17:02 greebo Status assigned => resolved
08.06.2021 17:02 greebo Resolution open => fixed
08.06.2021 17:02 greebo Fixed in Version => 2.13.0