View Issue Details

IDProjectCategoryView StatusLast Update
0005681DarkRadiantGUIpublic27.07.2021 08:55
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.12.0 
Target Version2.13.0Fixed in Version2.13.0 
Summary0005681: Copying a particle in the Particle Editor creates an ___editor list entry which can lead to crashes
DescriptionWhenever one uses the "Copy" button to clone an existing particle, 2 new entries are added to the particle list:
- the intended copy of the particle with the correct name
- another copy of the particle with ___editor appended to the end of the name

Closing and reopening the Particle Editor gets rid of the 2nd entry.
Steps To Reproduce1) In the Particle Editor, select a particle from the list and click "Copy".
2) You're prompted for a name for the particle, then for the name/location of the .prt file. Fill this out and click OK.
3) 2 entries are added to the list, as per the description.
4) Close the editor, then open it again. Now only 1 of the new entries remains.
TagsNo tags attached.

Activities

greebo

greebo

27.07.2021 05:25

administrator   ~0014192

That second particle is a "working copy", which is displayed and modified before you hit save, at which point the working copy will be overwriting the "real" one.
I can maybe look into hiding it from the list, it's an internal thing anyway. Does it cause any troubles, or can it get you into weird situations?
greebo

greebo

27.07.2021 05:37

administrator   ~0014193

I added a quick fix to hide these __editor particles from the list, as they really shouldn't show up there.
Dragofer

Dragofer

27.07.2021 07:44

developer   ~0014194

DR crashes if I try to save changes made to the ___editor version, so that does qualify as troubles. Changes made to the "real" version are saved properly even if the ___editor version is visible in the list, so it looks like there's no need to see the ___editor version.
greebo

greebo

27.07.2021 08:01

administrator   ~0014195

Ok, then the fix should resolve the problem.

The portable package in the build artifacts (https://github.com/codereader/DarkRadiant/runs/3168561451) should contain the fix, if you'd like to check it out (you have to be logged on at Github though).

Related Changesets

DarkRadiant: master cf5212b1

2021-07-27 05:37:24

greebo

Details Diff
0005681: Don't add the __editor particle copies to the list of existing defs Affected Issues
0005681
mod - radiant/ui/particles/ParticleEditor.cpp Diff File

Issue History

Date Modified Username Field Change
23.07.2021 21:32 Dragofer New Issue
27.07.2021 05:25 greebo Note Added: 0014192
27.07.2021 05:25 greebo Status new => feedback
27.07.2021 05:37 greebo Changeset attached => DarkRadiant master cf5212b1
27.07.2021 05:37 greebo Note Added: 0014193
27.07.2021 07:44 Dragofer Note Added: 0014194
27.07.2021 07:44 Dragofer Status feedback => new
27.07.2021 08:01 greebo Note Added: 0014195
27.07.2021 08:01 greebo Assigned To => greebo
27.07.2021 08:01 greebo Status new => assigned
27.07.2021 08:01 greebo Target Version => 2.13.0
27.07.2021 08:01 greebo Status assigned => resolved
27.07.2021 08:01 greebo Resolution open => fixed
27.07.2021 08:01 greebo Fixed in Version => 2.13.0
27.07.2021 08:55 greebo Summary Copying a particle in the Particle Editor creates 2 entries => Copying a particle in the Particle Editor creates an ___editor list entry which can lead to crashes