View Issue Details

IDProjectCategoryView StatusLast Update
0005682DarkRadiantGUIpublic09.08.2021 15:53
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.12.0 
Target Version2.13.0Fixed in Version2.13.0 
Summary0005682: Problems with particle preview
DescriptionDR generally tries to show previews of particles in camera view, but this preview often doesn’t show up or doesn’t look much like the particle. It’s also prone to rendering issues such as that the transparent textures become opaque when selected, or that other transparent textures behind or in front of it are obscured even if the preview itself seems to be invisible. In orthoview, the preview often increases the bounds considerably beyond the func_emitter itself.

There was some discussion of these issues in the DR forums, with the general consensus being that particle previews aren’t that useful in non-lighting mode, so may be best to disable them. Personally to me it looks like the same pros/cons exist in lighting mode, too, so maybe entities should generally not show previews of particles anymore?

https://forums.thedarkmod.com/index.php?/topic/21005-selecting-some-emitters/
TagsNo tags attached.

Activities

greebo

greebo

06.08.2021 08:21

administrator   ~0014242

I've removed the wireframe rendering for selected particle emitters, so all the particle quads don't get rendered all over the place. This is how it looks like in non-lighting cam preview, I hope this does the trick?
Dragofer

Dragofer

08.08.2021 18:12

developer   ~0014268

Last edited: 08.08.2021 18:13

That's looking good ^

Admittedly this was a multi-issue ticket since that forum thread highlighted quite a few issues with particles, and there was a general mood that particle previews aren't that useful in non-lighting mode. But I think properly working particle previews would be great.

Here's another image showing another of the issues mentioned, which is that particle previews can obstruct rendering of transparent surfaces such as water.
In this case, the dustfog1 particle is blotting out the water_clear surface. There's no sign of the fog particle itself.
Note that this was made on a PC with an AMD graphics card.
5682.png (104,412 bytes)   
5682.png (104,412 bytes)   
greebo

greebo

08.08.2021 18:14

administrator   ~0014269

Has this screenshot been made with the 2.13.0 sources?
Dragofer

Dragofer

08.08.2021 18:31

developer   ~0014270

Last edited: 08.08.2021 18:31

No, that's still DR 2.13pre3. I should look into getting setup for compiling latest DR, too.
greebo

greebo

08.08.2021 18:59

administrator   ~0014271

Last edited: 08.08.2021 18:59

You can always grab a portable snapshot build from the Github actions page: https://github.com/codereader/DarkRadiant/runs/3274515207
(There's the Artifacts dropdown on the top right where you can download a portable package). You have to be signed in though.
Dragofer

Dragofer

09.08.2021 15:52

developer   ~0014274

Last edited: 09.08.2021 15:53

Alright, that's let me confirm that the issue shown in the previous screenshot no longer persists, thanks! Foggy watery areas will be easier to handle.

Got a small regression to report though: in DR 2.13pre3, the bounds of a func_emitter with tdm_dustfog1.prt measure 24x24x24 units (so just the emitter box), but in build 0000178 it's 547x423x375 units, so including the whole particle bounds. This makes it more difficult to rotate without changing its origin without the correct settings. It's also odd considering I can't see any particle preview for this particle in the Camera.

Would probably be worth it to open a new ticket for this?

Related Changesets

DarkRadiant: master c895b4f9

2021-08-06 08:20:42

greebo

Details Diff
0005682: Don't render the particle quads as highlighted when their parent is selected Affected Issues
0005682
mod - libs/render/RenderableCollectionWalker.h Diff File

Issue History

Date Modified Username Field Change
24.07.2021 15:26 Dragofer New Issue
06.08.2021 06:43 greebo Status new => confirmed
06.08.2021 06:43 greebo Target Version => 2.13.0
06.08.2021 06:43 greebo Assigned To => greebo
06.08.2021 06:43 greebo Status confirmed => assigned
06.08.2021 08:20 greebo Changeset attached => DarkRadiant master c895b4f9
06.08.2021 08:20 greebo Status assigned => resolved
06.08.2021 08:20 greebo Resolution open => fixed
06.08.2021 08:20 greebo Fixed in Version => 2.13.0
06.08.2021 08:21 greebo Note Added: 0014242
06.08.2021 08:21 greebo File Added: 2021-08-06 08_41_56-unnamed.map _.png
08.08.2021 18:12 Dragofer Note Added: 0014268
08.08.2021 18:12 Dragofer File Added: 5682.png
08.08.2021 18:13 Dragofer Note Edited: 0014268
08.08.2021 18:14 greebo Note Added: 0014269
08.08.2021 18:31 Dragofer Note Added: 0014270
08.08.2021 18:31 Dragofer Note Edited: 0014270
08.08.2021 18:59 greebo Note Added: 0014271
08.08.2021 18:59 greebo Note Edited: 0014271
09.08.2021 15:52 Dragofer Note Added: 0014274
09.08.2021 15:53 Dragofer Note Edited: 0014274