View Issue Details

IDProjectCategoryView StatusLast Update
0005767DarkRadiantMap Editingpublic01.10.2021 10:22
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.13.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0005767: Flip Texture: Prevent huge face UV coordinate translations
DescriptionThe regular FlipTextureS/FlipTextureT commands should use the same algorithms as the Texture Tool, to prevent face UV coordinates from making huge jumps in the UV plane.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master d3aa245a

2021-10-01 06:40:31

greebo

Details Diff
0005767: Start unifying the algorithms by moving the texture tool node processor to selection::algorithm namespace, into Texturing.h/.cpp Affected Issues
0005767
mod - radiantcore/CMakeLists.txt Diff File
add - radiantcore/selection/algorithm/Texturing.cpp Diff File
add - radiantcore/selection/algorithm/Texturing.h Diff File
mod - radiantcore/selection/textool/TextureToolSelectionSystem.cpp Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: master d850f7c3

2021-10-01 08:20:49

greebo

Details Diff
0005767: Create separate test fixture to test Texture Manipulation Affected Issues
0005767
mod - radiantcore/selection/algorithm/Texturing.cpp Diff File
mod - radiantcore/selection/algorithm/Texturing.h Diff File
mod - radiantcore/selection/textool/TextureToolSelectionSystem.cpp Diff File
mod - test/Brush.cpp Diff File
mod - test/CMakeLists.txt Diff File
add - test/TextureManipulation.cpp Diff File
mod - test/algorithm/Primitives.h Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: master 9e9a81fa

2021-10-01 08:29:47

greebo

Details Diff
0005767: Unit tests for flipping face and patch textures Affected Issues
0005767
mod - test/TextureManipulation.cpp Diff File
mod - test/TextureTool.cpp Diff File
mod - test/algorithm/Primitives.h Diff File

DarkRadiant: master 5e8956b1

2021-10-01 09:15:53

greebo

Details Diff
0005767: Fix crash at shutdown due to PatchInspector placing itself as observer on selected patches even though it's not visible.
Remove the TexTool and PatchInspector update callouts from SurfaceInspector, they should listen to changes on their own.
Affected Issues
0005767
mod - radiant/ui/patch/PatchInspector.cpp Diff File
mod - radiant/ui/surfaceinspector/SurfaceInspector.cpp Diff File

DarkRadiant: master 2134f74d

2021-10-01 09:17:42

greebo

Details Diff
0005767: Flip Texture is now using the textool algorithm Affected Issues
0005767
mod - radiantcore/selection/algorithm/Shader.cpp Diff File
mod - radiantcore/selection/algorithm/Shader.h Diff File
mod - radiantcore/selection/algorithm/Texturing.cpp Diff File
mod - radiantcore/selection/algorithm/Texturing.h Diff File
mod - radiantcore/selection/textool/TextureToolSelectionSystem.cpp Diff File

DarkRadiant: master 3e0b6a0a

2021-10-01 10:02:34

greebo

Details Diff
0005767: Replace the old Patch::flipTexture algorithm Affected Issues
0005767
mod - radiantcore/patch/Patch.cpp Diff File
mod - radiantcore/selection/algorithm/Texturing.cpp Diff File
mod - radiantcore/selection/algorithm/Texturing.h Diff File

DarkRadiant: master 1f9ece67

2021-10-01 10:16:05

greebo

Details Diff
0005767: Replace the old Face::flipTexture algorithm Affected Issues
0005767
mod - radiantcore/brush/Face.cpp Diff File
mod - radiantcore/brush/TextureProjection.cpp Diff File
mod - radiantcore/brush/TextureProjection.h Diff File
mod - radiantcore/selection/algorithm/Texturing.cpp Diff File
mod - radiantcore/selection/algorithm/Texturing.h Diff File

Issue History

Date Modified Username Field Change
01.10.2021 06:39 greebo New Issue
01.10.2021 06:39 greebo Assigned To => greebo
01.10.2021 06:39 greebo Status new => assigned
01.10.2021 09:47 greebo Changeset attached => DarkRadiant master d3aa245a
01.10.2021 09:47 greebo Changeset attached => DarkRadiant master d850f7c3
01.10.2021 09:47 greebo Changeset attached => DarkRadiant master 9e9a81fa
01.10.2021 09:47 greebo Changeset attached => DarkRadiant master 5e8956b1
01.10.2021 09:47 greebo Changeset attached => DarkRadiant master 2134f74d
01.10.2021 10:16 greebo Changeset attached => DarkRadiant master 3e0b6a0a
01.10.2021 10:16 greebo Changeset attached => DarkRadiant master 1f9ece67
01.10.2021 10:22 greebo Target Version => 2.14.0
01.10.2021 10:22 greebo Status assigned => resolved
01.10.2021 10:22 greebo Resolution open => fixed
01.10.2021 10:22 greebo Fixed in Version => 2.14.0
01.10.2021 10:22 greebo Summary Flip Texture prevent huge face UV coordinate translations => Flip Texture: Prevent huge face UV coordinate translations