View Issue Details

IDProjectCategoryView StatusLast Update
0005771DarkRadiantMap Editingpublic03.10.2021 19:12
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.13.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0005771: Improve pasting textures to angled faces sharing an edge
DescriptionPasting a texture between two faces of the same brush (sharing an edge) should yield a seamless transition between the two faces.
TagsNo tags attached.

Activities

greebo

greebo

03.10.2021 12:17

administrator  

grafik.png (42,298 bytes)   
grafik.png (42,298 bytes)   
greebo

greebo

03.10.2021 18:09

administrator   ~0014392

First version:
paste_texture.gif (123,799 bytes)   
paste_texture.gif (123,799 bytes)   

Related Changesets

DarkRadiant: master dcbb2f29

2021-10-03 12:19:47

greebo

Details Diff
0005771: Add unit test with the brush faces that should be textured by pasting Affected Issues
0005771
mod - test/Selection.cpp Diff File
mod - test/TextureManipulation.cpp Diff File
mod - test/algorithm/View.h Diff File
mod - test/resources/tdm/maps/simple_brushes.map Diff File

DarkRadiant: master f2d97567

2021-10-03 15:28:50

greebo

Details Diff
0005771: Implement the first of several possible cases. Pasting across from z-facing to y-facing is working, and X/Y-facing sides of a cuboid are working too, but z-facing to x-facing is not. Affected Issues
0005771
mod - radiantcore/brush/Face.cpp Diff File
mod - radiantcore/selection/algorithm/Shader.cpp Diff File

DarkRadiant: master 99bd25c7

2021-10-03 17:17:57

greebo

Details Diff
0005771: Add one more unit test using a face that ends up using a 90 degree rotated texture after pasting. The current algorithm doesn't deal with that correctly, yielding an invalid texture matrix. Affected Issues
0005771
mod - test/TextureManipulation.cpp Diff File
mod - test/resources/tdm/maps/simple_brushes.map Diff File

DarkRadiant: master 59a5fc00

2021-10-03 17:55:14

greebo

Details Diff
0005771: Simpler, but more effective algorithm, wrapping the texture of the source face around the shared edge, extrapolating it. Affected Issues
0005771
mod - radiantcore/brush/Face.cpp Diff File
mod - radiantcore/brush/TextureProjection.cpp Diff File
mod - radiantcore/brush/TextureProjection.h Diff File

DarkRadiant: master b2f6ab9b

2021-10-03 19:12:29

greebo

Details Diff
0005771: Improve the texture wrapping by using an extrapolation vector that is orthogonal to the edge center, since the source brush might be skewed. Affected Issues
0005771
mod - radiantcore/brush/Face.cpp Diff File

Issue History

Date Modified Username Field Change
03.10.2021 12:17 greebo New Issue
03.10.2021 12:17 greebo File Added: grafik.png
03.10.2021 12:17 greebo Assigned To => greebo
03.10.2021 12:17 greebo Status new => assigned
03.10.2021 17:55 greebo Changeset attached => DarkRadiant master dcbb2f29
03.10.2021 17:55 greebo Changeset attached => DarkRadiant master f2d97567
03.10.2021 17:55 greebo Changeset attached => DarkRadiant master 99bd25c7
03.10.2021 17:55 greebo Changeset attached => DarkRadiant master 59a5fc00
03.10.2021 17:56 greebo Target Version => 2.14.0
03.10.2021 17:56 greebo Status assigned => resolved
03.10.2021 17:56 greebo Resolution open => fixed
03.10.2021 17:56 greebo Fixed in Version => 2.14.0
03.10.2021 17:56 greebo Product Version 2.14.0 => 2.13.0
03.10.2021 18:09 greebo Note Added: 0014392
03.10.2021 18:09 greebo File Added: paste_texture.gif
03.10.2021 19:12 greebo Changeset attached => DarkRadiant master b2f6ab9b