View Issue Details

IDProjectCategoryView StatusLast Update
0000578The Dark ModDesign/Codingpublic12.05.2013 11:46
ReporterKomag Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0000578: falling on a lowering platform doesn't properly subtract the relative velocity, so you get more hurt than you should
DescriptionIn my very fast elevator if I jump and start it going down, the elevator is lowering just slightly slower than I am falling, so I'm 'catching up' to it downward, but by the time I gently touch down inside the elevator (long before the elevator has reached the bottom level) I suddenly get killed as though I've fallen 50 feet and smashed into concrete.

I figure the game doesn't know the elevator is going down very fast too, so that the impact should be very minimal, but rather the game simply knows how far I've falled (or it just knows my velocity) and then it knows I've "touched down" and thus I get killed.

Is there any way to have the game take notice of any downward velocity of what I land on, and subtract it from my own downward velocity?
TagsNo tags attached.

Relationships

related to 0003407 closeduser81 Jumping on a moveable crate on a moving elevator can kill you 

Activities

grayman

grayman

19.02.2013 03:24

administrator   ~0005078

Take velocity of what the player or AI is landing on into account.

rev. 5699:

Actor.cpp
tels

tels

12.05.2013 11:44

reporter   ~0005418

The current version of the fix discounts moveables (because some of them can have high velocity). However, that would mean you can't jump on a stack of crates sitting on an elevator.

A better fix would maybe take into account the speed (and/or mass) of the moveable, and ignore them only if certain conditions are met.

Issue History

Date Modified Username Field Change
15.02.2008 18:48 Komag New Issue
16.02.2008 19:54 greebo Project DarkRadiant => The Dark Mod
06.04.2009 03:55 douga Status new => assigned
06.04.2009 03:55 douga Assigned To => douga
04.02.2012 04:11 grayman Assigned To douga => grayman
19.02.2013 03:24 grayman Note Added: 0005078
19.02.2013 03:24 grayman Status assigned => resolved
19.02.2013 03:24 grayman Resolution open => fixed
19.02.2013 03:24 grayman Product Version 0.9.5 =>
19.02.2013 03:24 grayman Fixed in Version => TDM 2.00
19.02.2013 03:24 grayman Target Version => TDM 2.00
12.05.2013 11:44 tels Note Added: 0005418
12.05.2013 11:46 tels Relationship added related to 0003407