View Issue Details

IDProjectCategoryView StatusLast Update
0005783DarkRadiantMap Editingpublic22.10.2021 14:10
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.13.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0005783: EntityInspector allows to set an entity's name to an empty value
DescriptionMethod 1: Cut the "name" spawnarg
Method 2: Just select the name and set an empty value using Enter or the checkmark button

In both cases, an assertion will fire in Debug builds since an empty name is not really supported by the code. The app doesn't crash in release configurations, but such a change should be disallowed.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 80f1b2fb

2021-10-22 13:35:19

greebo

Details Diff
0005783: Don't allow to remove "name" entity key values Affected Issues
0005783
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

Issue History

Date Modified Username Field Change
18.10.2021 10:01 greebo New Issue
18.10.2021 10:01 greebo Status new => confirmed
18.10.2021 10:02 greebo Reproducibility have not tried => always
22.10.2021 13:34 greebo Assigned To => greebo
22.10.2021 13:34 greebo Status confirmed => assigned
22.10.2021 13:34 greebo Target Version => 2.14.0
22.10.2021 13:43 greebo Description Updated
22.10.2021 13:43 greebo Status assigned => resolved
22.10.2021 13:43 greebo Resolution open => fixed
22.10.2021 13:43 greebo Fixed in Version => 2.14.0
22.10.2021 14:10 greebo Changeset attached => DarkRadiant master 80f1b2fb