View Issue Details

IDProjectCategoryView StatusLast Update
0005799DarkRadiantGUIpublic05.11.2021 16:22
ReporterBikerdude Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 (21H1)
Product Version2.14.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0005799: Texture Tool: dragged vertices snap to grid even though it's switched off
DescriptionVert points aren't on by default like they were in 2.12 and when dragging a vert point around with grid disabled, its snapping around as if grid 'was' enabled.

Here is a video of the issue/s - https://youtu.be/9AGFRreYFqw?t=119
TagsNo tags attached.

Activities

greebo

greebo

05.11.2021 14:34

administrator   ~0014503

Last edited: 05.11.2021 14:36

OK, I get the point about the vertices snapping to the grid even though it's switched off, I can address that.

Vertex mode is not enabled by default, since you can now drag around faces and patches as a whole, after selecting them clicking anywhere in their covered area.
Bikerdude

Bikerdude

05.11.2021 14:45

reporter   ~0014505

"Vertex mode is not enabled by default, since you can now drag around faces and patches as a whole, after selecting them clicking anywhere in their covered area."

Ah ok, I did wonder if that was possible, nice.
Bikerdude

Bikerdude

05.11.2021 15:23

reporter   ~0014507

"since you can now drag around faces and patches as a whole, after selecting them clicking anywhere in their covered area."

How do we do that in texture tool exactly..? I tried pressing the QE button on and off and I cant drag the texture or its edges at all, I have to enable vertices and move them around.
greebo

greebo

05.11.2021 15:30

administrator   ~0014508

Shift-Select the item you want to drag-around. It's working the same as in the regular mapping view.
Bikerdude

Bikerdude

05.11.2021 16:22

reporter   ~0014512

thank you.

Related Changesets

DarkRadiant: master 3bff7212

2021-11-05 15:02:29

greebo

Details Diff
0005799: Texture Tool drag manipulator shouldn't grid-snap when it's switched off. Affected Issues
0005799
mod - include/itexturetoolmodel.h Diff File
mod - radiant/selection/ManipulateMouseTool.cpp Diff File
mod - radiant/selection/ManipulateMouseTool.h Diff File
mod - radiant/selection/SceneManipulateMouseTool.cpp Diff File
mod - radiant/selection/SceneManipulateMouseTool.h Diff File
mod - radiant/textool/TexTool.cpp Diff File
mod - radiant/textool/tools/TextureToolManipulateMouseTool.cpp Diff File
mod - radiant/textool/tools/TextureToolManipulateMouseTool.h Diff File

Issue History

Date Modified Username Field Change
05.11.2021 12:59 Bikerdude New Issue
05.11.2021 12:59 Bikerdude Relationship added related to 0005798
05.11.2021 12:59 Bikerdude Relationship deleted related to 0005798
05.11.2021 14:34 greebo Note Added: 0014503
05.11.2021 14:36 greebo Note Edited: 0014503
05.11.2021 14:38 greebo Summary Texture manipulation on patches in texture tool broken => Texture Tool: dragged vertices snap to grid even though it's switched off
05.11.2021 14:38 greebo Status new => acknowledged
05.11.2021 14:45 Bikerdude Note Added: 0014505
05.11.2021 14:58 greebo Product Version 2.13.0 => 2.14.0
05.11.2021 14:58 greebo Target Version => 2.14.0
05.11.2021 14:58 greebo Assigned To => greebo
05.11.2021 14:58 greebo Status acknowledged => assigned
05.11.2021 15:02 greebo Changeset attached => DarkRadiant master 3bff7212
05.11.2021 15:02 greebo Status assigned => resolved
05.11.2021 15:02 greebo Resolution open => fixed
05.11.2021 15:02 greebo Fixed in Version => 2.14.0
05.11.2021 15:23 Bikerdude Note Added: 0014507
05.11.2021 15:30 greebo Note Added: 0014508
05.11.2021 16:22 Bikerdude Note Added: 0014512