View Issue Details

IDProjectCategoryView StatusLast Update
0005817DarkRadiantGUIpublic21.11.2021 16:48
ReporterDragofer Assigned To 
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.14.0 
Fixed in Version2.14.0 
Summary0005817: 2.14pre1: "Choose x..." on inherited spawnargs deficient
DescriptionVarious spawnargs offer "Choose x..." buttons in the entity inspector when clicked on. For example, the "model" spawnarg offers:
1) Choose model...
2) Choose skin...
3) Choose particle...

If the spawnarg only exists in the "inherited properties" list, then these "Choose x..." buttons tend to open without the correct entry selected, for example the Model Chooser is opened without any model selected. "Choose skin..." won't open at all, throwing an error message:
"The model key values of the selection are ambiguous, cannot choose a skin."

If the spawnarg is applied to the entity by clicking on the checkmark, so that it no longer only exists as an inherited property, then the "Choose x..." buttons work as normal again (i.e. they open a Chooser and with the correct entry selected) like in previous DR versions.
Steps To Reproduce1) Create entity > atdm:loot_painting_large
2) Enable "show inherited properties" in the entity inspector, then click on the "model" spawnarg.
3) Click on the "Choose skin..." button. The Skin Chooser fails to open with an error message as mentioned in the description.
4) Click on the "Choose model..." button. The Model Chooser opens, but without any model selected.

5) Click on the checkmark in the bottom right of the entity inspector to apply the "model" spawnarg. The spawnarg now no longer only exists as an inherited property.
6) Click on the "Choose skin..." button. The Skin Chooser now opens correctly.
7) Click on the "Choose model..." button. The Model Chooser now opens correctly with the painting model selected.
TagsNo tags attached.

Relationships

duplicate of 0005801 resolvedgreebo Applying a skin to a model entity no longer works under 2.14pre1 
related to 0005813 resolvedgreebo Spawnarg types and tooltips not reliably inherited in entityDefs 

Activities

greebo

greebo

21.11.2021 16:48

administrator   ~0014562

This has been fixed in the meantime, it should be resolved in recent master builds.

Issue History

Date Modified Username Field Change
20.11.2021 12:45 Dragofer New Issue
20.11.2021 15:27 Dragofer Steps to Reproduce Updated
20.11.2021 15:31 Dragofer Summary 2.14pre1: Can't "Choose skin..." on inherited "model" spawnarg => 2.14pre1: "Choose x..." on inherited spawnargs deficient
20.11.2021 15:31 Dragofer Description Updated
20.11.2021 16:42 greebo Status new => acknowledged
21.11.2021 16:46 greebo Relationship added related to 0005813
21.11.2021 16:48 greebo Relationship added duplicate of 0005801
21.11.2021 16:48 greebo Status acknowledged => resolved
21.11.2021 16:48 greebo Resolution open => duplicate
21.11.2021 16:48 greebo Fixed in Version => 2.14.0
21.11.2021 16:48 greebo Note Added: 0014562