View Issue Details

IDProjectCategoryView StatusLast Update
0005838DarkRadiantMap Editingpublic02.03.2022 04:29
ReporterBrendonChung Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionunable to reproduce 
OSWindows 10 
Product Version2.14.0 
Fixed in Version3.0.0 
Summary0005838: Rotating a brush results in erratic movement
DescriptionWhen I rotate a brush and then move the brush, the brush instantly moves to a distant location.

Video here: https://www.youtube.com/watch?v=NKPZSL1Qp7o

Note: this seems to only happen to entity brushes, not world brushes.
Steps To Reproduce1. Select a brush.
1. Rotate brush using the Z-rotate button.
2. Click and drag the brush to move it. The brush moves to a distant location.
TagsNo tags attached.

Activities

greebo

greebo

01.03.2022 11:17

administrator   ~0014747

Last edited: 01.03.2022 11:18

Can't reproduce that behaviour - do you still have that map around, and is it still happening?
BrendonChung

BrendonChung

01.03.2022 19:21

reporter   ~0014753

Hi -- I just updated to the latest in-progress build (https://github.com/codereader/DarkRadiant/actions) and this behavior is no longer happening.

I believe that when I submitted this report, it was on the official 2.14 release build from last year.
greebo

greebo

02.03.2022 04:29

administrator   ~0014754

Thanks for checking, I'll set this to resolved. Please re-open in case it's hitting you again.

Issue History

Date Modified Username Field Change
15.12.2021 20:50 BrendonChung New Issue
17.12.2021 13:03 greebo Status new => acknowledged
13.01.2022 20:43 BrendonChung Description Updated
01.03.2022 11:17 greebo Status acknowledged => feedback
01.03.2022 11:17 greebo Note Added: 0014747
01.03.2022 11:18 greebo Note Edited: 0014747
01.03.2022 19:21 BrendonChung Note Added: 0014753
01.03.2022 19:21 BrendonChung Status feedback => new
02.03.2022 04:29 greebo Assigned To => greebo
02.03.2022 04:29 greebo Status new => resolved
02.03.2022 04:29 greebo Resolution open => unable to reproduce
02.03.2022 04:29 greebo Fixed in Version => 3.0.0
02.03.2022 04:29 greebo Note Added: 0014754