View Issue Details

IDProjectCategoryView StatusLast Update
0005846DarkRadiantMap Editingpublic01.03.2022 06:12
ReporterIZaRTaX Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows 7OS Versionx64
Product Version2.14.0 
Target Version3.0.0Fixed in Version3.0.0 
Summary0005846: Rotating a func_static result to random stretch textures
DescriptionAs the title say, when you rotate a func static made with brushes or patches a textures glitch appear

I personally use custom rotation key binding like CTRL+D to rotate at 90°

https://youtu.be/EMw_mmSai0I


TagsNo tags attached.

Relationships

has duplicate 0005854 resolvedgreebo Rotating Prefab breaks texturing on some brushes 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 78e97bb7

2022-02-27 15:20:44

greebo

Details Diff
0005846: Add unit test covering the problem Affected Issues
0005846
mod - test/TextureManipulation.cpp Diff File
add - test/resources/tdm/maps/rotate_with_texlock.map Diff File

DarkRadiant: master aaf11c44

2022-02-28 03:49:24

greebo

Details Diff
0005846: Fix texture being messed up by 90 degree rotations of brushes. Freezetransform is triggering a second evaluation of the current transformation (which is identity) - this was messing up the texDefTransformed() algorithm since the winding vertices were still at the old position. The face normal ended up being parallel to the face plane. The quick solution here is to ignore identity transforms in Face::transform. Affected Issues
0005846
mod - radiantcore/brush/BrushNode.cpp Diff File
mod - test/TextureManipulation.cpp Diff File

Issue History

Date Modified Username Field Change
17.12.2021 23:15 IZaRTaX New Issue
17.12.2021 23:16 IZaRTaX Description Updated
17.12.2021 23:17 IZaRTaX Description Updated
17.12.2021 23:17 IZaRTaX Description Updated
17.12.2021 23:18 IZaRTaX Description Updated
27.02.2022 08:56 greebo Status new => confirmed
28.02.2022 03:49 greebo Assigned To => greebo
28.02.2022 03:49 greebo Status confirmed => assigned
28.02.2022 03:50 greebo Changeset attached => DarkRadiant master 78e97bb7
28.02.2022 03:50 greebo Changeset attached => DarkRadiant master aaf11c44
28.02.2022 03:50 greebo Status assigned => resolved
28.02.2022 03:50 greebo Resolution open => fixed
28.02.2022 03:50 greebo Fixed in Version => 3.0.0
28.02.2022 03:50 greebo Target Version => 3.0.0
01.03.2022 06:12 greebo Relationship added has duplicate 0005854