View Issue Details

IDProjectCategoryView StatusLast Update
0005893DarkRadiantRendererpublic02.04.2022 05:22
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Target Version3.0.0Fixed in Version3.0.0 
Summary0005893: Entity-to-light mapping structures for lighting mode rendering
DescriptionFollowup to 0005584 which broke lighting mode rendering. The task is to create the infrastructure necessary for scene nodes to register their surfaces and associate them to (render) entities. The backend renderer then has the chance to process the renderables grouped by light, entity and material.
TagsNo tags attached.

Relationships

related to 0005584 resolvedgreebo Move openGL render calls to Backend 
related to 0005908 resolvedgreebo Fix Material Preview rendering 
related to 0005582 closedgreebo Front End Renderer Advancements 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: lighting_mode 25e7ecd0

2022-01-26 11:39:57

greebo

Details Diff
0005893: Start extending the ISurfaceRenderer interface to accept the IRenderEntity a surface is associated with. Affected Issues
0005893
mod - include/isurfacerenderer.h Diff File
mod - libs/render/RenderableSurface.h Diff File
mod - radiantcore/model/NullModelNode.cpp Diff File
mod - radiantcore/model/NullModelNode.h Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - radiantcore/rendersystem/backend/SurfaceRenderer.h Diff File

DarkRadiant: lighting_mode 21c10aee

2022-01-26 11:53:59

greebo

Details Diff
0005893: Fix NullModel rendering Affected Issues
0005893
mod - libs/render/RenderableSurface.h Diff File
mod - radiantcore/model/NullModelNode.cpp Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File

DarkRadiant: lighting_mode a320e519

2022-01-26 11:57:47

greebo

Details Diff
0005893: Fix speaker volumes sticking around after hiding the speaker node Affected Issues
0005893
mod - radiantcore/entity/speaker/SpeakerNode.cpp Diff File
mod - radiantcore/entity/speaker/SpeakerNode.h Diff File

DarkRadiant: lighting_mode c69690b2

2022-01-26 13:54:00

greebo

Details Diff
0005893: Extend the rendersystem interface to support entity registration, deregistration and enumeration. Add a couple of unit tests. Affected Issues
0005893
mod - include/irender.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - test/Renderer.cpp Diff File

DarkRadiant: lighting_mode c613673c

2022-01-26 14:36:03

greebo

Details Diff
0005893: Entity registration in rendersystem implemented Affected Issues
0005893
mod - include/irender.h Diff File
mod - libs/render/RenderableSurface.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - test/Renderer.cpp Diff File

DarkRadiant: lighting_mode 6822fccc

2022-01-26 18:54:22

greebo

Details Diff
0005893: Let StaticModelNode attach its renderable surfaces to the render entity. Affected Issues
0005893
mod - include/irender.h Diff File
mod - include/isurfacerenderer.h Diff File
mod - libs/render/RenderableSurface.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/model/NullModelNode.cpp Diff File
mod - radiantcore/model/NullModelNode.h Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - radiantcore/rendersystem/backend/SurfaceRenderer.h Diff File

DarkRadiant: lighting_mode c1996a67

2022-01-27 03:38:41

greebo

Details Diff
0005893: Detect light entities automatically in addEntity/removeEntity Affected Issues
0005893
mod - include/irender.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - test/Renderer.cpp Diff File

DarkRadiant: lighting_mode da0a46fb

2022-01-27 05:00:55

greebo

Details Diff
0005893: Add separate entry point to RenderSystem for drawing the scene in lighting mode. Affected Issues
0005893
mod - include/irender.h Diff File
mod - radiant/camera/CamWnd.cpp Diff File
add - radiantcore/rendersystem/LightingModeRenderResult.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode 8f56350d

2022-01-27 06:29:15

greebo

Details Diff
0005893: Add IRenderEntity::foreachSurfaceTouchingBounds to enumerate the ones intersecting with a given light. Affected Issues
0005893
mod - include/irender.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/rendersystem/LightingModeRenderResult.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File

DarkRadiant: lighting_mode 6bc219f9

2022-01-27 08:52:08

greebo

Details Diff
0005893: Coarse implementation of the surface collection used by IRenderEntities. Affected Issues
0005893
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
add - radiantcore/entity/RenderableSurfaceCollection.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode 2e61d96a

2022-01-27 09:23:15

greebo

Details Diff
0005893: The RenderableSurfaceCollection is now notified when any of the contained surfaces are changing their bounds. Affected Issues
0005893
mod - include/isurfacerenderer.h Diff File
mod - libs/render/RenderableSurface.h Diff File
mod - libs/scene/Node.h Diff File
mod - radiantcore/entity/RenderableSurfaceCollection.h Diff File
mod - radiantcore/model/NullModelNode.cpp Diff File
mod - radiantcore/model/NullModelNode.h Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/model/StaticModelNode.h Diff File
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File
mod - radiantcore/model/md5/MD5ModelNode.h Diff File

DarkRadiant: lighting_mode df10ec64

2022-01-27 13:44:50

greebo

Details Diff
0005893: Models are beginning to show up in the render view. The LightInteraction class will invoke the surface rendering per light, per entity, per material, per shader pass, per surface. The depth fill pass seems to be broken at this point. Affected Issues
0005893
mod - include/irender.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/entity/RenderableSurfaceCollection.h Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
add - radiantcore/rendersystem/LightInteraction.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode 328e9bc2

2022-01-27 17:02:40

greebo

Details Diff
0005893: Move LightInteractions class implementation to separate source file Affected Issues
0005893
mod - radiantcore/CMakeLists.txt Diff File
rm - radiantcore/rendersystem/LightInteraction.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
add - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
add - radiantcore/rendersystem/backend/LightInteractions.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode 58bf5046

2022-01-28 03:50:23

greebo

Details Diff
0005893: Separate the depth fill pass from the other passes Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File

DarkRadiant: lighting_mode 9f0439ca

2022-01-28 04:32:13

greebo

Details Diff
0005893: Missing entityDefs should not end up with invalid colours Affected Issues
0005893
mod - radiantcore/eclass/EntityClass.cpp Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode c1517112

2022-01-28 09:52:45

greebo

Details Diff
0005893: For now we're rendering without vertex colours. Fix client state flags in LightInteractions passes Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File

DarkRadiant: lighting_mode 58e11221

2022-01-28 09:57:32

greebo

Details Diff
0005893: Count glDrawElements calls Affected Issues
0005893
mod - radiantcore/rendersystem/LightingModeRenderResult.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File

DarkRadiant: lighting_mode 71b3f66e

2022-01-28 10:49:09

greebo

Details Diff
0005893: Cut off redundant calculations Affected Issues
0005893
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.h Diff File

DarkRadiant: lighting_mode 30edbc69

2022-01-28 11:52:58

greebo

Details Diff
0005893: Refactoring Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File

DarkRadiant: lighting_mode 652a3147

2022-01-28 14:52:40

greebo

Details Diff
0005893: Don't even consider invisible materials in the collect surfaces phase Affected Issues
0005893
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File

DarkRadiant: lighting_mode 8ca921bb

2022-01-28 14:52:57

greebo

Details Diff
0005893: Attach MD5 model surfaces to their render entity Affected Issues
0005893
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File

DarkRadiant: lighting_mode 03bcfaee

2022-01-28 15:19:30

greebo

Details Diff
0005893: Fix crash when rendering shaders without materials in lighting mode.
Fix GL program state leak which caused the ortho view grid to appear black
Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File

DarkRadiant: lighting_mode 51305f1d

2022-01-28 15:20:26

greebo

Details Diff
0005893: NullModels are rendering in lighting mode as grey boxes Affected Issues
0005893
mod - radiantcore/model/NullModelNode.cpp Diff File
mod - radiantcore/model/NullModelNode.h Diff File

DarkRadiant: lighting_mode a249291c

2022-01-29 03:22:21

greebo

Details Diff
0005893: Reimplement GeometryRenderer.VertexBuffer to use data structures suitable for glMultiDrawElementsBaseVertex.
This removes the need of recalculating a lot of indices, and allows the renderer to cherry-pick the submitted surfaces.
Affected Issues
0005893
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File

DarkRadiant: lighting_mode 4e9c0f3c

2022-01-29 03:49:19

greebo

Details Diff
0005893: Code cleanup Affected Issues
0005893
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File

DarkRadiant: lighting_mode 50020cd2

2022-01-29 06:45:16

greebo

Details Diff
0005893: Introduce a new interface which allows a more general kind of renderables to be attached to IRenderEntities.
The common RenderableGeometry type now supports attaching itself to a render entity to be considered during lighting mode rendering.
Affected Issues
0005893
mod - include/irender.h Diff File
add - include/irenderableobject.h Diff File
mod - include/isurfacerenderer.h Diff File
mod - libs/render/RenderableBox.h Diff File
mod - libs/render/RenderableGeometry.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/model/NullModelNode.cpp Diff File
mod - radiantcore/model/RenderableModelSurface.h Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File
mod - radiantcore/rendersystem/LightingModeRenderResult.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File
mod - radiantcore/rendersystem/backend/SurfaceRenderer.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File
mod - tools/msvc/include.vcxproj Diff File
mod - tools/msvc/include.vcxproj.filters Diff File

DarkRadiant: lighting_mode 66113487

2022-01-29 16:36:49

greebo

Details Diff
0005893: Some initial code to implement a central vertex and index buffer used by the render system. Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
add - radiantcore/rendersystem/backend/GeometryStore.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode dd64e8e2

2022-01-29 18:02:01

greebo

Details Diff
0005893: Move buffer implementation to separate file. Affected Issues
0005893
add - libs/render/ContinuousBuffer.h Diff File
mod - radiantcore/rendersystem/backend/GeometryStore.h Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: lighting_mode 6a68cced

2022-01-30 04:26:39

greebo

Details Diff
0005893: Start writing unit tests checking buffer behaviour. Affected Issues
0005893
mod - libs/render/ContinuousBuffer.h Diff File
mod - test/CMakeLists.txt Diff File
add - test/ContinuousBuffer.cpp Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: lighting_mode 908f01f9

2022-01-30 05:22:32

greebo

Details Diff
0005893: Improve block merge algorithm, expand unit tests Affected Issues
0005893
mod - libs/render/ContinuousBuffer.h Diff File
mod - test/ContinuousBuffer.cpp Diff File

DarkRadiant: lighting_mode 47276ee9

2022-01-30 05:39:34

greebo

Details Diff
0005893: Recycle unused block descriptors Affected Issues
0005893
mod - libs/render/ContinuousBuffer.h Diff File

DarkRadiant: lighting_mode 50dcb0a2

2022-01-30 06:35:10

greebo

Details Diff
0005893: Working on connecting the geometry store to the renderable objects. Affected Issues
0005893
mod - include/igeometryrenderer.h Diff File
add - include/igeometrystore.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File
mod - radiantcore/rendersystem/backend/GeometryStore.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - tools/msvc/include.vcxproj Diff File
mod - tools/msvc/include.vcxproj.filters Diff File

DarkRadiant: lighting_mode 7cb1e038

2022-01-30 07:09:56

greebo

Details Diff
0005893: Ongoing work on connecting the geometry store to the renderable surfaces and geometry. Affected Issues
0005893
mod - include/igeometryrenderer.h Diff File
mod - include/irenderableobject.h Diff File
mod - include/isurfacerenderer.h Diff File
mod - libs/render/RenderableGeometry.h Diff File
mod - libs/render/RenderableSurface.h Diff File
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - radiantcore/rendersystem/backend/SurfaceRenderer.h Diff File

DarkRadiant: lighting_mode 444d1ebc

2022-01-30 08:05:26

greebo

Details Diff
0005893: Migrate GeometryRenderer to directly use the data stored in the backend Affected Issues
0005893
mod - include/igeometrystore.h Diff File
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File
mod - radiantcore/rendersystem/backend/GeometryStore.h Diff File

DarkRadiant: lighting_mode c15fc0c1

2022-01-30 08:12:59

greebo

Details Diff
0005893: GeometryRenderer cleanup Affected Issues
0005893
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File

DarkRadiant: lighting_mode 94c34b61

2022-01-30 08:27:29

greebo

Details Diff
0005893: Migrate SurfaceRenderer implementation to store the vertex data in the backend Affected Issues
0005893
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/SurfaceRenderer.h Diff File

DarkRadiant: lighting_mode 4de1d8f9

2022-01-30 09:10:05

greebo

Details Diff
0005893: Minor optimisation Affected Issues
0005893
mod - radiantcore/brush/RenderableWinding.h Diff File

DarkRadiant: lighting_mode 6c659d53

2022-01-30 17:31:24

greebo

Details Diff
0005893: Adjust model registration code, this is handled by the RenderableSurface Affected Issues
0005893
mod - radiantcore/model/NullModelNode.cpp Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File

DarkRadiant: lighting_mode e8b3e608

2022-01-30 17:32:16

greebo

Details Diff
0005893: Lighting mode renderer is using the vertex data in the GeometryStore Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File

DarkRadiant: lighting_mode eacb2eae

2022-01-30 17:42:15

greebo

Details Diff
0005893: Patches attach suitable geometry to the render entity, they are appearing in lit render mode now Affected Issues
0005893
mod - libs/render/RenderableGeometry.h Diff File
mod - radiantcore/patch/PatchNode.cpp Diff File

DarkRadiant: lighting_mode c0283851

2022-02-04 04:43:27

greebo

Details Diff
0005893: Don't attach empty model surfaces, the GeometryRenderer doesn't support this Affected Issues
0005893
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/model/md5/MD5ModelNode.cpp Diff File

DarkRadiant: lighting_mode 12b9959b

2022-02-04 04:44:02

greebo

Details Diff
0005893: Preserve patch tangent and bitangent vectors Affected Issues
0005893
mod - libs/render/ArbitraryMeshVertex.h Diff File
mod - radiantcore/patch/PatchRenderables.h Diff File

DarkRadiant: lighting_mode 9884ba48

2022-02-04 05:29:32

greebo

Details Diff
0005893: Clear entities and lights while modules are still alive.
This is most likely due to unclean removal of attached light entities when their host entities are removed from the scene, so this is a defensive step.
Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File

DarkRadiant: lighting_mode 0bf1d391

2022-02-04 06:03:12

greebo

Details Diff
0005893: Patch bounds were not known at the time the surface attached itself to the parent entity.
It's now possible to acquire the geometry bounds from the data in the GeometryStore.
Affected Issues
0005893
mod - include/igeometryrenderer.h Diff File
mod - include/igeometrystore.h Diff File
mod - libs/render/RenderableGeometry.h Diff File
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File
mod - radiantcore/rendersystem/backend/GeometryStore.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File

DarkRadiant: lighting_mode 9570138a

2022-02-06 06:10:52

greebo

Details Diff
0005893: Winding registration is taking a render entity reference now. The material's WindingRenderer should group the incoming windings by entity and register them, such that they can be picked up by the back end renderer when iterating through entities.
Not functional yet, this is WIP.
Affected Issues
0005893
mod - include/irender.h Diff File
mod - include/iwindingrenderer.h Diff File
mod - libs/render/RenderableGeometry.h Diff File
mod - libs/render/RenderableSurface.h Diff File
mod - libs/render/WindingRenderer.h Diff File
mod - radiantcore/brush/RenderableWinding.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/entity/RenderableObjectCollection.h Diff File
mod - radiantcore/rendersystem/backend/ColourShader.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File

DarkRadiant: lighting_mode 2d7ee74e

2022-02-06 10:02:01

greebo

Details Diff
0005893: All windings of a certain material are now combined into IRenderableObjects within the WindingRenderer.
The windings are indexed clockwise right now, which is wrong for surfaces.
Affected Issues
0005893
mod - libs/render/WindingRenderer.h Diff File

DarkRadiant: lighting_mode 3e813357

2022-02-06 10:17:56

greebo

Details Diff
0005893: Reverse winding index to match glFrontFace(GL_CW) Affected Issues
0005893
mod - libs/render/CompactWindingVertexBuffer.h Diff File
mod - libs/render/WindingRenderer.h Diff File
mod - test/WindingRendering.cpp Diff File

DarkRadiant: lighting_mode 2e896e38

2022-02-06 10:29:26

greebo

Details Diff
0005893: Preserve tangent and bitangent vectors when copying winding data to the buffers Affected Issues
0005893
mod - radiantcore/brush/RenderableWinding.h Diff File

DarkRadiant: lighting_mode afaf3b78

2022-02-06 10:30:00

greebo

Details Diff
0005893: Fix crash when closing the render preview. The RenderSystem should not be destroyed before the scene is disposed of. Affected Issues
0005893
mod - libs/wxutil/preview/RenderPreview.cpp Diff File

DarkRadiant: lighting_mode d6f6d96e

2022-02-06 10:52:27

greebo

Details Diff
0005893: Don't add empty geometries to the shader Affected Issues
0005893
mod - libs/render/RenderableGeometry.h Diff File

DarkRadiant: lighting_mode d143178c

2022-02-06 11:50:03

greebo

Details Diff
0005893: Fix an allocation problem after filling the continuous to the last byte Affected Issues
0005893
mod - libs/render/ContinuousBuffer.h Diff File
mod - test/ContinuousBuffer.cpp Diff File

DarkRadiant: lighting_mode 34ee5513

2022-02-06 16:15:08

greebo

Details Diff
0005893: Fix crash after resizing the client side buffers, seems like openGL is accessing the vertex data after the old buffer has gone out of business. Affected Issues
0005893
mod - libs/render/ContinuousBuffer.h Diff File

DarkRadiant: lighting_mode 41791126

2022-02-11 07:01:08

greebo

Details Diff
0005893: First implementation to switch buffers in between frames, separated by sync fences. Affected Issues
0005893
mod - include/irender.h Diff File
mod - libs/render/ContinuousBuffer.h Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - radiantcore/rendersystem/backend/GeometryStore.h Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File

DarkRadiant: lighting_mode 0dceee37

2022-02-11 15:03:50

greebo

Details Diff
0005893: Fix crash when displaying missing models in lighting mode Affected Issues
0005893
mod - radiantcore/rendersystem/backend/BuiltInShader.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File

DarkRadiant: lighting_mode 42abd0b5

2022-02-11 15:56:42

greebo

Details Diff
0005893: Cleanup round Affected Issues
0005893
mod - libs/render/ContinuousBuffer.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/GeometryStore.h Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File

DarkRadiant: lighting_mode d7e9a562

2022-02-12 05:10:27

greebo

Details Diff
0005893: Handle visibiltiy of attached entities. Move show/hide functions to scenelib.h Affected Issues
0005893
mod - libs/scenelib.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/selection/algorithm/General.cpp Diff File

DarkRadiant: lighting_mode 73025f38

2022-02-12 06:18:57

greebo

Details Diff
0005893: Add IEntityNode::foreachAttachment method and a basic unit test. Affected Issues
0005893
mod - include/ientity.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode 40d8492a

2022-02-12 06:24:58

greebo

Details Diff
0005893: Add test checking that attached lights are registering themselves with the render system Affected Issues
0005893
mod - test/Renderer.cpp Diff File

DarkRadiant: lighting_mode 74de9610

2022-02-12 06:33:01

greebo

Details Diff
0005893: Migrate and reactivate one unit test checking the child light position Affected Issues
0005893
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode 9b4adc64

2022-02-12 07:29:37

greebo

Details Diff
0005893: Move common code to RenderableCollectorBase. Migrate the RenderFixture and two unit tests. Affected Issues
0005893
mod - libs/render/CamRenderer.h Diff File
mod - libs/render/RenderableCollectorBase.h Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode c7e603e4

2022-02-13 04:33:59

greebo

Details Diff
0005893: Reactivate/migrate more unit test code Affected Issues
0005893
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode c4750350

2022-02-13 05:22:09

greebo

Details Diff
0005893: Reactivate/migrate more unit test code Affected Issues
0005893
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode2 eb000fcd

2022-02-13 05:50:51

greebo

Details Diff
0005893: Fix a signal timing problem when reloading entityDefs. We can't have the eclass changed signal fired in the middle of re-parsing all the files, since things like entity colours are not resolved at that point yet. Affected Issues
0005893
mod - radiantcore/eclass/EClassManager.cpp Diff File

DarkRadiant: lighting_mode2 a01caa9d

2022-02-13 08:19:13

greebo

Details Diff
0005893: Fix vertex attribute GL state leak, causing textures to be messed when switching back to fullbright mode Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File

DarkRadiant: lighting_mode2 7ca88d9e

2022-02-13 08:34:04

greebo

Details Diff
0005893: Disconnect the old lighting mode infrastructure in the CamRenderer. Affected Issues
0005893
mod - include/irenderable.h Diff File
mod - libs/render/CamRenderer.h Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/render/RenderStatistics.h Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode2 45483904

2022-02-13 08:36:43

greebo

Details Diff
0005893: Remove now unused VectorLightList class Affected Issues
0005893
mod - libs/render/CamRenderer.h Diff File
rm - libs/render/VectorLightList.h Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiantcore/brush/FaceInstance.h Diff File
mod - radiantcore/model/StaticModelNode.h Diff File
mod - radiantcore/model/md5/MD5ModelNode.h Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: lighting_mode2 612eda22

2022-02-13 08:48:20

greebo

Details Diff
0005893: Remove LightSources interface Affected Issues
0005893
mod - include/irender.h Diff File
mod - include/irenderable.h Diff File
mod - libs/render/CamRenderer.h Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File

DarkRadiant: lighting_mode2 28d79592

2022-02-13 09:01:57

greebo

Details Diff
0005893: Remove LitObject interface Affected Issues
0005893
mod - include/irender.h Diff File
mod - include/irenderable.h Diff File
mod - libs/render/CamRenderer.h Diff File
mod - libs/scene/Node.cpp Diff File
mod - libs/scene/Node.h Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode2 34cd699d

2022-02-13 09:12:22

greebo

Details Diff
0005893: Remove the regular IRenderableCollector::addRenderable method, since nothing was using it anymore.
Except for the MeasurementTool which is broken by this commit.
Affected Issues
0005893
mod - include/irenderable.h Diff File
mod - libs/render/CamRenderer.h Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - radiant/xyview/tools/MeasurementTool.cpp Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode2 cedc797f

2022-02-13 10:45:26

greebo

Details Diff
0005893: Migrate the MeasurementTool to use a RenderableGeometry subtype Affected Issues
0005893
add - libs/render/RenderableVertexArray.h Diff File
mod - radiant/xyview/tools/MeasurementTool.cpp Diff File
mod - radiant/xyview/tools/MeasurementTool.h Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: lighting_mode2 2723f4c0

2022-02-13 11:38:33

greebo

Details Diff
0005893: Migrate text rendering in the MeasurementTool Affected Issues
0005893
mod - radiant/xyview/tools/MeasurementTool.cpp Diff File
mod - radiant/xyview/tools/MeasurementTool.h Diff File

DarkRadiant: lighting_mode2 f663ced2

2022-02-13 13:41:02

greebo

Details Diff
0005893: Remove IRenderableCollector::processRenderable method Affected Issues
0005893
mod - include/irenderable.h Diff File
mod - libs/render/RenderableCollectionWalker.h Diff File
mod - libs/render/RenderableCollectorBase.h Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: lighting_mode2 b2c2f3a9

2022-02-13 18:04:34

greebo

Details Diff
0005893: Minimise the amount of memory copied between the frame buffers by replaying just the changes that have been occurring during the previous frame. Affected Issues
0005893
mod - include/igeometrystore.h Diff File
mod - libs/render/ContinuousBuffer.h Diff File
mod - radiantcore/rendersystem/backend/GeometryStore.h Diff File

DarkRadiant: lighting_mode2 62585222

2022-02-13 19:16:06

greebo

Details Diff
0005893: Attempt to fix gcc compilation Affected Issues
0005893
mod - libs/render/RenderableVertexArray.h Diff File

DarkRadiant: lighting_mode2 c437301d

2022-02-18 13:12:28

greebo

Details Diff
0005893: Start setting up the shader program rendering cameraCubeMap stages.
Use an enum to acquire a built-in GLSL program.
Affected Issues
0005893
add - install/gl/cubemap_fp.glsl Diff File
add - install/gl/cubemap_vp.glsl Diff File
mod - radiantcore/CMakeLists.txt Diff File
mod - radiantcore/rendersystem/backend/DepthFillPass.cpp Diff File
mod - radiantcore/rendersystem/backend/GLProgramFactory.cpp Diff File
mod - radiantcore/rendersystem/backend/GLProgramFactory.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
add - radiantcore/rendersystem/backend/glprogram/GLSLCubeMapProgram.cpp Diff File
add - radiantcore/rendersystem/backend/glprogram/GLSLCubeMapProgram.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode2 22b34e10

2022-02-19 04:22:13

greebo

Details Diff
0005893: WIP commit, creating the cube map shader, some refactoring Affected Issues
0005893
mod - include/GLProgramAttributes.h Diff File
mod - install/gl/cubemap_fp.glsl Diff File
mod - install/gl/cubemap_vp.glsl Diff File
mod - libs/render/WindingRenderer.h Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/GeometryRenderer.h Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/SurfaceRenderer.h Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLBumpProgram.cpp Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLCubeMapProgram.cpp Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLCubeMapProgram.h Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLDepthFillAlphaProgram.cpp Diff File

DarkRadiant: lighting_mode2 58aa2137

2022-02-19 06:06:15

greebo

Details Diff
0005893: Basic cube map rendering is working now. The texture transformation applied in the OpenGLShaderPass has been moved to the shader. Affected Issues
0005893
mod - install/gl/cubemap_fp.glsl Diff File
mod - install/gl/cubemap_vp.glsl Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLCubeMapProgram.cpp Diff File

DarkRadiant: lighting_mode2 da6adb26

2022-02-19 06:18:02

greebo

Details Diff
0005893: Code cleanup Affected Issues
0005893
mod - install/gl/cubemap_fp.glsl Diff File
mod - install/gl/cubemap_vp.glsl Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.h Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLCubeMapProgram.cpp Diff File

DarkRadiant: lighting_mode2 b73af9b8

2022-02-19 08:03:32

greebo

Details Diff
0005893: Remove unused IRenderEntity* parameter from Shader::addRenderable. Affected Issues
0005893
mod - include/irender.h Diff File
mod - libs/render/CamRenderer.h Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.h Diff File

DarkRadiant: lighting_mode2 95d16e35

2022-02-19 08:17:32

greebo

Details Diff
0005893: Remove RendererLight parameter from OpenGLShaderPass::addRenderable Affected Issues
0005893
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.h Diff File

DarkRadiant: lighting_mode2 6a2149a9

2022-02-19 08:54:50

greebo

Details Diff
0005893: Restrict LightInteractions rendering to those stages that feature a lighting (DBS) pass Affected Issues
0005893
mod - radiantcore/CMakeLists.txt Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
add - radiantcore/rendersystem/backend/InteractionPass.cpp Diff File
add - radiantcore/rendersystem/backend/InteractionPass.h Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode2 fe94f37e

2022-02-19 14:15:23

greebo

Details Diff
0005893: Extend IRenderEntity interface to enumerate renderables without bounds check Affected Issues
0005893
mod - include/irender.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - radiantcore/entity/RenderableObjectCollection.h Diff File

DarkRadiant: lighting_mode2 d3c1f1d0

2022-02-20 04:58:12

greebo

Details Diff
0005893: Add third render pass drawing the non-interaction stages Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.h Diff File

DarkRadiant: lighting_mode2 27c5d59f

2022-02-20 05:54:04

greebo

Details Diff
0005893: Comparing to the TDM engine, the skybox appears to be rotated - compensate that in the shader Affected Issues
0005893
mod - install/gl/cubemap_vp.glsl Diff File

DarkRadiant: lighting_mode2 245e7def

2022-02-20 06:29:07

greebo

Details Diff
0005893: TDM is using 90 degrees FOV with wide-screen correction. DR doesn't have that correction yet, but let's use 90 degrees to have the same sense of scale. Affected Issues
0005893
mod - radiantcore/camera/Camera.cpp Diff File

DarkRadiant: lighting_mode2 ecab2d9a

2022-02-20 12:48:31

greebo

Details Diff
0005893: Fix an intelligence fail Affected Issues
0005893
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File

DarkRadiant: lighting_mode2 543b249d

2022-02-20 17:31:24

greebo

Details Diff
0005893: ParticleNodes attach their renderables to the owning entity. Not working yet, since we only have Quad primitives in the renderable particle bunches. Affected Issues
0005893
mod - include/iparticles.h Diff File
mod - libs/wxutil/preview/ParticlePreview.cpp Diff File
mod - radiantcore/particles/ParticleNode.cpp Diff File
mod - radiantcore/particles/ParticleNode.h Diff File
mod - radiantcore/particles/RenderableParticle.cpp Diff File
mod - radiantcore/particles/RenderableParticle.h Diff File

DarkRadiant: lighting_mode2 a16ef9a1

2022-02-25 07:02:33

greebo

Details Diff
0005893: Use triangulated geometry to render particles Affected Issues
0005893
mod - radiantcore/particles/ParticleNode.cpp Diff File
mod - radiantcore/particles/RenderableParticleBunch.cpp Diff File
mod - radiantcore/particles/RenderableParticleBunch.h Diff File
mod - radiantcore/particles/RenderableParticleStage.cpp Diff File

DarkRadiant: lighting_mode2 0475759d

2022-02-25 07:03:05

greebo

Details Diff
0005893: Particle rendering is working in lighting mode again. Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLBumpProgram.cpp Diff File

DarkRadiant: lighting_mode2 d115fd19

2022-02-25 08:56:20

greebo

Details Diff
0005893: Materials qualified as Translucent should not write to the depth buffer. Affected Issues
0005893
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File

DarkRadiant: lighting_mode2 24410858

2022-02-25 09:03:45

greebo

Details Diff
0005893: Move algorithm to issue draw calls to helper class Affected Issues
0005893
mod - radiantcore/CMakeLists.txt Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File
add - radiantcore/rendersystem/backend/ObjectRenderer.cpp Diff File
add - radiantcore/rendersystem/backend/ObjectRenderer.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: lighting_mode2 b4e641e2

2022-02-25 10:29:47

greebo

Details Diff
0005893: Move all renderer algorithm from OpenGLRenderSystem to separate SceneRenderer implementations, one for Lighting Mode, one for FullBright Mode. Affected Issues
0005893
mod - include/irender.h Diff File
add - libs/render/NopRenderView.h Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - libs/wxutil/preview/RenderPreview.h Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - radiantcore/CMakeLists.txt Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
add - radiantcore/rendersystem/backend/FullBrightRenderer.cpp Diff File
add - radiantcore/rendersystem/backend/FullBrightRenderer.h Diff File
add - radiantcore/rendersystem/backend/LightingModeRenderer.cpp Diff File
add - radiantcore/rendersystem/backend/LightingModeRenderer.h Diff File
add - radiantcore/rendersystem/backend/SceneRenderer.cpp Diff File
add - radiantcore/rendersystem/backend/SceneRenderer.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: lighting_mode2 c57316d3

2022-02-25 10:52:08

greebo

Details Diff
0005893: Refactoring Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/backend/FullBrightRenderer.cpp Diff File
mod - radiantcore/rendersystem/backend/FullBrightRenderer.h Diff File
mod - radiantcore/rendersystem/backend/LightingModeRenderer.cpp Diff File
mod - radiantcore/rendersystem/backend/LightingModeRenderer.h Diff File
mod - radiantcore/rendersystem/backend/SceneRenderer.cpp Diff File
mod - radiantcore/rendersystem/backend/SceneRenderer.h Diff File

DarkRadiant: lighting_mode2 62c5f605

2022-02-25 11:02:18

greebo

Details Diff
0005893: Harmonise the render return types, both renderer implementations return a result object now Affected Issues
0005893
mod - include/irender.h Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/xyview/XYRenderer.h Diff File
mod - radiant/xyview/XYWnd.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - radiantcore/rendersystem/backend/FullBrightRenderer.cpp Diff File
mod - radiantcore/rendersystem/backend/FullBrightRenderer.h Diff File
mod - radiantcore/rendersystem/backend/LightingModeRenderer.h Diff File

DarkRadiant: lighting_mode2 ad8119ae

2022-02-25 11:13:17

greebo

Details Diff
0005893: Pre-construct the renderers and pick the right one based on the client's request Affected Issues
0005893
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.h Diff File
mod - radiantcore/rendersystem/backend/FullBrightRenderer.h Diff File
mod - radiantcore/rendersystem/backend/LightingModeRenderer.h Diff File
mod - radiantcore/rendersystem/backend/SceneRenderer.h Diff File

DarkRadiant: lighting_mode2 1df0c022

2022-02-25 11:36:20

greebo

Details Diff
0005893: Fix brush selection outlines not being updated in ortho view after grid snapping Affected Issues
0005893
mod - radiantcore/brush/BrushNode.cpp Diff File

DarkRadiant: master a067d34b

2022-02-25 13:23:18

greebo

Details Diff
0005893: Reduce state changes a bit Affected Issues
0005893
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightingModeRenderer.cpp Diff File
mod - radiantcore/rendersystem/backend/ObjectRenderer.cpp Diff File
mod - radiantcore/rendersystem/backend/SceneRenderer.cpp Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLBumpProgram.cpp Diff File

DarkRadiant: master 916cc082

2022-02-25 13:45:17

greebo

Details Diff
0005893: Remove unused locals Affected Issues
0005893
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightingModeRenderer.cpp Diff File

DarkRadiant: master b4d0de21

2022-02-26 04:37:45

greebo

Details Diff
0005893: Fix faces not updating their visuals after fitting their texture. Affected Issues
0005893
mod - radiantcore/brush/BrushNode.cpp Diff File
mod - radiantcore/brush/Face.cpp Diff File
mod - radiantcore/brush/Face.h Diff File

Issue History

Date Modified Username Field Change
26.01.2022 10:44 greebo New Issue
26.01.2022 10:44 greebo Relationship added related to 0005584
26.01.2022 10:44 greebo Assigned To => greebo
26.01.2022 10:44 greebo Status new => assigned
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode 25e7ecd0
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode 21c10aee
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode a320e519
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode c69690b2
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode c613673c
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode 6822fccc
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode c1996a67
27.01.2022 05:42 greebo Changeset attached => DarkRadiant lighting_mode da0a46fb
27.01.2022 13:49 greebo Changeset attached => DarkRadiant lighting_mode 8f56350d
27.01.2022 13:49 greebo Changeset attached => DarkRadiant lighting_mode 6bc219f9
27.01.2022 13:49 greebo Changeset attached => DarkRadiant lighting_mode 2e61d96a
27.01.2022 13:49 greebo Changeset attached => DarkRadiant lighting_mode df10ec64
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 328e9bc2
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 58bf5046
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 9f0439ca
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode c1517112
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 58e11221
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 71b3f66e
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 30edbc69
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 652a3147
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 8ca921bb
29.01.2022 03:49 greebo Changeset attached => DarkRadiant lighting_mode 03bcfaee
29.01.2022 03:50 greebo Changeset attached => DarkRadiant lighting_mode 51305f1d
29.01.2022 03:50 greebo Changeset attached => DarkRadiant lighting_mode a249291c
29.01.2022 03:50 greebo Changeset attached => DarkRadiant lighting_mode 4e9c0f3c
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 50020cd2
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 66113487
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode dd64e8e2
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 6a68cced
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 908f01f9
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 47276ee9
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 50dcb0a2
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 7cb1e038
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 444d1ebc
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode c15fc0c1
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 94c34b61
30.01.2022 09:10 greebo Changeset attached => DarkRadiant lighting_mode 4de1d8f9
30.01.2022 17:43 greebo Changeset attached => DarkRadiant lighting_mode 6c659d53
30.01.2022 17:43 greebo Changeset attached => DarkRadiant lighting_mode e8b3e608
30.01.2022 17:43 greebo Changeset attached => DarkRadiant lighting_mode eacb2eae
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode c0283851
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode 12b9959b
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode 9884ba48
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode 0bf1d391
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode 9570138a
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode 2d7ee74e
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode 3e813357
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode 2e896e38
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode afaf3b78
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode d6f6d96e
06.02.2022 11:59 greebo Changeset attached => DarkRadiant lighting_mode d143178c
12.02.2022 05:10 greebo Changeset attached => DarkRadiant lighting_mode 34ee5513
12.02.2022 05:10 greebo Changeset attached => DarkRadiant lighting_mode 41791126
12.02.2022 05:10 greebo Changeset attached => DarkRadiant lighting_mode 0dceee37
12.02.2022 05:10 greebo Changeset attached => DarkRadiant lighting_mode 42abd0b5
12.02.2022 05:10 greebo Changeset attached => DarkRadiant lighting_mode d7e9a562
13.02.2022 05:26 greebo Changeset attached => DarkRadiant lighting_mode 73025f38
13.02.2022 05:26 greebo Changeset attached => DarkRadiant lighting_mode 40d8492a
13.02.2022 05:26 greebo Changeset attached => DarkRadiant lighting_mode 74de9610
13.02.2022 05:26 greebo Changeset attached => DarkRadiant lighting_mode 9b4adc64
13.02.2022 05:26 greebo Changeset attached => DarkRadiant lighting_mode c7e603e4
13.02.2022 05:26 greebo Changeset attached => DarkRadiant lighting_mode c4750350
13.02.2022 06:45 greebo Changeset attached => DarkRadiant lighting_mode2 eb000fcd
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 a01caa9d
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 7ca88d9e
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 45483904
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 612eda22
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 28d79592
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 34cd699d
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 cedc797f
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 2723f4c0
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 f663ced2
13.02.2022 18:05 greebo Changeset attached => DarkRadiant lighting_mode2 b2c2f3a9
13.02.2022 19:16 greebo Changeset attached => DarkRadiant lighting_mode2 62585222
19.02.2022 06:18 greebo Changeset attached => DarkRadiant lighting_mode2 c437301d
19.02.2022 06:18 greebo Changeset attached => DarkRadiant lighting_mode2 22b34e10
19.02.2022 06:18 greebo Changeset attached => DarkRadiant lighting_mode2 58aa2137
19.02.2022 06:18 greebo Changeset attached => DarkRadiant lighting_mode2 da6adb26
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 b73af9b8
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 95d16e35
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 6a2149a9
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 fe94f37e
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 d3c1f1d0
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 27c5d59f
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 245e7def
20.02.2022 13:10 greebo Changeset attached => DarkRadiant lighting_mode2 ecab2d9a
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 543b249d
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 a16ef9a1
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 0475759d
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 d115fd19
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 24410858
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 b4e641e2
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 c57316d3
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 62c5f605
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 ad8119ae
25.02.2022 11:42 greebo Changeset attached => DarkRadiant lighting_mode2 1df0c022
25.02.2022 12:33 greebo Status assigned => resolved
25.02.2022 12:33 greebo Resolution open => fixed
25.02.2022 12:33 greebo Fixed in Version => 3.0.0
25.02.2022 12:34 greebo Target Version => 3.0.0
25.02.2022 13:45 greebo Changeset attached => DarkRadiant master a067d34b
25.02.2022 13:45 greebo Changeset attached => DarkRadiant master 916cc082
26.02.2022 04:41 greebo Changeset attached => DarkRadiant master b4d0de21
01.03.2022 12:31 greebo Relationship added related to 0005908
02.04.2022 05:22 greebo Relationship added related to 0005582