View Issue Details

IDProjectCategoryView StatusLast Update
0000590DarkRadiantSelection Systempublic05.02.2021 13:17
ReporterKomag Assigned To 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionduplicate 
Product Version0.9.5 
Summary0000590: Would like to add filters for "Portal Sky" and "No Draw Solid". Also, would like a "favourites" setting, and an "Inverse"
Description(I think "Selection System" sound like this...)

I like the filters available and would like to see added two more - "Portal Sky" and "No Draw Solid".

Also, Fidcal had a good idea of a custom "Favourites" filter which turns on all the ones a person has pre-selected.

Also, I would really like an "Inverse" setting, so I can select, say, Caulk, and then select the inverse so that everything BUT Caulk is filtered.
TagsNo tags attached.

Relationships

related to 0005524 resolvedgreebo Add portal_sky filter to default filters 
related to 0005525 new Toggle multiple filters at once 

Activities

Dragofer

Dragofer

30.01.2021 08:57

developer   ~0013575

Last edited: 30.01.2021 09:06

View 4 revisions

It crossed my mind a few times to open a ticket for these 2 filters. Every mapper should have a portal_sky filter which is probably almost as important as a caulk filter. A nodrawsolid filter would allow to filter just that, without simultaneously hiding invisible nodraw entities (i.e func_pendulum for lamps).

Not so sure about the 2nd one, maybe DR didn't remember filter settings back then? Though some kind of pre-made combination for making maps visually navigable (collision + clip + caulk + portal_sky + shadow + visportals + nodraw) with a one-click solution would be convenient. Sometimes I have to deselect all filters, i.e. because I want to move a map section, and its a lot of clicks to turn them all back on individually.

The 3rd feature is, good to say, already implemented.
greebo

greebo

05.02.2021 11:08

administrator   ~0013647

A favourite filter group should be possible just by combining all the individual filter rules into one set. Not sure if a separate feature is necessary to do that. Same goes for the inverse filter, the rules just need to be specified by the mapper, which is admittedly a bit of work.

If the portal_sky filter is wanted, then I can add such an entry to the factory set - just let me know.
greebo

greebo

05.02.2021 11:13

administrator   ~0013648

Just on a related note, this issue is a good example of a "package deal issue". It's describing three feature requests all in one entry, which increases its "toughness" both to assign and resolve - the portal_sky filter would probably have been added to the factory set long ago if it had been requested separately, this way it's sitting around tied to the other two (much larger) feature requests.
Dragofer

Dragofer

05.02.2021 13:07

developer   ~0013649

Last edited: 05.02.2021 13:16

View 2 revisions

Splitting up this ticket was actually on my mind, just a question of getting around to it.

In my opinion the "hide everything but the filter" request is more than adequately covered by "select by filter" & "deselect by filter", so I wouldn't open a new ticket for that item.

Issue History

Date Modified Username Field Change
29.02.2008 00:10 Komag New Issue
03.03.2008 09:55 greebo Status new => confirmed
30.01.2021 08:57 Dragofer Note Added: 0013575
30.01.2021 09:00 Dragofer Note Edited: 0013575 View Revisions
30.01.2021 09:04 Dragofer Note Edited: 0013575 View Revisions
30.01.2021 09:06 Dragofer Note Edited: 0013575 View Revisions
05.02.2021 11:08 greebo Note Added: 0013647
05.02.2021 11:13 greebo Note Added: 0013648
05.02.2021 13:07 Dragofer Note Added: 0013649
05.02.2021 13:11 Dragofer Relationship added related to 0005524
05.02.2021 13:16 Dragofer Note Edited: 0013649 View Revisions
05.02.2021 13:16 Dragofer Relationship added related to 0005525
05.02.2021 13:17 Dragofer Status confirmed => closed
05.02.2021 13:17 Dragofer Resolution open => duplicate