View Issue Details

IDProjectCategoryView StatusLast Update
0005905DarkRadiantSaving and loadingpublic03.04.2022 19:54
ReporterGeep Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.14.0 
Target Version3.0.0Fixed in Version3.0.0 
Summary0005905: Feature Request: Safeguard against Loss of Layering
DescriptionProblem:
Occasionally, it is necessary to manually rename a .map and .darkradiant file. If you overlook or make a typo in the latter, and then do subsequent editing (typically over many sessions before you realize the problem), your layering/grouping is irrevocably lost/corrupted.

Proposed Solution:
When DR is asked to open an existing .map or project (i.e., not a new one), if it doesn't find the corresponding .darkradiant file, it will immediately notify you, e.g.:

"No existing file named <same as map>.darkradiant found. A new one will be created, with no DR Groups and only a Default Layer." [OK]

After which you can take appropriate corrective action, e.g., exit the session without saving, and jigger the old .darkradiant file.

Steps To ReproduceWhen you use DR to open a project .map file, if it doesn't find a corresponding .darkradiant file, it quietly creates a new one. And then you go on, blissfully ignorant, editing away, until at some point you need your layers and find them all gone except Default. And if you try to use (with renaming) the last real .darkradiant file, everything is scrambled beyond hope due to node changes.
Additional InformationThis is the second time I've made this mistake over the years. This time, I've now thoroughly ruined my layering, elaborately constructed over the course of 2021. And too much editing has occurred to rollback to where .darkradiant was last meaningful. Aargh.

The proposed solution doesn't fix that, only would prevent it from happening again to me or anyone else. (I can certainly imagine a complicated repair algorithm, but forgetaboutit.)

The solution would also have to be compatible with autosave files.
TagsNo tags attached.

Activities

Geep

Geep

03.04.2022 19:54

reporter   ~0014794

Testing notes under DR 3.0.0 pre 1: For project testDR3preview, I renamed the testDR3preview.darkradiant to testDR3previewBAD.darkradiant. Then on loading the map, saw the popup:

Title: Missing .darkradiant File
[warning symbol] No existing file named testDR3preview.darkradiant found, could not load any group or layer information. A new info file will be created the next time the map is saved. [OK]

Does the job to alert about a problem. The process keeps it simple, too; it doesn't also look for testDR3preview.darkradiant.bak or testDR3preview_autosave.darkradiant. That's better left to the mapper to decide cleanup.

Related Changesets

DarkRadiant: master e0e03b2b

2022-04-03 04:49:54

greebo

Details Diff
0005905: Emit a warning when DR fails to locate the info file on map load Affected Issues
0005905
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - test/MapSavingLoading.cpp Diff File

Issue History

Date Modified Username Field Change
13.02.2022 23:06 Geep New Issue
13.02.2022 23:14 Geep Additional Information Updated
02.03.2022 17:49 greebo Status new => acknowledged
03.04.2022 04:50 greebo Target Version => 3.0.0
03.04.2022 04:50 greebo Assigned To => greebo
03.04.2022 04:50 greebo Status acknowledged => assigned
03.04.2022 04:50 greebo Changeset attached => DarkRadiant master e0e03b2b
03.04.2022 04:50 greebo Status assigned => resolved
03.04.2022 04:50 greebo Resolution open => fixed
03.04.2022 04:50 greebo Fixed in Version => 3.0.0
03.04.2022 19:54 Geep Note Added: 0014794