View Issue Details

IDProjectCategoryView StatusLast Update
0005919DarkRadiantSaving and loadingpublic27.03.2022 13:15
ReporterVanishedOne Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
OSLinux 
Product Version2.14.0 
Target Version3.0.0Fixed in Version3.0.0 
Summary0005919: Crash on loading certain maps
DescriptionI have a couple of maps that were functional in the versions last used to work on them but crash the current DR when loaded. One is the map file for In The Black; I've linked a core dump for the other one.
Additional InformationLink to core dump: http://rfjseddon.net/ext/core.darkradiant.1000.8ce1846158a743cbadf609098ab722b5.108928.1646799630000000000000.lz4

I've given 2.14 as the DR version, but actually I built DR yesterday using the compilation instructions, so I think it's from trunk.
TagsNo tags attached.

Activities

greebo

greebo

27.03.2022 11:54

administrator   ~0014782

I can confirm that loading In the Black will result in an exception being logged to darkradiant.log:
Unhandled Exception: Cannot attach geometry without any shader

Related Changesets

DarkRadiant: master 1dc59bfe

2022-03-27 12:24:40

greebo

Details Diff
0005919: Fix crash when updating particle geometry.
Updating a RenderableGeometry instance with an empty set of vertices will clear the structure, including its shader.
Affected Issues
0005919
mod - libs/render/RenderableGeometry.h Diff File
mod - radiantcore/particles/RenderableParticle.cpp Diff File
mod - radiantcore/particles/RenderableParticleStage.cpp Diff File
mod - radiantcore/particles/RenderableParticleStage.h Diff File

DarkRadiant: master c5deae25

2022-03-27 12:45:07

greebo

Details Diff
0005919: Fix a crash due to a problem in the destruction order of EntityNodes.
Any child nodes handled by the ModelKey member might still want to communicate with their parent entity in their destructor, so let's shutdown the ModelKey and attachment list before the EntityNode goes defunct.
Affected Issues
0005919
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/ModelKey.cpp Diff File
mod - radiantcore/entity/ModelKey.h Diff File

Issue History

Date Modified Username Field Change
09.03.2022 13:08 VanishedOne New Issue
27.03.2022 11:38 greebo Status new => acknowledged
27.03.2022 11:53 greebo Status acknowledged => confirmed
27.03.2022 11:54 greebo Note Added: 0014782
27.03.2022 11:54 greebo Assigned To => greebo
27.03.2022 11:54 greebo Status confirmed => assigned
27.03.2022 11:54 greebo Target Version => 3.0.0
27.03.2022 13:14 greebo Changeset attached => DarkRadiant master 1dc59bfe
27.03.2022 13:14 greebo Changeset attached => DarkRadiant master c5deae25
27.03.2022 13:15 greebo Status assigned => resolved
27.03.2022 13:15 greebo Resolution open => fixed
27.03.2022 13:15 greebo Fixed in Version => 3.0.0