View Issue Details

IDProjectCategoryView StatusLast Update
0005923DarkRadiantRendererpublic19.03.2022 06:00
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.0 
Fixed in Version3.0.0 
Summary0005923: TargetLineNodes are updating their geometry every frame
DescriptionIn a medium-sized maps this can lead to hundreds of tiny geometry updates that are needlessly spamming the GeometryStore.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 3f42ccde

2022-03-19 04:20:27

greebo

Details Diff
0005923: RenderableTargetLines are no longer updating all of their geometry on every frame. Affected Issues
0005923
mod - include/ientity.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/target/RenderableTargetLines.h Diff File
mod - radiantcore/entity/target/Target.h Diff File
mod - radiantcore/entity/target/TargetKey.cpp Diff File
mod - radiantcore/entity/target/TargetKey.h Diff File
mod - radiantcore/entity/target/TargetKeyCollection.cpp Diff File
mod - radiantcore/entity/target/TargetKeyCollection.h Diff File
mod - radiantcore/entity/target/TargetLineNode.cpp Diff File
mod - radiantcore/entity/target/TargetLineNode.h Diff File
mod - radiantcore/entity/target/TargetManager.cpp Diff File
mod - radiantcore/entity/target/TargetManager.h Diff File
mod - radiantcore/entity/target/TargetableNode.cpp Diff File
mod - radiantcore/entity/target/TargetableNode.h Diff File

DarkRadiant: master 416c1ff1

2022-03-19 04:44:53

greebo

Details Diff
0005923: Handle visibility changes of targetable nodes Affected Issues
0005923
mod - include/ientity.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/target/Target.h Diff File
mod - radiantcore/entity/target/TargetKey.cpp Diff File
mod - radiantcore/entity/target/TargetManager.cpp Diff File
mod - radiantcore/entity/target/TargetManager.h Diff File
mod - radiantcore/entity/target/TargetableNode.cpp Diff File
mod - radiantcore/entity/target/TargetableNode.h Diff File

DarkRadiant: master 9f9ca84f

2022-03-19 05:12:48

greebo

Details Diff
0005923: Handle position updates in StaticGeometryNodes, such that other nodes targeting the StaticGeometryNode can update their target lines Affected Issues
0005923
mod - radiantcore/entity/doom3group/StaticGeometryNode.cpp Diff File

DarkRadiant: master afe33a29

2022-03-19 05:52:04

greebo

Details Diff
0005923: Add object bounds culling to LightingModeRenderer. Since no shadows are involved yet, it is safe to assume that objects outside the view frustum are not contributing to the scene. Affected Issues
0005923
mod - radiantcore/rendersystem/backend/LightInteractions.cpp Diff File
mod - radiantcore/rendersystem/backend/LightInteractions.h Diff File
mod - radiantcore/rendersystem/backend/LightingModeRenderer.cpp Diff File

Issue History

Date Modified Username Field Change
19.03.2022 04:45 greebo New Issue
19.03.2022 04:45 greebo Assigned To => greebo
19.03.2022 04:45 greebo Status new => assigned
19.03.2022 06:00 greebo Changeset attached => DarkRadiant master 3f42ccde
19.03.2022 06:00 greebo Changeset attached => DarkRadiant master 416c1ff1
19.03.2022 06:00 greebo Changeset attached => DarkRadiant master 9f9ca84f
19.03.2022 06:00 greebo Changeset attached => DarkRadiant master afe33a29
19.03.2022 06:00 greebo Status assigned => resolved
19.03.2022 06:00 greebo Resolution open => fixed
19.03.2022 06:00 greebo Fixed in Version => 3.0.0