View Issue Details

IDProjectCategoryView StatusLast Update
0005982DarkRadiantGUIpublic18.06.2022 05:28
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.1.0Fixed in Version3.1.0 
Summary0005982: Modifier Hint Popup can crash when hitting Ctrl/Alt/Shift keys during shutdown
DescriptionAt some point during shutdown the GlobalMainFrame().getWxTopLevelWindow() is returning nullptr, leading to a crash in the MouseToolManager::updateStatusbar method, since the GlobalKeyEventFilter has not been disconnected yet.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master f5f9ab1f

2022-06-18 05:27:59

greebo

Details Diff
0005982: Fix ModifierHintPopup crash at shutdown when mainframe window has been destroyed already Affected Issues
0005982
mod - radiant/eventmanager/MouseToolManager.cpp Diff File

Issue History

Date Modified Username Field Change
18.06.2022 05:27 greebo New Issue
18.06.2022 05:27 greebo Assigned To => greebo
18.06.2022 05:27 greebo Status new => assigned
18.06.2022 05:28 greebo Changeset attached => DarkRadiant master f5f9ab1f
18.06.2022 05:28 greebo Status assigned => resolved
18.06.2022 05:28 greebo Resolution open => fixed
18.06.2022 05:28 greebo Fixed in Version => 3.1.0